summaryrefslogtreecommitdiff
path: root/sysutils/nautilus-cd-burner/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/nautilus-cd-burner/Makefile')
-rw-r--r--sysutils/nautilus-cd-burner/Makefile26
1 files changed, 21 insertions, 5 deletions
diff --git a/sysutils/nautilus-cd-burner/Makefile b/sysutils/nautilus-cd-burner/Makefile
index f2f68f798864..715870d6a315 100644
--- a/sysutils/nautilus-cd-burner/Makefile
+++ b/sysutils/nautilus-cd-burner/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= nautilus-cd-burner
-PORTVERSION= 0.5.3
-PORTREVISION= 7
+PORTVERSION= 2.6.0
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.5
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.6
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -21,14 +20,31 @@ RUN_DEPENDS= mkisofs:${PORTSDIR}/sysutils/mkisofs \
USE_BZIP2= yes
USE_X_PREFIX= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
GNOME_DESKTOP_VERSION=2
-USE_GNOME= gnomeprefix gnomehack nautilus2
+USE_GNOME= gnomeprefix gnomehack intlhack lthack nautilus2
USE_LIBTOOL_VER=13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/growisofs)
+WITH_DVD= yes
+.endif
+
+.if defined(WITH_DVD)
+RUN_DEPENDS+= growisofs:${PORTSDIR}/sysutils/dvd+rw-tools
+.endif
+
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "${PORTNAME} has the following configurable option(s):"
+ @${ECHO_MSG} " WITH_DVD Enable DVD burning support"
+ @${ECHO_MSG} ""
+
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>