summaryrefslogtreecommitdiff
path: root/net/openbgpd7/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/openbgpd7/Makefile')
-rw-r--r--net/openbgpd7/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/net/openbgpd7/Makefile b/net/openbgpd7/Makefile
new file mode 100644
index 000000000000..ab185ed51b77
--- /dev/null
+++ b/net/openbgpd7/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= openbgpd
+PORTVERSION= 7.2
+CATEGORIES= net
+MASTER_SITES= OPENBSD/OpenBGPD
+PKGNAMESUFFIX= 7
+
+MAINTAINER= href@random.sh
+COMMENT= Free implementation of the Border Gateway Protocol, Version 7
+
+LICENSE= ISCL
+LICENSE_FILE= ${FILESDIR}/COPYING
+
+USES= autoreconf libtool uidfix
+USE_RC_SUBR= ${PORTNAME}
+
+GNU_CONFIGURE= yes
+
+SUB_FILES= pkg-message
+
+USERS= _bgpd
+GROUPS= _bgpd
+
+CONFLICTS= zebra quagga
+
+OPTIONS_DEFINE= IPV6LLPEER
+OPTIONS_DEFAULT= IPV6LLPEER
+IPV6LLPEER_DESC= Support nexthop using IPv6 link-local address
+IPV6LLPEER_MAKE_ARGS= -DIPV6_LINKLOCAL_PEER
+
+.include <bsd.port.mk>