summaryrefslogtreecommitdiff
path: root/games/redeclipse-data16/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/redeclipse-data16/Makefile')
-rw-r--r--games/redeclipse-data16/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/games/redeclipse-data16/Makefile b/games/redeclipse-data16/Makefile
new file mode 100644
index 000000000000..ed499405cb83
--- /dev/null
+++ b/games/redeclipse-data16/Makefile
@@ -0,0 +1,33 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+
+PORTNAME= redeclipse-data
+PORTVERSION= 1.6.0
+DISTVERSIONPREFIX= v
+CATEGORIES= games
+PKGNAMESUFFIX= 16
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Data files for Red Eclipse first-person shooter
+
+USE_GITHUB= nodefault
+GH_TUPLE= ${DATAFILES:C/.*/red-eclipse:&:${DISTVERSIONPREFIX}${PORTVERSION}:&\/&/}
+
+CONFLICTS_INSTALL=redeclipse-data-[0-9]*
+
+DATAFILES= acerspyro actors appleflap blendbrush caustics crosshairs \
+ decals dziq elyvisions fonts freezurbern john jojo jwin luckystrike \
+ maps mayhem mikeplus64 misc nieb nobiax particles philipk \
+ projectiles props skyboxes snipergoth sounds textures torley \
+ trak ulukai unnamed vanities vegetation weapons wicked
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+DATADIR= ${PREFIX}/share/redeclipse
+
+PORTDATA= *
+
+do-install:
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} "${DATAFILES}" ${STAGEDIR}${DATADIR}
+
+.include <bsd.port.mk>