summaryrefslogtreecommitdiff
path: root/games/redeclipse-data16/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-05-29 19:06:14 +0300
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-06-01 20:34:50 +0300
commit758a5a0446ff438d0e65dbcd7a057baa747ec88f (patch)
tree29482dd1bb2268b1c9e0f1fa2b1d36586ea18aa1 /games/redeclipse-data16/Makefile
parentgames/freeorion: fix build with boost 1.76 (diff)
games/redeclipse16: resurrect older version of redeclipse
As reported by one of the players, not everybody is happy with changes in latest Red Eclipse 2.0, so many are staying with 1.6. Resurrect redeclipse/redeclipse-data at version 1.6 for them.
Diffstat (limited to 'games/redeclipse-data16/Makefile')
-rw-r--r--games/redeclipse-data16/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/games/redeclipse-data16/Makefile b/games/redeclipse-data16/Makefile
new file mode 100644
index 000000000000..ed499405cb83
--- /dev/null
+++ b/games/redeclipse-data16/Makefile
@@ -0,0 +1,33 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+
+PORTNAME= redeclipse-data
+PORTVERSION= 1.6.0
+DISTVERSIONPREFIX= v
+CATEGORIES= games
+PKGNAMESUFFIX= 16
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Data files for Red Eclipse first-person shooter
+
+USE_GITHUB= nodefault
+GH_TUPLE= ${DATAFILES:C/.*/red-eclipse:&:${DISTVERSIONPREFIX}${PORTVERSION}:&\/&/}
+
+CONFLICTS_INSTALL=redeclipse-data-[0-9]*
+
+DATAFILES= acerspyro actors appleflap blendbrush caustics crosshairs \
+ decals dziq elyvisions fonts freezurbern john jojo jwin luckystrike \
+ maps mayhem mikeplus64 misc nieb nobiax particles philipk \
+ projectiles props skyboxes snipergoth sounds textures torley \
+ trak ulukai unnamed vanities vegetation weapons wicked
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+DATADIR= ${PREFIX}/share/redeclipse
+
+PORTDATA= *
+
+do-install:
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} "${DATAFILES}" ${STAGEDIR}${DATADIR}
+
+.include <bsd.port.mk>