summaryrefslogtreecommitdiff
path: root/emulators/ppsspp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/ppsspp/Makefile')
-rw-r--r--emulators/ppsspp/Makefile63
1 files changed, 27 insertions, 36 deletions
diff --git a/emulators/ppsspp/Makefile b/emulators/ppsspp/Makefile
index 2d4cb619305e..88b9efcbbd69 100644
--- a/emulators/ppsspp/Makefile
+++ b/emulators/ppsspp/Makefile
@@ -2,19 +2,14 @@
PORTNAME= ppsspp
DISTVERSIONPREFIX= v
-DISTVERSION?= 1.3
-PORTREVISION?= 4
+DISTVERSION?= 1.4
+PORTREVISION?= 0
CATEGORIES= emulators
# XXX Get from Debian once #697821 lands
MASTER_SITES= https://bazaar.launchpad.net/~sergio-br2/${PORTNAME}/debian-sdl/download/5/${PORTNAME}.1-20140802045408-dd26dik367ztj5xg-8/:manpage
DISTFILES= ${PORTNAME}.1:manpage
EXTRACT_ONLY= ${DISTFILES:N*\:manpage:C/:.*//}
-.ifndef PKGNAMESUFFIX
-PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
-PATCHFILES= 7a7e4ed23f5f.patch:-p1
-.endif
-
MAINTAINER= jbeich@FreeBSD.org
COMMENT= PSP emulator in C++ with dynarec JIT for x86, ARM, MIPS
@@ -27,25 +22,26 @@ RUN_DEPENDS= xdg-open:devel/xdg-utils
USE_GITHUB= yes
GH_ACCOUNT= hrydgard
-GH_TUPLE?= hrydgard:${PORTNAME}-lang:cdf4a8d:lang/lang \
- Kingcom:armips:1ffab37:armips/ext/armips
+GH_TUPLE?= hrydgard:glslang:b16f7e68:glslang/ext/glslang \
+ hrydgard:${PORTNAME}-lang:ed0bbfb:lang/assets/lang \
+ KhronosGroup:SPIRV-Cross:6381b2f:SPIRV/ext/SPIRV-Cross \
+ Kingcom:armips:v0.9-26-g770365d:armips/ext/armips \
+ Kingcom:tinyformat:Release-2.0.1-7-gb7f5a22:tinyformat/ext/armips/ext/tinyformat
CONFLICTS_INSTALL= ${PORTNAME}-*
-# [QT4] FakeJit.cpp:42:37: error: no matching constructor for initialization of 'JitBlockCache'
# [QT5] c++: error: the clang compiler does not support '-march=armv7-a'
# [SDL] SplineCommon.cpp:639:17: error: use of undeclared identifier 'AllocateAlignedMemory'
BROKEN_aarch64= https://github.com/hrydgard/ppsspp/issues/9032
-USES= compiler:c++11-lib localbase:ldflags pkgconfig
-EXCLUDE= glew snappy libzip zlib
+USES= cmake:outsource compiler:c++11-lib localbase:ldflags pkgconfig
+EXCLUDE= libzip zlib
EXTRACT_AFTER_ARGS=${EXCLUDE:S,^,--exclude ,}
-USE_GL= glew glu
+USE_GL= gl glew glu
USE_SDL= sdl2 # joystick
CMAKE_ARGS= -DUSE_SYSTEM_FFMPEG=on
-QMAKE_SOURCE_PATH= ${WRKSRC}/Qt/PPSSPPQt.pro
-QMAKE_ARGS= CONFIG+="system_ffmpeg" LREL_TOOL="${LRELEASE}"
-NO_INSTALL= yes # ports/202949
+SUB_FILES= pkg-message
+PORTDATA= assets ${PORTNAME}
DESKTOP_ENTRIES="PPSSPP" \
"" \
@@ -54,51 +50,46 @@ DESKTOP_ENTRIES="PPSSPP" \
"Game;Emulator;" \
""
+OPTIONS_DEFINE= OLDJOY
OPTIONS_SINGLE= GUI
-OPTIONS_SINGLE_GUI= QT4 QT5 SDL
+OPTIONS_SINGLE_GUI= QT5 SDL
OPTIONS_SLAVE?= SDL
OPTIONS_EXCLUDE:= ${OPTIONS_SINGLE_GUI}
-QT4_USES= qmake:outsource
-QT4_USE= QT4=qmake_build,moc_build,rcc_build,uic_build,linguisttools_build,gui,opengl
-QT5_USES= qmake:outsource
+OLDJOY_DESC= Old joystick support with fixed button mappings (deprecated)
+OLDJOY_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-old-joy
QT5_USE= QT5=qmake_build,buildtools_build,linguisttools_build,gui,opengl,widgets
-SDL_USES= cmake:outsource
+QT5_CMAKE_BOOL= USING_QT_UI
+QT5_VARS= EXENAME=PPSSPPQt
SDL_BUILD_DEPENDS= png>=1.6:graphics/png
SDL_LIB_DEPENDS= libpng.so:graphics/png
-SDL_VARS= PORTDATA+="assets ${PORTNAME}"
+SDL_VARS= EXENAME=PPSSPPSDL
post-patch:
+ @${REINPLACE_CMD} -e 's/Linux/${OPSYS}/' \
+ ${WRKSRC}/assets/gamecontrollerdb.txt
@${REINPLACE_CMD} -e 's,/usr/share,${PREFIX}/share,' \
${WRKSRC}/UI/NativeApp.cpp
- @${REINPLACE_CMD} -e 's,/usr,${LOCALBASE},' \
- ${WRKSRC}/Qt/*.pr*
@${REINPLACE_CMD} \
-e 's/"unknown"/"${GH_TAGNAME}"/' \
-e 's/^\(VERSION =\).*/\1 ${GH_TAGNAME}/' \
- ${WRKSRC}/git-version.cmake \
- ${WRKSRC}/Qt/Settings.pri
+ ${WRKSRC}/git-version.cmake
-do-install-SDL-on:
+do-install:
# cmake doesn't pack assets into the app unlike qmake
(cd ${INSTALL_WRKSRC} && ${COPYTREE_SHARE} \
"${PORTDATA:N${PORTNAME}}" ${STAGEDIR}${DATADIR})
# Install the app alongside assets to avoid warnings with GetExeDirectory()
- ${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/${PORTNAME:tu}* \
+ ${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/${EXENAME} \
${STAGEDIR}${DATADIR}/${PORTNAME}
- ${LN} -sf ${DATADIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
-
-do-install-SDL-off:
- ${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/${PORTNAME} \
- ${STAGEDIR}${PREFIX}/bin
+ ${LN} -sf ../${DATADIR_REL}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
-post-install:
${INSTALL_MAN} ${_DISTDIR}/${PORTNAME}.1 \
${STAGEDIR}${MAN1PREFIX}/man/man1
- (cd ${WRKSRC}/assets/unix-icons && ${COPYTREE_SHARE} \
+ (cd ${WRKSRC}/icons && ${COPYTREE_SHARE} \
"hicolor" ${STAGEDIR}${PREFIX}/share/icons)
${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps
- ${INSTALL_DATA} ${WRKSRC}/assets/unix-icons/icon-512.svg \
+ ${INSTALL_DATA} ${WRKSRC}/icons/icon-512.svg \
${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps/${PORTNAME}.svg
.include <bsd.port.mk>