summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-testfixtures/Makefile20
-rw-r--r--devel/py-testfixtures/distinfo3
-rw-r--r--devel/py-testfixtures/pkg-descr11
4 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index df87a18387c0..c5bd47b27b56 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5192,6 +5192,7 @@
SUBDIR += py-termcolor
SUBDIR += py-terminable_thread
SUBDIR += py-termstyle
+ SUBDIR += py-testfixtures
SUBDIR += py-testgears
SUBDIR += py-testinfra
SUBDIR += py-testoob
diff --git a/devel/py-testfixtures/Makefile b/devel/py-testfixtures/Makefile
new file mode 100644
index 000000000000..67b1a96d3ad2
--- /dev/null
+++ b/devel/py-testfixtures/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= testfixtures
+PORTVERSION= 6.6.2
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= 0mp@FreeBSD.org
+COMMENT= Collection of helpers and mock objects for unit tests and doc tests
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-testfixtures/distinfo b/devel/py-testfixtures/distinfo
new file mode 100644
index 000000000000..04456dfc8077
--- /dev/null
+++ b/devel/py-testfixtures/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1553774811
+SHA256 (testfixtures-6.6.2.tar.gz) = 79b1c1ae5407750406eaf4407ea0d4c0d50b60bec3f85494c6401e072e7d2239
+SIZE (testfixtures-6.6.2.tar.gz) = 109986
diff --git a/devel/py-testfixtures/pkg-descr b/devel/py-testfixtures/pkg-descr
new file mode 100644
index 000000000000..20903547ffb2
--- /dev/null
+++ b/devel/py-testfixtures/pkg-descr
@@ -0,0 +1,11 @@
+TestFixtures is a collection of helpers and mock objects that are useful when
+writing unit tests or doc tests.
+
+If you're wondering why "yet another mock object library", testing is often
+described as an art form and as such some styles of library will suit some
+people while others will suit other styles. This library contains common test
+fixtures the author found himself repeating from package to package and so
+decided to extract them into their own library and give them some tests of
+their own!
+
+WWW: https://github.com/Simplistix/testfixtures