summaryrefslogtreecommitdiff
path: root/textproc/py-laserhammer/Makefile
diff options
context:
space:
mode:
authorEdward Tomasz Napierala <trasz@FreeBSD.org>2018-08-23 10:01:54 +0000
committerEdward Tomasz Napierala <trasz@FreeBSD.org>2018-08-23 10:01:54 +0000
commit5ee21729b3fe8131ed94906e1d2a1b0765af0989 (patch)
tree9b9e65a5a9799da3e0774720e93d837c128a3078 /textproc/py-laserhammer/Makefile
parent- Update WWW (diff)
LaserHammer is a simple DocBook to mdoc(7) ("UNIX man page syntax")
converter. The command line utility resides in the scripts/ subdirectory; use it like this: $ laserhammer book.parsed.xml book.7 The 7 above stands for section 7 of man pages, "miscellaneous documentation". The 'book.parsed.xml' is a processed XML source of the FreeBSD Handbook; you can use it as test sample. The 'book.7' is the example translated into mdoc. There's also a rudimentary Python module. Use it like this: import laserhammer mdoc = laserhammer.laserhammer(file_path) print(mdoc) WWW: https://github.com/trasz/laserhammer
Diffstat (limited to 'textproc/py-laserhammer/Makefile')
-rw-r--r--textproc/py-laserhammer/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/textproc/py-laserhammer/Makefile b/textproc/py-laserhammer/Makefile
new file mode 100644
index 000000000000..b6c6ecaf04c5
--- /dev/null
+++ b/textproc/py-laserhammer/Makefile
@@ -0,0 +1,18 @@
+# Created by: Edward Tomasz Napierala <trasz@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= laserhammer
+PORTVERSION= 2.4
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= trasz@FreeBSD.org
+COMMENT= Docbook to mdoc(7) converter
+
+LICENSE= BSD2CLAUSE
+
+USES= python:3.6+
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>