summaryrefslogtreecommitdiff
path: root/textproc/p5-Unicode-Tussle/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2019-12-11 19:38:04 +0000
committerKurt Jaeger <pi@FreeBSD.org>2019-12-11 19:38:04 +0000
commit56f51753d7139e6f00dcfcbbe140ab7549ee0c73 (patch)
tree2f5a1b3f1e302b9f3ed6c98f9f9eeadc2b7ed890 /textproc/p5-Unicode-Tussle/Makefile
parentNew port: korean/p5-Lingua-KO-Romanize-Hangul: Romanization of Korean language (diff)
New port: textproc/p5-Unicode-Tussle: Tom's Unicode Scripts So Life is Easier
Tom's Unicode Scripts So Life is Easier. This is a collection of separate programs. WWW: https://metacpan.org/release/Unicode-Tussle PR: 242358 Submitted by: Tomohiro Hosaka <bokutin@bokut.in>
Diffstat (limited to 'textproc/p5-Unicode-Tussle/Makefile')
-rw-r--r--textproc/p5-Unicode-Tussle/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/textproc/p5-Unicode-Tussle/Makefile b/textproc/p5-Unicode-Tussle/Makefile
new file mode 100644
index 000000000000..b42e759aeeca
--- /dev/null
+++ b/textproc/p5-Unicode-Tussle/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= Unicode-Tussle
+PORTVERSION= 1.111
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR=CPAN:BDFOY
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= bokutin@bokut.in
+COMMENT= Tom's Unicode Scripts So Life is Easier
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+
+RUN_DEPENDS= p5-Lingua-EN-Syllable>=0:textproc/p5-Lingua-EN-Syllable \
+ p5-Lingua-JA-Romanize-Japanese>=0:japanese/p5-Lingua-JA-Romanize-Japanese \
+ p5-Lingua-KO-Hangul-Util>=0:korean/p5-Lingua-KO-Hangul-Util \
+ p5-Lingua-KO-Romanize-Hangul>=0:korean/p5-Lingua-KO-Romanize-Hangul \
+ p5-Lingua-ZH-Romanize-Pinyin>=0:chinese/p5-Lingua-ZH-Romanize-Pinyin \
+ p5-Unicode-LineBreak>=0:textproc/p5-Unicode-LineBreak \
+ p5-Unicode-Unihan>=0:textproc/p5-Unicode-Unihan
+
+USES= perl5 shebangfix
+USE_PERL5= configure
+NO_ARCH= yes
+
+SHEBANG_FILES= script/*
+
+post-patch:
+ cd ${WRKSRC}/script && ${RM} es-sort hantest havshpx hypertest vowel-sigs nunez
+
+.include <bsd.port.mk>