summaryrefslogtreecommitdiff
path: root/sysutils/fvcool/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-10-13 07:12:53 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-10-13 07:12:53 +0000
commit3182871f3d1657318e390fc92c1fd23eb133815e (patch)
tree5218fa98504efc572ef33360b20ab21c20ec929f /sysutils/fvcool/Makefile
parentAdd liveMedia(2002.10.11), a set of C++ libraries for (diff)
New port fvcool version 1.0.2: VCool for FreeBSD - Cooling software
for AMD Athlon/Durin CPUs PR: 43732 Submitted by: Frerich Raabe <frerich.raabe@gmx.de>
Diffstat (limited to 'sysutils/fvcool/Makefile')
-rw-r--r--sysutils/fvcool/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/sysutils/fvcool/Makefile b/sysutils/fvcool/Makefile
new file mode 100644
index 000000000000..6c50c6ffbb61
--- /dev/null
+++ b/sysutils/fvcool/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: fvcool
+# Date created: 5 October 2002
+# Whom: Frerich Raabe <frerich.raabe@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fvcool
+PORTVERSION= 1.0.2
+CATEGORIES= sysutils
+MASTER_SITES= http://www.nt.phys.kyushu-u.ac.jp/shimizu/download/
+DISTNAME= FVCool${PORTVERSION:S/.//g}
+
+MAINTAINER= frerich.raabe@gmx.de
+
+USE_REINPLACE= yes
+ALL_TARGET= fvcool
+PLIST_SUB+= DOCSDIR=${DOCSDIR:S,^${PREFIX}/,,}
+
+DOC_FILES= 00README.txt 00READMEj.txt 00READMEkt133.txt
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|gcc|${CC} ${CFLAGS}|; \
+ s|-O3||;s|-s$$||' \
+ ${BUILD_WRKSRC}/${MAKEFILE}
+
+do-install: install-doc
+ @${INSTALL_PROGRAM} ${WRKSRC}/fvcool ${PREFIX}/sbin/fvcool
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+install-doc:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>