summaryrefslogtreecommitdiff
path: root/math/p5-Math-Geometry-Planar-Offset/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-21 23:14:47 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-21 23:14:47 +0000
commitadbe1274286e882a9cd579c0e5831308436744c9 (patch)
tree2bb0ca570c4552cc6a33f2070533aab06967bc21 /math/p5-Math-Geometry-Planar-Offset/Makefile
parentUse SUB_FILES to install mdoc.local. (diff)
Adding port math/p5-Math-Geometry-Planar-Offset, a library for calculating offset polygons.
Approved by: tobez (implicit)
Diffstat (limited to 'math/p5-Math-Geometry-Planar-Offset/Makefile')
-rw-r--r--math/p5-Math-Geometry-Planar-Offset/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/math/p5-Math-Geometry-Planar-Offset/Makefile b/math/p5-Math-Geometry-Planar-Offset/Makefile
new file mode 100644
index 000000000000..d7cd19b1c647
--- /dev/null
+++ b/math/p5-Math-Geometry-Planar-Offset/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: Math-Geometry-Planar-Offset
+# Date created: 21 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Geometry-Planar-Offset
+PORTVERSION= 1.03
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/E/EW/EWILHELM/Math
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION}_01
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Calculate offset polygons
+
+MAN3= Math::Geometry::Planar::Offset.3
+
+PERL_MODBUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>