summaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2013-08-03 13:44:00 +0000
committerMathieu Arnold <mat@FreeBSD.org>2013-08-03 13:44:00 +0000
commit62a41b423ba42c0a1ab0c0ada5d33752e965f615 (patch)
tree5fff787fcf509ed53762690c395516c337412423 /cad
parentConvert to new perl framework. (diff)
- Convert to new perl framework
- Remove MAKE_JOBS_SAFE=yes, it's the default.
Diffstat (limited to 'cad')
-rw-r--r--cad/chipvault/Makefile3
-rw-r--r--cad/dinotrace/Makefile5
-rw-r--r--cad/geda-utils/Makefile3
-rw-r--r--cad/geda/Makefile5
4 files changed, 8 insertions, 8 deletions
diff --git a/cad/chipvault/Makefile b/cad/chipvault/Makefile
index 323ec27da264..71de94b7b4f9 100644
--- a/cad/chipvault/Makefile
+++ b/cad/chipvault/Makefile
@@ -22,7 +22,8 @@ EXTRACT_BEFORE_ARGS= # empty
EXTRACT_AFTER_ARGS= > ${DISTNAME}
NO_BUILD= yes
PLIST_FILES= bin/cv
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/cv.pl ${PREFIX}/bin/cv
diff --git a/cad/dinotrace/Makefile b/cad/dinotrace/Makefile
index 67e99d4e3dfc..0ffb3b6b4ab1 100644
--- a/cad/dinotrace/Makefile
+++ b/cad/dinotrace/Makefile
@@ -16,10 +16,9 @@ OPTIONS_DEFAULT= EMACS
EMACS_DESC= Install Emacs supplimentary files
USE_XORG= x11 sm ice xmu xt
-USES= gmake motif
-USE_PERL5_BUILD= yes
+USES= gmake motif perl5
+USE_PERL5= build
GNU_CONFIGURE= yes
-MAKE_JOBS_SAFE= yes
INFO= dinotrace
PLIST_FILES= bin/dinotrace
diff --git a/cad/geda-utils/Makefile b/cad/geda-utils/Makefile
index dcce8cd6c0e8..c1c508a5c46e 100644
--- a/cad/geda-utils/Makefile
+++ b/cad/geda-utils/Makefile
@@ -24,10 +24,11 @@ LIB_DEPENDS= geda.33:${PORTSDIR}/cad/libgeda
DOCSDIR= ${PREFIX}/share/doc/geda
DATADIR= ${PREFIX}/share/geda
+USES= perl5
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= gtk20
-USE_PERL5_RUN= yes
+USE_PERL5= run
USE_PYTHON_RUN= yes
CONFIGURE_ARGS= --with-docdir=${DOCSDIR}
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/cad/geda/Makefile b/cad/geda/Makefile
index 13be739e5732..5ce6100adb4f 100644
--- a/cad/geda/Makefile
+++ b/cad/geda/Makefile
@@ -20,16 +20,15 @@ RUN_DEPENDS= gawk:${PORTSDIR}/lang/gawk
OPTIONS_DEFINE= DOCS
-USES= pathfix gettext
+USES= pathfix gettext perl5
USE_GNOME= desktopfileutils gtk20
-USE_PERL5_RUN= yes
+USE_PERL5= run
USE_PYTHON= run
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --with-libstroke=${LOCALBASE}
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
-MAKE_JOBS_SAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib