summaryrefslogtreecommitdiff
path: root/Mk/bsd.gecko.mk
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-06-18 20:34:16 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-06-18 20:34:16 +0000
commit16daddfbda754c48dd5a13dcf3689dbf31c85e80 (patch)
tree5d3ac416ff34fc71bae3c0a567aaf4ae31dcc70e /Mk/bsd.gecko.mk
parentFix runtime error by adding security/py-pycryptodome (diff)
Mk/bsd.gecko.mk: add devel/binutils to BUILD_DEPENDS
Currently, Rust on powerpc64 elfv2 builds with GCC because of past issue with LLVM. However, this issue seems to be resolved now and I can already build Rust with Clang and then build with it other packages, like Firefox. The problem is that, when using GCC, binutils is getting installed, but when using LLVM, it's not and there is -fno-integrated-as getting passed on ppc64. Since it's only for the build and users building from ports have binutils installed anyway, add it for everyone. PR: 247387 Approved by: jbeich (maintainer)
Diffstat (limited to 'Mk/bsd.gecko.mk')
-rw-r--r--Mk/bsd.gecko.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 49d5536d00ad..dd7af13bcbdd 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -310,6 +310,7 @@ CFLAGS+= -B${LOCALBASE}/bin
LDFLAGS+= -B${LOCALBASE}/bin
. endif
.elif ${ARCH:Mpowerpc*}
+BUILD_DEPENDS+= as:devel/binutils
. if ${ARCH} == "powerpc64"
MOZ_EXPORT+= UNAME_m="${ARCH}"
. endif