summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Davis <brd@FreeBSD.org>2017-03-31 14:32:02 +0000
committerBrad Davis <brd@FreeBSD.org>2017-03-31 14:32:02 +0000
commitf13fc84959fd7381a1108793020a387197515de8 (patch)
tree014f7fcca7593c59857b1c90c6a804247eb22fd2
parentFix people using LICENSE_DISTFILES in the wrong way. (diff)
Add net/p5-Net-NTP
Approved by: swills (mentor) Sponsored by: Netflix
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-NTP/Makefile19
-rw-r--r--net/p5-Net-NTP/distinfo3
-rw-r--r--net/p5-Net-NTP/files/patch-lib_Net_NTP.pm10
-rw-r--r--net/p5-Net-NTP/pkg-descr5
5 files changed, 38 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 605251c43f4b..6f00515d20cb 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -675,6 +675,7 @@
SUBDIR += p5-Net-NBsocket
SUBDIR += p5-Net-NIS
SUBDIR += p5-Net-NIS-Listgroup
+ SUBDIR += p5-Net-NTP
SUBDIR += p5-Net-Nessus-XMLRPC
SUBDIR += p5-Net-Nmsg
SUBDIR += p5-Net-OAuth
diff --git a/net/p5-Net-NTP/Makefile b/net/p5-Net-NTP/Makefile
new file mode 100644
index 000000000000..f1cc86da5901
--- /dev/null
+++ b/net/p5-Net-NTP/Makefile
@@ -0,0 +1,19 @@
+# Created by: brd@FreeBSD.org
+# $FreeBSD$
+
+PORTNAME= Net-NTP
+PORTVERSION= 1.5
+CATEGORIES= net
+MASTER_SITES= CPAN
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Perl extension for decoding NTP server responses
+
+NO_ARCH= yes
+USE_PERL5= configure
+USES= perl5
+
+PLIST_FILES= %%SITE_PERL%%/Net/NTP.pm \
+ %%PERL5_MAN3%%/Net::NTP.3.gz
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-NTP/distinfo b/net/p5-Net-NTP/distinfo
new file mode 100644
index 000000000000..ca0bb6615e51
--- /dev/null
+++ b/net/p5-Net-NTP/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1490969857
+SHA256 (Net-NTP-1.5.tar.gz) = b16817f88ecc75f155aea3dcf8874d4b8bcc0c9d249e1bc1e12ce7cfa5e7d9aa
+SIZE (Net-NTP-1.5.tar.gz) = 6459
diff --git a/net/p5-Net-NTP/files/patch-lib_Net_NTP.pm b/net/p5-Net-NTP/files/patch-lib_Net_NTP.pm
new file mode 100644
index 000000000000..9625e9de5be9
--- /dev/null
+++ b/net/p5-Net-NTP/files/patch-lib_Net_NTP.pm
@@ -0,0 +1,10 @@
+--- lib/Net/NTP.pm.orig 2017-03-30 18:32:06 UTC
++++ lib/Net/NTP.pm
+@@ -179,6 +179,7 @@ sub get_ntp_response {
+ alarm(0);
+ };
+ alarm 0;
++ die $@ if $@;
+
+ my $rectime = time; # T4
+ my $pkt = Net::NTP::Packet->decode($data, $xmttime, $rectime);
diff --git a/net/p5-Net-NTP/pkg-descr b/net/p5-Net-NTP/pkg-descr
new file mode 100644
index 000000000000..b6b2dd28a1bc
--- /dev/null
+++ b/net/p5-Net-NTP/pkg-descr
@@ -0,0 +1,5 @@
+All this module does is send a packet to an NTP server and
+then decode the packet received into it's respective parts
+- as outlined in RFC5905 (superseding RFC1305 and RFC2030).
+
+WWW: http://search.cpan.org/dist/Net-NTP/