summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2022-03-16 19:28:57 +0100
committerDimitry Andric <dim@FreeBSD.org>2022-03-16 19:28:57 +0100
commitdbafe427a49b7feef6049e10e3398a0681c8ccd5 (patch)
treefc5e0a91ff12acc1ec9bd2c5ede1fb66f206e1f2
parentsysutils/opa: Update 0.32.0 -> 0.38.1 (diff)
databases/postgresql14-server: Avoid using llvm14
When the base system compiler is clang 14, the postgresql ports attempt to build against the devel/llvm14 port. This will fail with several compile errors as there are a few incompatible changes in the LLVM 14 C and C++ APIs. Until upstream postgresql adapts to these changes, limit the PG_LLVM_VERSION to a maximum of 13. PR: 261976 Approved by: maintainer timeout (2 weeks) MFH: 2022Q1
-rw-r--r--databases/postgresql14-server/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/databases/postgresql14-server/Makefile b/databases/postgresql14-server/Makefile
index c55a077634ac..c8d97cafd294 100644
--- a/databases/postgresql14-server/Makefile
+++ b/databases/postgresql14-server/Makefile
@@ -266,15 +266,26 @@ LLVM_PORT_SUFFIX= ${COMPILER_VERSION:C/.$//}
.if ${COMPILER_VERSION} > ${LLVM_DEFAULT_VERSION}
# LLVM versions in ports are, in order, 70, 80 90, 10, 11, 12... where 10 > 90. [sic]
. if ${LLVM_PORT_SUFFIX} < 70
+# PR 261976 postgresql fails to build with LLVM 14
+. if ${LLVM_PORT_SUFFIX} > 13
+PG_LLVM_VERSION=13
+PG_COMPILER_VERSION=13
+. else
PG_LLVM_VERSION=${LLVM_PORT_SUFFIX}
PG_COMPILER_VERSION=${LLVM_PORT_SUFFIX}
+. endif
. else
PG_LLVM_VERSION=11
PG_COMPILER_VERSION=11
. endif
.else
+. if ${LLVM_PORT_SUFFIX} > 13
+PG_LLVM_VERSION=13
+PG_COMPILER_VERSION=13
+. else
PG_LLVM_VERSION=${LLVM_DEFAULT}
PG_COMPILER_VERSION=${LLVM_PORT_SUFFIX}
+. endif
.endif
.if ${DISTVERSION:C/([0-9]*).*/\1/} >= 11