summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2019-03-28 16:46:51 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2019-03-28 16:46:51 +0000
commita687849b5173a0ceba3ddf659999195857ad158c (patch)
tree247e119a2fcc07f71ca7cfbb1a9809e3910dc8c5
parentNew port: devel/py-testfixtures: Collection of helpers and mock objects for u... (diff)
New port: textproc/up: Ultimate plumber, a tool for writing pipes with instant live preview
up is the Ultimate Plumber, a tool for writing Linux pipes in a terminal-based UI interactively, with instant live preview of command results. The main goal of the Ultimate Plumber is to help interactively and incrementally explore textual data in Linux, by making it easier to quickly build complex pipelines, thanks to a fast feedback loop. This is achieved by boosting any typical Linux text-processing utils such as grep, sort, cut, paste, awk, wc, perl, etc., etc., by providing a quick, interactive, scrollable preview of their results. WWW: https://github.com/akavel/up Reviewed by: mat Approved by: mat (mentor) Differential Revision: https://reviews.freebsd.org/D19716
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/up/Makefile42
-rw-r--r--textproc/up/distinfo17
-rw-r--r--textproc/up/pkg-descr11
4 files changed, 71 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index e221224a8408..12c6f80741ac 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1802,6 +1802,7 @@
SUBDIR += unoconv
SUBDIR += unroff
SUBDIR += unrtf
+ SUBDIR += up
SUBDIR += urlview
SUBDIR += utf8proc
SUBDIR += uz-aspell
diff --git a/textproc/up/Makefile b/textproc/up/Makefile
new file mode 100644
index 000000000000..44e6b742b30c
--- /dev/null
+++ b/textproc/up/Makefile
@@ -0,0 +1,42 @@
+# $FreeBSD$
+
+PORTNAME= up
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.3.2
+CATEGORIES= textproc
+
+MAINTAINER= 0mp@FreeBSD.org
+COMMENT= Ultimate plumber, a tool for writing pipes with instant live preview
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go
+
+USE_GITHUB= yes
+GH_ACCOUNT= akavel
+GH_TUPLE= gdamore:encoding:b23993cbb635:encoding/src/github.com/gdamore/encoding \
+ gdamore:tcell:493f3b46b3c2:tcell/src/github.com/gdamore/tcell \
+ lucasb-eyer:go-colorful:231272389856:gocolorful/src/github.com/lucasb-eyer/go-colorful \
+ mattn:go-isatty:v0.0.3:goisatty/src/github.com/mattn/go-isatty \
+ mattn:go-runewidth:v0.0.2:gorunewidth/src/github.com/mattn/go-runewidth \
+ spf13:pflag:v1.0.3:pflag/src/github.com/spf13/pflag \
+ golang:text:f21a4dfb5e38:text/src/golang.org/x/text
+
+PLIST_FILES= bin/up
+PORTDOCS= README.md
+
+OPTIONS_DEFINE= DOCS
+
+post-extract:
+ @${LN} -sf ${WRKSRC}/src ${WRKDIR}
+ @${LN} -sf ${WRKSRC} ${GO_WRKSRC}
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
+
+do-test:
+ cd ${GO_WRKSRC}; ${SETENV} ${GO_ENV} ${GO_CMD} test
+
+.include <bsd.port.mk>
diff --git a/textproc/up/distinfo b/textproc/up/distinfo
new file mode 100644
index 000000000000..434577828e9e
--- /dev/null
+++ b/textproc/up/distinfo
@@ -0,0 +1,17 @@
+TIMESTAMP = 1553595493
+SHA256 (akavel-up-v0.3.2_GH0.tar.gz) = 359510cfea8af8f14de39d63f63cc5c765f681cca2c37f00174837d52c62cad1
+SIZE (akavel-up-v0.3.2_GH0.tar.gz) = 157016
+SHA256 (gdamore-encoding-b23993cbb635_GH0.tar.gz) = 3c607d322b9f585567dd4b6b19a0179a8277de94d44f98b4b42629632c035923
+SIZE (gdamore-encoding-b23993cbb635_GH0.tar.gz) = 10635
+SHA256 (gdamore-tcell-493f3b46b3c2_GH0.tar.gz) = c636b7735634f329015e605ca154acc47c0164040f9af5af157cc073ebd79410
+SIZE (gdamore-tcell-493f3b46b3c2_GH0.tar.gz) = 720314
+SHA256 (lucasb-eyer-go-colorful-231272389856_GH0.tar.gz) = fe20e3f90bcbcf6bc258cc0421a6a1aa3ff51c1bf5c46637083989b3e203709a
+SIZE (lucasb-eyer-go-colorful-231272389856_GH0.tar.gz) = 428461
+SHA256 (mattn-go-isatty-v0.0.3_GH0.tar.gz) = daf68970a6506650b05bac72082865f88d582ecdb74418b95ac5621d5392b633
+SIZE (mattn-go-isatty-v0.0.3_GH0.tar.gz) = 3364
+SHA256 (mattn-go-runewidth-v0.0.2_GH0.tar.gz) = 6c7734401fdf829af4f35a5af21a54548f7d3a68336940fb550178ddfe95b076
+SIZE (mattn-go-runewidth-v0.0.2_GH0.tar.gz) = 22367
+SHA256 (spf13-pflag-v1.0.3_GH0.tar.gz) = 9e57f86f493f04d9077fccd04e7139ebf243dd544e917ab83d35729b3e54a124
+SIZE (spf13-pflag-v1.0.3_GH0.tar.gz) = 46002
+SHA256 (golang-text-f21a4dfb5e38_GH0.tar.gz) = 51198f5706bc4b834a52a2c8ffe9037360a300702aed2ad567f4853b991e6be2
+SIZE (golang-text-f21a4dfb5e38_GH0.tar.gz) = 6102597
diff --git a/textproc/up/pkg-descr b/textproc/up/pkg-descr
new file mode 100644
index 000000000000..4f18ab035183
--- /dev/null
+++ b/textproc/up/pkg-descr
@@ -0,0 +1,11 @@
+up is the Ultimate Plumber, a tool for writing Linux pipes in a terminal-based
+UI interactively, with instant live preview of command results.
+
+The main goal of the Ultimate Plumber is to help interactively and
+incrementally explore textual data in Linux, by making it easier to quickly
+build complex pipelines, thanks to a fast feedback loop. This is achieved by
+boosting any typical Linux text-processing utils such as grep, sort, cut,
+paste, awk, wc, perl, etc., etc., by providing a quick, interactive, scrollable
+preview of their results.
+
+WWW: https://github.com/akavel/up