summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJordan Bracco <href@random.sh>2022-03-16 13:53:39 +0000
committerJordan Bracco <href@random.sh>2022-03-16 13:53:39 +0000
commite734ed0098b1706ac6f6844554b7f239c13772ad (patch)
tree911b02bcedf2a18f8243ea8c4c867fd69cc11f82
parentgraphics/vulkan-tools: update to 1.2.208 (diff)
security/ory-keto: wiphref/security/ory-keto
-rw-r--r--GIDs2
-rw-r--r--UIDs2
-rw-r--r--security/ory-keto/Makefile15
-rwxr-xr-xsecurity/ory-keto/files/ory-keto.in21
-rw-r--r--security/ory-keto/pkg-descr4
-rw-r--r--security/ory-keto/pkg-plist3
6 files changed, 45 insertions, 2 deletions
diff --git a/GIDs b/GIDs
index 18c8f8438f09..57a7be87f3d0 100644
--- a/GIDs
+++ b/GIDs
@@ -245,7 +245,7 @@ netdata:*:302:
onlyoffice:*:303:www
glewlwyd:*:304:
nats:*:305:
-# free: 306
+ory-keto:*:306:
# free: 307
# free: 308
# free: 309
diff --git a/UIDs b/UIDs
index acdac4f39461..708af3fa7193 100644
--- a/UIDs
+++ b/UIDs
@@ -250,7 +250,7 @@ netdata:*:302:302::0:0:NetData Daemon:/var/cache/netdata:/usr/sbin/nologin
onlyoffice:*:303:303::0:0:Onlyoffice pseudo-user:/usr/local/www/onlyoffice/documentserver:/usr/sbin/nologin
glewlwyd:*:304:304::0:0:Glewlwyd SSO server:/nonexistent:/usr/sbin/nologin
nats:*:305:305::0:0:NATS Daemon:/nonexistent:/usr/sbin/nologin
-# free: 306
+ory-keto:*:306:306::0:0:ORY Keto:/nonexistent:/usr/sbin/nologin
# free: 307
# free: 308
# free: 309
diff --git a/security/ory-keto/Makefile b/security/ory-keto/Makefile
new file mode 100644
index 000000000000..d7ae5feb708f
--- /dev/null
+++ b/security/ory-keto/Makefile
@@ -0,0 +1,15 @@
+PORTNAME= ory-keto
+DISTVERSIONPREFIX=v
+DISTVERSION= 0.8.0-alpha.2
+CATEGORIES= security
+
+MAINTAINER= href@random.sh
+COMMENT= Ory Global Authorization System
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+GO_MODULE= github.com/ory/keto
+
+.include <bsd.port.mk>
diff --git a/security/ory-keto/files/ory-keto.in b/security/ory-keto/files/ory-keto.in
new file mode 100755
index 000000000000..d447545a9176
--- /dev/null
+++ b/security/ory-keto/files/ory-keto.in
@@ -0,0 +1,21 @@
+#!/bin/sh
+
+. /etc/rc.subr
+
+name="ory_keto"
+rcvar="${name}_enable"
+
+load_rc_config $name
+: ${ory_keto_enable:=no}
+: ${ory_keto_config="%%ETCDIR%%/ory-keto.yml"}
+: ${ory_keto_serve_args=""}
+: ${ory_keto_user="ory-keto"}
+: ${ory_keto_group="ory-keto"}
+
+pidfile="/var/run/ory-keto.pid"
+command="/usr/sbin/daemon"
+ory_keto_command="%%PREFIX%%/bin/keto"
+procname="daemon"
+command_args="-S -T ${name} -r -c -P ${pidfile} ${ory_keto_command} serve ${ory_keto_serve_flags} --config ${ory_keto_config}"
+
+run_rc_command "$1"
diff --git a/security/ory-keto/pkg-descr b/security/ory-keto/pkg-descr
new file mode 100644
index 000000000000..d8bc3ee79997
--- /dev/null
+++ b/security/ory-keto/pkg-descr
@@ -0,0 +1,4 @@
+Open Source (Go) implementation of "Zanzibar: Google's Consistent, Global Authorization System".
+Ships gRPC, REST APIs, newSQL, and an easy and granular permission language. Supports ACL, RBAC, and other access models.
+
+WWW: https://www.ory.sh/keto/
diff --git a/security/ory-keto/pkg-plist b/security/ory-keto/pkg-plist
new file mode 100644
index 000000000000..2c43f83e2e1d
--- /dev/null
+++ b/security/ory-keto/pkg-plist
@@ -0,0 +1,3 @@
+bin/keto
+@sample %%ETCDIR%%/keto.yml
+@dir /var/db/ory-keto