From 9e5632dd661f75b5801706e55659a4da501e49b5 Mon Sep 17 00:00:00 2001
From: Joe Marcus Clarke <marcus@FreeBSD.org>
Date: Fri, 9 Jul 2004 17:43:11 +0000
Subject: Apply a big libtool patch to allow porters to use the libtool
 installed by the libtoolX ports instead of the one included with each port. 
 Ports that set USE_LIBTOOL_VER=X will now use the ports version of libtool
 instead of the included version.  To restore previous behavior, use the new
 macro, USE_INC_LIBTOOL_VER.  Both macros accept the same argument: a libtool
 version.

For example, to use the ports version of libtool-1.5, add the following to
your Makefile:

USE_LIBTOOL_VER=        15

To use the included version of libtool with extra hacks provided by
libtool-1.5, add the following to your Makefile:

USE_INC_LIBTOOL_VER=    15

With this change, ports that had to add additional libtool hacks to prevent
.la files from being installed or to fix certain threading issues can now
delete those hacks (after appropriate testing, of course).

PR:		63944
Based on work by:eik and marcus
Approved by:	ade (autotools maintainer)
Tested by:	kris on pointyhat
Bound to be hidden problems:	You bet
---
 x11/eterm/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

(limited to 'x11/eterm')

diff --git a/x11/eterm/Makefile b/x11/eterm/Makefile
index 4c8abadd361a..53fb0397dd8d 100644
--- a/x11/eterm/Makefile
+++ b/x11/eterm/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS=	Imlib2.2:${PORTSDIR}/graphics/imlib2 \
 		ast.2:${PORTSDIR}/devel/libast
 
 USE_X_PREFIX=	yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
 INSTALLS_SHLIB=	yes
 CONFIGURE_ARGS?=--enable-trans --enable-utmp \
 		--enable-xim --with-theme-update \
-- 
cgit v1.2.3