From b7ad3af71f39875855d8b4db529701ab8726eb06 Mon Sep 17 00:00:00 2001
From: Pav Lucistnik <pav@FreeBSD.org>
Date: Wed, 28 Jul 2004 21:17:49 +0000
Subject: Add bbappconf, an utility that makes it possible to set some options
 for the windows blackbox opens, like:

    * on which desktop they should open
    * if it should be displayed without titlebar
    * if it should be sticky
    * position size of windows

PR:		ports/69613
Submitted by:	Gerrit Beine <tux@pinguru.net>
---
 x11/bbappconf/Makefile               | 26 ++++++++++++++++++++++++++
 x11/bbappconf/distinfo               |  2 ++
 x11/bbappconf/files/patch-resouce.cc | 10 ++++++++++
 x11/bbappconf/pkg-descr              |  9 +++++++++
 x11/bbappconf/pkg-plist              |  5 +++++
 5 files changed, 52 insertions(+)
 create mode 100644 x11/bbappconf/Makefile
 create mode 100644 x11/bbappconf/distinfo
 create mode 100644 x11/bbappconf/files/patch-resouce.cc
 create mode 100644 x11/bbappconf/pkg-descr
 create mode 100644 x11/bbappconf/pkg-plist

(limited to 'x11/bbappconf')

diff --git a/x11/bbappconf/Makefile b/x11/bbappconf/Makefile
new file mode 100644
index 000000000000..f804a7d5a66b
--- /dev/null
+++ b/x11/bbappconf/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for:	bbappconf
+# Date created:				26 July 2004
+# Whom:				Gerrit Beine <tux@pinguru.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	bbappconf
+PORTVERSION=	0.0.2
+CATEGORIES=	x11
+MASTER_SITES=	http://bbtools.windsofstorm.net/sources/
+
+MAINTAINER=	tux@pinguru.net
+COMMENT=	Application configuring tool for the blackbox window manager
+
+USE_X_PREFIX=	yes
+GNU_CONFIGURE=	yes
+
+do-install:
+	@${INSTALL_PROGRAM} ${WRKSRC}/bbappconf ${PREFIX}/bin
+	@${MKDIR} ${PREFIX}/share/bbtools
+.for a in README.bbappconf bbappconf.bb bbappconf.nobb
+	@${INSTALL_DATA} ${WRKSRC}/data/${a} ${PREFIX}/share/bbtools
+.endfor
+
+.include <bsd.port.mk>
diff --git a/x11/bbappconf/distinfo b/x11/bbappconf/distinfo
new file mode 100644
index 000000000000..e6aafc1f6f47
--- /dev/null
+++ b/x11/bbappconf/distinfo
@@ -0,0 +1,2 @@
+MD5 (bbappconf-0.0.2.tar.gz) = 3f36aa6739db238d22f2894d697293d9
+SIZE (bbappconf-0.0.2.tar.gz) = 80107
diff --git a/x11/bbappconf/files/patch-resouce.cc b/x11/bbappconf/files/patch-resouce.cc
new file mode 100644
index 000000000000..727581753334
--- /dev/null
+++ b/x11/bbappconf/files/patch-resouce.cc
@@ -0,0 +1,10 @@
+--- resource.cc.orig	Tue Oct 15 21:10:51 2002
++++ resource.cc	Mon Jul 26 11:36:10 2004
+@@ -23,6 +23,7 @@
+ #include "blackboxstyle.hh"
+ 
+ Resource::Resource(ToolWindow *toolwindow): BaseResource(toolwindow) {
++  frame.font = NULL;
+   Load();
+ }
+ 
diff --git a/x11/bbappconf/pkg-descr b/x11/bbappconf/pkg-descr
new file mode 100644
index 000000000000..290fbadda2cd
--- /dev/null
+++ b/x11/bbappconf/pkg-descr
@@ -0,0 +1,9 @@
+bbappconf makes it possible to set some options for the windows blackbox opens,
+like:
+
+    * on which desktop they should open
+    * if it should be displayed without titlebar
+    * if it should be sticky
+    * position size of windows
+
+WWW: http://bbtools.windsofstorm.net/
diff --git a/x11/bbappconf/pkg-plist b/x11/bbappconf/pkg-plist
new file mode 100644
index 000000000000..5afe498d2c17
--- /dev/null
+++ b/x11/bbappconf/pkg-plist
@@ -0,0 +1,5 @@
+bin/bbappconf
+share/bbtools/README.bbappconf
+share/bbtools/bbappconf.bb
+share/bbtools/bbappconf.nobb
+@dirrm share/bbtools
-- 
cgit v1.2.3