From 92abd7971a1eb5a22da79d946e3d1b061555d6b7 Mon Sep 17 00:00:00 2001
From: Ade Lovett <ade@FreeBSD.org>
Date: Tue, 8 May 2001 18:58:23 +0000
Subject: The eel library contains a number of generally useful classes and
 functions. Many of them are extensions to things in glib, gtk, gnome-libs,
 and other widely-used GNOME platform libraries. The long term plan is to move
 much of this into the platform libraries themselves.

---
 x11-toolkits/eel/Makefile | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)
 create mode 100644 x11-toolkits/eel/Makefile

(limited to 'x11-toolkits/eel/Makefile')

diff --git a/x11-toolkits/eel/Makefile b/x11-toolkits/eel/Makefile
new file mode 100644
index 000000000000..77d9a85d6f14
--- /dev/null
+++ b/x11-toolkits/eel/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for:    eel
+# Date created:         		8th May 2001
+# Whom:                 		Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	eel
+PORTVERSION=	1.0
+CATEGORIES=	graphics gnome
+MASTER_SITES=	${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR=	stable/sources/librsvg
+
+MAINTAINER=	ade@FreeBSD.org
+
+BUILD_DEPENDS=	freetype-config:${PORTSDIR}/print/freetype2	# XXX
+LIB_DEPENDS=	rsvg.1:${PORTSDIR}/graphics/librsvg
+
+USE_GMAKE=	yes
+USE_X_PREFIX=	yes
+USE_GNOME=	yes
+USE_LIBTOOL=	yes
+INSTALLS_SHLIB=	yes
+
+CONFIGURE_ARGS=	--enable-shared --enable-static
+CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include" \
+		LIBS="-L${LOCALBASE}/lib"
+
+pre-patch:
+	@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+		 s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+	@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+		's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+		 s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>
-- 
cgit v1.2.3