From f648b23c83da5bf1d5dee6cbc3d04671d9714303 Mon Sep 17 00:00:00 2001
From: Alex Dupre <ale@FreeBSD.org>
Date: Tue, 6 Jun 2006 14:08:08 +0000
Subject: Update to 1.0 release and add coverager support.

---
 www/xcache/Makefile               | 31 +++++++++++++++++++++---
 www/xcache/distinfo               |  6 ++---
 www/xcache/files/patch-xcache.ini | 50 +++++++++++++++++++++++++++++++++++++++
 www/xcache/pkg-plist              |  7 ++++++
 4 files changed, 88 insertions(+), 6 deletions(-)
 create mode 100644 www/xcache/files/patch-xcache.ini

(limited to 'www/xcache')

diff --git a/www/xcache/Makefile b/www/xcache/Makefile
index 74fa894cf603..f571b64b7d80 100644
--- a/www/xcache/Makefile
+++ b/www/xcache/Makefile
@@ -6,9 +6,9 @@
 #
 
 PORTNAME=	xcache
-DISTVERSION=	1.0-rc
+DISTVERSION=	1.0
 CATEGORIES=	www
-MASTER_SITES=	http://210.51.190.228/pub/XCache/
+MASTER_SITES=	http://210.51.190.228/pub/XCache/Releases/
 
 MAINTAINER=	ale@FreeBSD.org
 COMMENT=	A fast and stable php opcode cacher
@@ -18,11 +18,26 @@ USE_PHPIZE=	yes
 
 CONFIGURE_ARGS=	--enable-xcache=shared
 
+OPTIONS=	COVERAGER "Enable code coverage dumper" off
+
 SUB_FILES=	pkg-message
 PKGMESSAGE=	${WRKDIR}/pkg-message
 
 WRKSRC=		${WRKDIR}/${PORTNAME}
 
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_COVERAGER)
+CONFIGURE_ARGS+=--enable-xcache-coverager
+PLIST_SUB+=	COVERAGER=""
+.else
+PLIST_SUB+=	COVERAGER="@comment "
+.endif
+
+post-build:
+	@${REINPLACE_CMD} 's|%%LOCALBASE%%|${LOCALBASE}|;s|%%PHP_EXT_DIR%%|${PHP_EXT_DIR}|' \
+		${WRKSRC}/xcache.ini
+
 do-install:
 	@${MKDIR} ${PREFIX}/lib/php/${PHP_EXT_DIR}
 	${INSTALL_DATA} ${WRKSRC}/modules/${PORTNAME}.so \
@@ -34,12 +49,22 @@ do-install:
 post-install:
 	@${MKDIR} ${EXAMPLESDIR}/admin
 	${INSTALL_DATA} ${WRKSRC}/admin/config.php.example \
+		${WRKSRC}/admin/help.php \
 		${WRKSRC}/admin/index.php \
 		${WRKSRC}/admin/tablesort.js \
 		${WRKSRC}/admin/xcache.css \
 		${WRKSRC}/admin/xcache.php \
 		${WRKSRC}/admin/xcache.tpl.php \
 		${EXAMPLESDIR}/admin
+.if defined(WITH_COVERAGER)
+	@${MKDIR} ${EXAMPLESDIR}/coverager
+	${INSTALL_DATA} ${WRKSRC}/coverager/config.php.example \
+		${WRKSRC}/coverager/coverager.css \
+		${WRKSRC}/coverager/coverager.php \
+		${WRKSRC}/coverager/coverager.tpl.php \
+		${WRKSRC}/coverager/index.php \
+		${EXAMPLESDIR}/coverager
+.endif
 	@${CAT} ${PKGMESSAGE}
 
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/xcache/distinfo b/www/xcache/distinfo
index 4d29c6fa7aa1..0fcfd9e82d5b 100644
--- a/www/xcache/distinfo
+++ b/www/xcache/distinfo
@@ -1,3 +1,3 @@
-MD5 (xcache-1.0-rc.tar.gz) = fecf8edfecc9468696a0d71009340a46
-SHA256 (xcache-1.0-rc.tar.gz) = 3c8ac00df37e690c8c23ca72bccf390712c21dfbe1fb12e55b14874e8a96676f
-SIZE (xcache-1.0-rc.tar.gz) = 132489
+MD5 (xcache-1.0.tar.gz) = a4e2ff36f16b096f24d3edd9b6ab411b
+SHA256 (xcache-1.0.tar.gz) = 5261222cb595d7e12e087feaf797b8e8c6283dc74a1f9f553b9466b02623ef40
+SIZE (xcache-1.0.tar.gz) = 70272
diff --git a/www/xcache/files/patch-xcache.ini b/www/xcache/files/patch-xcache.ini
new file mode 100644
index 000000000000..565bda77c3cd
--- /dev/null
+++ b/www/xcache/files/patch-xcache.ini
@@ -0,0 +1,50 @@
+--- xcache.ini.orig	Mon May 29 00:00:10 2006
++++ xcache.ini	Tue Jun  6 16:07:22 2006
+@@ -1,18 +1,15 @@
+ [xcache-common]
+-;; install as zend extension (recommended), normally "$extension_dir/xcache.so"
+-zend_extension = /usr/local/lib/php/extensions/non-debug-non-zts-xxx/xcache.so
+-;; For windows users, replace xcache.so with php_xcache.dll
+-zend_extension_ts = c:/php/extensions/php_xcache.dll
+-;; or install as extension, make sure your extension_dir setting is correct
+-; extension = xcache.so
+-;; or win32:
+-; extension = php_xcache.dll
++;; install as zend extension (recommended, but not working yet)
++;zend_extension = %%LOCALBASE%%/lib/php/%%PHP_EXT_DIR%%/xcache.so
++;zend_extension_ts = %%LOCALBASE%%/lib/php/%%PHP_EXT_DIR%%/xcache.so
++;; or install as extension
++extension = xcache.so
+ 
+ ; required for >=php5.1 if you turn XCache on
+ auto_globals_jit = Off
+ 
+ [xcache.admin]
+-xcache.admin.user = "mOo"
++xcache.admin.user = "admin"
+ ; xcache.admin.pass = md5($your_password)
+ xcache.admin.pass = ""
+ 
+@@ -20,8 +17,8 @@
+ ; ini only settings, all the values here is default unless explained
+ ; to disable: xcache.size=0
+ ; to enable : xcache.size=any size > 0 and your system mmap allows
+-xcache.size =                  0
+-; uncomment and set to cpu count (cat /proc/cpuinfo |grep -c processor)
++xcache.size =                32M
++; uncomment and set to cpu count
+ xcache.count =                 1
+ ; just a hash hints, you can always store count(items) > slots
+ xcache.slots =                8K
+@@ -34,11 +31,9 @@
+ xcache.test =                Off
+ ; N/A for /dev/zero
+ xcache.readonly_protection = Off
+-; for win32, xcache.mmap_path=anonymous map name, not file path
+ ; uncomment and change to "/tmp/xcache" for readonly protection
+ ; 2 group of php won't share the same /tmp/xcache
+ xcache.mmap_path =    "/dev/zero"
+-
+ 
+ ; leave it blank(disabled) or "/tmp/phpcore/"
+ ; make sure it's writable by php (without checking open_basedir)
diff --git a/www/xcache/pkg-plist b/www/xcache/pkg-plist
index bfd615cf989f..273d03e5de2c 100644
--- a/www/xcache/pkg-plist
+++ b/www/xcache/pkg-plist
@@ -1,11 +1,18 @@
 lib/php/%%PHP_EXT_DIR%%/xcache.so
 @dirrmtry lib/php/%%PHP_EXT_DIR%%
 %%EXAMPLESDIR%%/admin/config.php.example
+%%EXAMPLESDIR%%/admin/help.php
 %%EXAMPLESDIR%%/admin/index.php
 %%EXAMPLESDIR%%/admin/tablesort.js
 %%EXAMPLESDIR%%/admin/xcache.css
 %%EXAMPLESDIR%%/admin/xcache.php
 %%EXAMPLESDIR%%/admin/xcache.tpl.php
+%%COVERAGER%%%%EXAMPLESDIR%%/coverager/config.php.example
+%%COVERAGER%%%%EXAMPLESDIR%%/coverager/coverager.css
+%%COVERAGER%%%%EXAMPLESDIR%%/coverager/coverager.php
+%%COVERAGER%%%%EXAMPLESDIR%%/coverager/coverager.tpl.php
+%%COVERAGER%%%%EXAMPLESDIR%%/coverager/index.php
 %%EXAMPLESDIR%%/xcache.ini
 @dirrm %%EXAMPLESDIR%%/admin
+%%COVERAGER%%@dirrm %%EXAMPLESDIR%%/coverager
 @dirrm %%EXAMPLESDIR%%
-- 
cgit v1.2.3