From 6a398052e0b75b93f5f2dd6ca94f3102e4ed89a2 Mon Sep 17 00:00:00 2001
From: Martin Wilke <miwi@FreeBSD.org>
Date: Wed, 3 Jan 2007 16:06:20 +0000
Subject: The [[TracNav]] macro implements fully customizable navigation bar
 for the Trac wiki engine. The contents of the navigation bar is a wiki page
 itself and can be edited like any other wiki page. The navigation bar
 supports hierarchical ordering of topics.

WWW: http://trac-hacks.org/wiki/TracNav

PR:		ports/107462
Submitted by:	Gerrit Beine <gerrit.beine at gmx.de>
---
 www/trac-nav/Makefile  | 30 ++++++++++++++++++++++++++++++
 www/trac-nav/distinfo  |  3 +++
 www/trac-nav/pkg-descr |  6 ++++++
 www/trac-nav/pkg-plist |  1 +
 4 files changed, 40 insertions(+)
 create mode 100644 www/trac-nav/Makefile
 create mode 100644 www/trac-nav/distinfo
 create mode 100644 www/trac-nav/pkg-descr
 create mode 100644 www/trac-nav/pkg-plist

(limited to 'www/trac-nav')

diff --git a/www/trac-nav/Makefile b/www/trac-nav/Makefile
new file mode 100644
index 000000000000..851ed80329e3
--- /dev/null
+++ b/www/trac-nav/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: trac-nav
+# Date created:                      January 03 2007
+# Whom:                              Gerrit Beine <gerrit.beine@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	nav
+PORTVERSION=	3.92p6
+CATEGORIES=	www devel python
+MASTER_SITES=	http://www.gerritbeine.de/downloads/trac-hacks/
+PKGNAMEPREFIX=	trac-
+DISTNAME=	TracNav-${PORTVERSION:S/p/pre/}
+
+MAINTAINER=	gerrit.beine@gmx.de
+COMMENT=	A fully customizable navigation bar for Trac
+
+BUILD_DEPENDS+=	easy_install:${PORTSDIR}/devel/py-setuptools \
+		tracd:${PORTSDIR}/www/trac
+RUN_DEPENDS+=	${BUILD_DEPENDS}
+
+USE_ZIP=	yes
+USE_PYTHON=	2.3+
+USE_PYDISTUTILS=yes
+PLIST_SUB+=	PORTVERSION=${PORTVERSION:S/p/pre/} PYTHONVERSION=${_PYTHON_VERSION}
+
+do-build:
+	@${DO_NADA}
+
+.include <bsd.port.mk>
diff --git a/www/trac-nav/distinfo b/www/trac-nav/distinfo
new file mode 100644
index 000000000000..c5680b565edb
--- /dev/null
+++ b/www/trac-nav/distinfo
@@ -0,0 +1,3 @@
+MD5 (TracNav-3.92pre6.zip) = 96d56563518088709906a175e92e257b
+SHA256 (TracNav-3.92pre6.zip) = 97059471822ff066b988d858cf572d089e95d545176c808ab107d796028dcbcb
+SIZE (TracNav-3.92pre6.zip) = 15680
diff --git a/www/trac-nav/pkg-descr b/www/trac-nav/pkg-descr
new file mode 100644
index 000000000000..6175851c26aa
--- /dev/null
+++ b/www/trac-nav/pkg-descr
@@ -0,0 +1,6 @@
+The [[TracNav]] macro implements fully customizable navigation bar for the Trac
+wiki engine. The contents of the navigation bar is a wiki page itself and can
+be edited like any other wiki page. The navigation bar supports hierarchical
+ordering of topics.
+
+WWW: http://trac-hacks.org/wiki/TracNav
diff --git a/www/trac-nav/pkg-plist b/www/trac-nav/pkg-plist
new file mode 100644
index 000000000000..02facd52a8d7
--- /dev/null
+++ b/www/trac-nav/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/TracNav-%%PORTVERSION%%-py%%PYTHONVERSION%%.egg
-- 
cgit v1.2.3