From d3007b43e7929d4010bd442883a4813c24f744af Mon Sep 17 00:00:00 2001
From: Martin Wilke <miwi@FreeBSD.org>
Date: Wed, 27 Feb 2008 07:37:12 +0000
Subject: - Update to 6.1.5

PR:		121091
Submitted by:	Ports Fury
---
 www/swish++/Makefile               |  6 ++----
 www/swish++/distinfo               |  6 +++---
 www/swish++/files/patch-elements.c | 11 -----------
 3 files changed, 5 insertions(+), 18 deletions(-)
 delete mode 100644 www/swish++/files/patch-elements.c

(limited to 'www/swish++')

diff --git a/www/swish++/Makefile b/www/swish++/Makefile
index ac94036d2069..6c5cc43b3aee 100644
--- a/www/swish++/Makefile
+++ b/www/swish++/Makefile
@@ -7,10 +7,9 @@
 #
 
 PORTNAME=	swish++
-PORTVERSION=	6.1.4
+PORTVERSION=	6.1.5
 CATEGORIES=	www textproc
-MASTER_SITES=	${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR=	swishplusplus
+MASTER_SITES=	SF/swishplusplus
 
 MAINTAINER=	ports@FreeBSD.org
 COMMENT=	Simple Web Indexing System for Humans: C++ version
@@ -19,7 +18,6 @@ RUN_DEPENDS=	wget:${PORTSDIR}/ftp/wget
 
 USE_PERL5=	yes
 USE_GMAKE=	yes
-USE_GCC=	3.4+
 MAKEFILE=	GNUmakefile
 MAKE_ENV=	PTHREAD_LIBS=${PTHREAD_LIBS} \
 		PERL=${PERL} PERL_VER=${PERL_VER}
diff --git a/www/swish++/distinfo b/www/swish++/distinfo
index f0fe8c75ed0b..425890a39bd9 100644
--- a/www/swish++/distinfo
+++ b/www/swish++/distinfo
@@ -1,3 +1,3 @@
-MD5 (swish++-6.1.4.tar.gz) = 08c0eac88e4f08c353037b893e243268
-SHA256 (swish++-6.1.4.tar.gz) = 35e2c3d98a0cfd8c9fac45b7e12d13462e2521f025daac81045e697f403721f7
-SIZE (swish++-6.1.4.tar.gz) = 302123
+MD5 (swish++-6.1.5.tar.gz) = af755e4c7477fd1c05634596d6a9ff00
+SHA256 (swish++-6.1.5.tar.gz) = 497b7d1f5dada146b74d82f787a1767a3713402e018b1e693cb7f6191db88d86
+SIZE (swish++-6.1.5.tar.gz) = 320082
diff --git a/www/swish++/files/patch-elements.c b/www/swish++/files/patch-elements.c
deleted file mode 100644
index ab3bd53c87e5..000000000000
--- a/www/swish++/files/patch-elements.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- mod/html/elements.c.orig	2007-07-31 20:12:01.000000000 +0200
-+++ mod/html/elements.c	2007-07-31 20:12:22.000000000 +0200
-@@ -295,7 +295,7 @@
-         // become overly pedantic about casting to enums.
-         //
-         element::end_tag_type const
--            v = (element::end_tag_type const)(int const)(p[1]);
-+            v = (element::end_tag_type const)(intptr_t const)(p[1]);
-         element &e = insert( value_type( *p++, element( v ) ) ).first->second;
- 
-         switch ( v ) {
-- 
cgit v1.2.3