From 6988580bcb421c37d687578fbde71bb0b2c683a3 Mon Sep 17 00:00:00 2001
From: Ying-Chieh Liao <ijliao@FreeBSD.org>
Date: Sat, 7 Jul 2001 13:13:48 +0000
Subject: add mod_put An Apache module that provides PUT and DELETE methods

PR:		28414
Submitted by:	Joao Carlos Mendes Luis <jonny@jonny.eng.br>
---
 www/mod_put/Makefile    | 34 ++++++++++++++++++++++++++++++++++
 www/mod_put/distinfo    |  1 +
 www/mod_put/pkg-comment |  1 +
 www/mod_put/pkg-descr   |  5 +++++
 www/mod_put/pkg-plist   |  5 +++++
 5 files changed, 46 insertions(+)
 create mode 100644 www/mod_put/Makefile
 create mode 100644 www/mod_put/distinfo
 create mode 100644 www/mod_put/pkg-comment
 create mode 100644 www/mod_put/pkg-descr
 create mode 100644 www/mod_put/pkg-plist

(limited to 'www/mod_put')

diff --git a/www/mod_put/Makefile b/www/mod_put/Makefile
new file mode 100644
index 000000000000..31217ddb2d48
--- /dev/null
+++ b/www/mod_put/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for:	mod_put Apache module
+# Date created:		Jun 26 2001
+# Whom:			Joao Carlos Mendes Luis <jonny@jonny.eng.br>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	mod_put
+PORTVERSION=	1.3
+CATEGORIES=	www
+MASTER_SITES=	http://hpwww.ec-lyon.fr/~vincent/apache/
+DISTFILES=	mod_put.tar.gz
+
+MAINTAINER=	ports@FreeBSD.org
+
+BUILD_DEPENDS=	${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
+RUN_DEPENDS=	${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
+
+DIST_SUBDIR=	${PORTNAME}-${PORTVERSION}
+
+do-build:
+	cd ${WRKSRC} && ${LOCALBASE}/sbin/apxs -c ${PORTNAME}.c
+
+do-install:
+	cd ${WRKSRC} && ${LOCALBASE}/sbin/apxs -A -i ${PORTNAME}.so
+
+.if !defined(NOPORTDOCS)
+post-install:
+	@${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
+	@${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.html \
+		${PREFIX}/share/doc/${PORTNAME}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/mod_put/distinfo b/www/mod_put/distinfo
new file mode 100644
index 000000000000..77cafdb938d4
--- /dev/null
+++ b/www/mod_put/distinfo
@@ -0,0 +1 @@
+MD5 (mod_put-1.3/mod_put.tar.gz) = 23e3c9925c200ccc5913c43b371da32c
diff --git a/www/mod_put/pkg-comment b/www/mod_put/pkg-comment
new file mode 100644
index 000000000000..94fcb4f2018d
--- /dev/null
+++ b/www/mod_put/pkg-comment
@@ -0,0 +1 @@
+An Apache module that provides PUT and DELETE methods
diff --git a/www/mod_put/pkg-descr b/www/mod_put/pkg-descr
new file mode 100644
index 000000000000..1024580cfbb1
--- /dev/null
+++ b/www/mod_put/pkg-descr
@@ -0,0 +1,5 @@
+This small module implements the HTTP/1.1 PUT and DELETE methods.
+Please notice that it can be a big security hole to activate them
+without securing the web server.
+
+WWW: http://hpwww.ec-lyon.fr/~vincent/apache/mod_put.html
diff --git a/www/mod_put/pkg-plist b/www/mod_put/pkg-plist
new file mode 100644
index 000000000000..1f94b8812768
--- /dev/null
+++ b/www/mod_put/pkg-plist
@@ -0,0 +1,5 @@
+libexec/apache/mod_put.so
+%%PORTDOCS%%share/doc/mod_put/mod_put.html
+%%PORTDOCS%%@dirrm share/doc/mod_put
+@exec ${PKG_PREFIX}/sbin/apxs -e -A -n put mod_put.so; echo "	enable the mod_put in Apache's config manually"
+@unexec ${PKG_PREFIX}/sbin/apxs -e -A -n put mod_put.so || echo " remove the mod_put from Apache's config manually"
-- 
cgit v1.2.3