From b584ea4bbb0c0efae58e5e5a86077134bdc7c75a Mon Sep 17 00:00:00 2001
From: Kelly Yancey <kbyanc@FreeBSD.org>
Date: Sun, 20 Aug 2000 21:42:27 +0000
Subject: Update fcgi dev-kit to version 2.2.0. From the release announcement: 
 This release has a C++ lib, thread support (in the fcgiapp and 	Perl
 lib), and some platform fixes.

---
 www/fcgi/Makefile       |   5 +-
 www/fcgi/distinfo       |   2 +-
 www/fcgi/files/patch-ab | 167 +++++++++++++++++++-----------------------------
 www/fcgi/pkg-descr      |   4 --
 4 files changed, 68 insertions(+), 110 deletions(-)

(limited to 'www/fcgi')

diff --git a/www/fcgi/Makefile b/www/fcgi/Makefile
index 5b8c6abfb73d..ca5deb49f69a 100644
--- a/www/fcgi/Makefile
+++ b/www/fcgi/Makefile
@@ -6,9 +6,10 @@
 #
 
 PORTNAME=	fcgi-devkit
-PORTVERSION= 	2.1
+PORTVERSION= 	2.2.0
 CATEGORIES=	www
 MASTER_SITES=	http://www.fastcgi.com/dist/
+DISTNAME=	devkit_2.2.0
 
 MAINTAINER=	kbyanc@posi.net
 
@@ -25,7 +26,7 @@ post-install:
 .for i in fastcgi-prog-guide fastcgi-whitepaper
 	    ${MKDIR} ${PREFIX}/share/doc/${PORTNAME}/$i
 	    cd ${WRKSRC}/doc/$i && \
-                ${INSTALL_DATA} * ${PREFIX}/share/doc/${PORTNAME}/$i
+		${INSTALL_DATA} * ${PREFIX}/share/doc/${PORTNAME}/$i
 	    @if [ -f ${PREFIX}/share/doc/${PORTNAME}/$i/Makefile ]; then \
 		${RM} ${PREFIX}/share/doc/${PORTNAME}/$i/Makefile; \
 	    fi
diff --git a/www/fcgi/distinfo b/www/fcgi/distinfo
index 87af0d1663b0..863344487565 100644
--- a/www/fcgi/distinfo
+++ b/www/fcgi/distinfo
@@ -1 +1 @@
-MD5 (fcgi-devkit-2.1.tar.gz) = c397edce40036372d230193223549f98
+MD5 (devkit_2.2.0.tar.gz) = eb73624d7dcb3a3f2fca3f86f09a518c
diff --git a/www/fcgi/files/patch-ab b/www/fcgi/files/patch-ab
index 6fc891d78bd7..24e017a24c9e 100644
--- a/www/fcgi/files/patch-ab
+++ b/www/fcgi/files/patch-ab
@@ -1,103 +1,64 @@
-*** libfcgi/os_unix.c.orig	Sat Feb  6 00:08:33 1999
---- libfcgi/os_unix.c	Thu May 13 10:32:00 1999
-***************
-*** 412,420 ****
-   */
-  int OS_Read(int fd, char * buf, size_t len)
-  {
-!     return(read(fd, buf, len));
-  }
-! 
-  /*
-   *--------------------------------------------------------------
-   *
---- 412,424 ----
-   */
-  int OS_Read(int fd, char * buf, size_t len)
-  {
-!     int result;
-!     do {
-! 	result = read(fd, buf, len);
-!     } while((result == -1) && (errno == EINTR));
-!     return(result);
-  }
-! 
-  /*
-   *--------------------------------------------------------------
-   *
-***************
-*** 433,442 ****
-   */
-  int OS_Write(int fd, char * buf, size_t len)
-  {
-!     return(write(fd, buf, len));
-  }
-  
-- 
-  /*
-   *----------------------------------------------------------------------
-   *
---- 437,449 ----
-   */
-  int OS_Write(int fd, char * buf, size_t len)
-  {
-!     int result;
-!     do {
-! 	result = write(fd, buf, len);
-!     } while((result == -1) && (errno == EINTR));
-!     return(result);
-  }
-  
-  /*
-   *----------------------------------------------------------------------
-   *
-***************
-*** 761,768 ****
-       * any work to do.
-       */
-      if(numRdPosted == 0 && numWrPosted == 0) {
-!         selectStatus = select((maxFd+1), &readFdSetCpy, &writeFdSetCpy,
-!                               NULL, tmo);
-          if(selectStatus < 0) {
-              exit(errno);
-  	}
---- 768,777 ----
-       * any work to do.
-       */
-      if(numRdPosted == 0 && numWrPosted == 0) {
-! 	do {
-!             selectStatus = select((maxFd+1), &readFdSetCpy, &writeFdSetCpy,
-!                                   NULL, tmo);
-! 	} while ((selectStatus == -1) && (errno == EINTR));
-          if(selectStatus < 0) {
-              exit(errno);
-  	}
-***************
-*** 1020,1030 ****
-  {
-      struct timeval tval = { READABLE_UNIX_FD_DROP_DEAD_TIMEVAL };
-      fd_set read_fds;
-  
-      FD_ZERO(&read_fds);
-      FD_SET(fd, &read_fds);
-      
-!     return select(fd + 1, &read_fds, NULL, NULL, &tval) >= 0 && FD_ISSET(fd, &read_fds);
-  }
-  
-  /*
---- 1029,1043 ----
-  {
-      struct timeval tval = { READABLE_UNIX_FD_DROP_DEAD_TIMEVAL };
-      fd_set read_fds;
-+     int result;
-  
-      FD_ZERO(&read_fds);
-      FD_SET(fd, &read_fds);
-      
-!     do {
-! 	result = select(fd + 1, &read_fds, NULL, NULL, &tval);
-!     } while((result == -1) && (errno == EINTR));
-!     return result >= 0 && FD_ISSET(fd, &read_fds);
-  }
-  
-  /*
+--- libfcgi/os_unix.c.orig	Wed Aug  2 05:36:43 2000
++++ libfcgi/os_unix.c	Sun Aug 20 14:32:35 2000
+@@ -404,9 +404,13 @@
+  */
+ int OS_Read(int fd, char * buf, size_t len)
+ {
+-    return(read(fd, buf, len));
++    int result;
++    do {
++	result = read(fd, buf, len);
++    } while((result == -1) && (errno == EINTR));
++    return(result);
+ }
+-
++
+ /*
+  *--------------------------------------------------------------
+  *
+@@ -425,10 +429,13 @@
+  */
+ int OS_Write(int fd, char * buf, size_t len)
+ {
+-    return(write(fd, buf, len));
++    int result;
++    do {
++	result = write(fd, buf, len);
++    } while((result == -1) && (errno == EINTR));
++    return(result);
+ }
+ 
+-
+ /*
+  *----------------------------------------------------------------------
+  *
+@@ -753,8 +760,10 @@
+      * any work to do.
+      */
+     if(numRdPosted == 0 && numWrPosted == 0) {
+-        selectStatus = select((maxFd+1), &readFdSetCpy, &writeFdSetCpy,
+-                              NULL, tmo);
++	do {
++            selectStatus = select((maxFd+1), &readFdSetCpy, &writeFdSetCpy,
++                                  NULL, tmo);
++	} while ((selectStatus == -1) && (errno == EINTR));
+         if(selectStatus < 0) {
+             exit(errno);
+ 	}
+@@ -1020,11 +1029,15 @@
+ {
+     struct timeval tval = { READABLE_UNIX_FD_DROP_DEAD_TIMEVAL };
+     fd_set read_fds;
++    int result;
+ 
+     FD_ZERO(&read_fds);
+     FD_SET(fd, &read_fds);
+ 
+-    return select(fd + 1, &read_fds, NULL, NULL, &tval) >= 0 && FD_ISSET(fd, &read_fds);
++    do {
++      result = select(fd + 1, &read_fds, NULL, NULL, &tval);
++    } while((result == -1) && (errno == EINTR));
++    return result >= 0 && FD_ISSET(fd, &read_fds);
+ }
+ 
+ /*
diff --git a/www/fcgi/pkg-descr b/www/fcgi/pkg-descr
index 63bbb8fc9489..bdf61480cec5 100644
--- a/www/fcgi/pkg-descr
+++ b/www/fcgi/pkg-descr
@@ -15,10 +15,6 @@ FastCGI, then FastCGI applications get all the perks (mainly being *really*
 fast); if the server does not support FastCGI, then FastCGI applications
 behave exactly like standard CGIs.
 
-See http://www.fastcgi.com/ for more information about the benefits of
-FastCGI, for developer documentation, and for the Apache FastCGI module (to
-enable FastCGI support for the popular Apache web server).
-
 WWW: http://www.fastcgi.com/
 
   -Kelly
-- 
cgit v1.2.3