From 741aa714833b9bb1e9afaaf5124d3f5c60b5e49c Mon Sep 17 00:00:00 2001
From: Rong-En Fan <rafan@FreeBSD.org>
Date: Thu, 21 Aug 2008 06:18:49 +0000
Subject: Update CONFIGURE_ARGS for how we pass CONFIGURE_TARGET to configure
 script. Specifically, newer autoconf (> 2.13) has different semantic of the
 configure target. In short, one should use --build=CONFIGURE_TARGET instead
 of CONFIGURE_TARGET directly. Otherwise, you will get a warning and the old
 semantic may be removed in later autoconf releases.

To workaround this issue, many ports hack the CONFIGURE_TARGET variable
so that it contains the ``--build='' prefix.

To solve this issue, under the fact that some ports still have
configure script generated by the old autoconf, we use runtime detection
in the do-configure target so that the proper argument can be used.

Changes to Mk/*:
 - Add runtime detection magic in bsd.port.mk
 - Remove CONFIGURE_TARGET hack in various bsd.*.mk
 - USE_GNOME=gnometarget is now an no-op

Changes to individual ports, other than removing the CONFIGURE_TARGET hack:

= pkg-plist changed (due to the ugly CONFIGURE_TARGET prefix in * executables)
  - comms/gnuradio
  - science/abinit
  - science/elmer-fem
  - science/elmer-matc
  - science/elmer-meshgen2d
  - science/elmerfront
  - science/elmerpost

= use x86_64 as ARCH
  - devel/g-wrap

= other changes
  - print/magicfilter
    GNU_CONFIGURE -> HAS_CONFIGURE since it's not generated by autoconf

Total # of ports modified:  1,027
Total # of ports affected: ~7,000 (set GNU_CONFIGURE to yes)

PR:		126524 (obsoletes 52917)
Submitted by:	rafan
Tested on:	two pointyhat 7-amd64 exp runs (by pav)
Approved by:	portmgr (pav)
---
 www/cgicc/Makefile | 1 -
 1 file changed, 1 deletion(-)

(limited to 'www/cgicc')

diff --git a/www/cgicc/Makefile b/www/cgicc/Makefile
index 8b4879253e62..6775c33273ae 100644
--- a/www/cgicc/Makefile
+++ b/www/cgicc/Makefile
@@ -18,7 +18,6 @@ COMMENT=	A C++ class library for writing CGI applications
 USE_AUTOTOOLS=	libtool:15
 USE_GMAKE=	yes
 GNU_CONFIGURE=	yes
-CONFIGURE_TARGET=	--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
 MAKE_ARGS=	NOPORTDOCS=${NOPORTDOCS}
 USE_LDCONFIG=	yes
 
-- 
cgit v1.2.3