From 874ad3832bdc46d0e90cb52e09571296995d9ed8 Mon Sep 17 00:00:00 2001
From: Foxfair Hu <foxfair@FreeBSD.org>
Date: Tue, 27 Jul 1999 04:12:45 +0000
Subject: PR:			12799 Submitted by:		Jim Mock
 <jim@blues.ghis.net>

New port of bluefish, which is an HTML editor that uses gtk.  Future
versions will possibly include gnome support and it will be added to the
Makefile if/when it happens.

Bluefish is an advanced HTML editor that contains functionality for
PHP, SSI, and RXML.  It is designed for the experienced web designer.

WWW:   http://bluefish.linuxbox.com/
---
 www/bluefish/Makefile       | 34 +++++++++++++++++++++++
 www/bluefish/distinfo       |  1 +
 www/bluefish/files/patch-aa | 67 +++++++++++++++++++++++++++++++++++++++++++++
 www/bluefish/pkg-comment    |  1 +
 www/bluefish/pkg-descr      |  6 ++++
 www/bluefish/pkg-plist      |  7 +++++
 6 files changed, 116 insertions(+)
 create mode 100644 www/bluefish/Makefile
 create mode 100644 www/bluefish/distinfo
 create mode 100644 www/bluefish/files/patch-aa
 create mode 100644 www/bluefish/pkg-comment
 create mode 100644 www/bluefish/pkg-descr
 create mode 100644 www/bluefish/pkg-plist

(limited to 'www/bluefish')

diff --git a/www/bluefish/Makefile b/www/bluefish/Makefile
new file mode 100644
index 000000000000..bfcbd37fe4c2
--- /dev/null
+++ b/www/bluefish/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for:   bluefish
+# Version required:            0.3.2
+# Date created:                        25 July 1999
+# Whom:                                Jim Mock <jim@blues.ghis.net>
+#
+# $Id$
+#
+
+DISTNAME=	bluefish-0.3.2
+CATEGORIES=	www editors
+MASTER_SITES=	http://bluefish.linuxbox.com/download/ \
+		http://student.wau.nl/~olivier/bluefish/download/ \
+		http://ha-pc.cheque.uq.edu.au/download/
+
+MAINTAINER=	jim@blues.ghis.net
+
+LIB_DEPENDS=	gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+
+GTK_CONFIG?=	${X11BASE}/bin/gtk12-config
+
+USE_X_PREFIX=  yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}"
+
+post-install:
+	@strip ${PREFIX}/bin/bluefish
+.if !defined(NOPORTDOCS)
+	@${ECHO} "===>   Installing bluefish docs in ${PREFIX}/share/doc/bluefish"
+	@${ECHO} "===>   A manual is available online at http://bluefish.linuxbox.com/manual/"
+	@${MKDIR} ${PREFIX}/share/doc/bluefish && chmod a+rx ${PREFIX}/share/doc/bluefish
+	@${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/bluefish
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/bluefish/distinfo b/www/bluefish/distinfo
new file mode 100644
index 000000000000..83bbfe20f554
--- /dev/null
+++ b/www/bluefish/distinfo
@@ -0,0 +1 @@
+MD5 (bluefish-0.3.2.tar.gz) = 4debcd19a28b715056384af44cba9c5a
diff --git a/www/bluefish/files/patch-aa b/www/bluefish/files/patch-aa
new file mode 100644
index 000000000000..589e94389f33
--- /dev/null
+++ b/www/bluefish/files/patch-aa
@@ -0,0 +1,67 @@
+--- configure.orig     Tue Jul  6 16:57:38 1999
++++ configure  Sun Jul 25 09:46:50 1999
+@@ -841,8 +841,8 @@
+   x_includes="/usr/include"
+ fi
+
+-LIBS=`gtk-config --libs`
+-CFLAGS=`gtk-config --cflags`
++LIBS=`${GTK_CONFIG} --libs`
++CFLAGS=`${GTK_CONFIG} --cflags`
+
+ # Check whether --with-gtk-prefix or --without-gtk-prefix was given.
+ if test "${with_gtk_prefix+set}" = set; then
+@@ -872,18 +872,18 @@
+   if test x$gtk_config_exec_prefix != x ; then
+      gtk_config_args="$gtk_config_args --exec-prefix=$gtk_config_exec_prefix"
+      if test x${GTK_CONFIG+set} != xset ; then
+-        GTK_CONFIG=$gtk_config_exec_prefix/bin/gtk-config
++        GTK_CONFIG=$gtk_config_exec_prefix/bin/${GTK_CONFIG}
+      fi
+   fi
+   if test x$gtk_config_prefix != x ; then
+      gtk_config_args="$gtk_config_args --prefix=$gtk_config_prefix"
+      if test x${GTK_CONFIG+set} != xset ; then
+-        GTK_CONFIG=$gtk_config_prefix/bin/gtk-config
++        GTK_CONFIG=$gtk_config_prefix/bin/${GTK_CONFIG}
+      fi
+   fi
+
+-  # Extract the first word of "gtk-config", so it can be a program name with args.
+-set dummy gtk-config; ac_word=$2
++  # Extract the first word of "${GTK_CONFIG}", so it can be a program name with args.
++set dummy ${GTK_CONFIG}; ac_word=$2
+ echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
+ echo "configure:889: checking for $ac_word" >&5
+ if eval "test \"`echo '$''{'ac_cv_path_GTK_CONFIG'+set}'`\" = set"; then
+@@ -1019,10 +1019,10 @@
+   else
+      echo "$ac_t""no" 1>&6
+ #     if test "$GTK_CONFIG" = "no" ; then
+-#       echo "*** The gtk-config script installed by GTK could not be found"
++#       echo "*** The ${GTK_CONFIG} script installed by GTK could not be found"
+ #       echo "*** If GTK was installed in PREFIX, make sure PREFIX/bin is in"
+ #       echo "*** your path, or set the GTK_CONFIG environment variable to the"
+-#       echo "*** full path to gtk-config."
++#       echo "*** full path to ${GTK_CONFIG}."
+ #     else
+ #       if test -f conf.gtktest ; then
+ #        :
+@@ -1051,7 +1051,7 @@
+ #        [ echo "*** The test program failed to compile or link. See the file config.log for the"
+ #          echo "*** exact error that occured. This usually means GTK was incorrectly installed"
+ #          echo "*** or that you have moved GTK since it was installed. In the latter case, you"
+-#          echo "*** may want to edit the gtk-config script: $GTK_CONFIG" ])
++#          echo "*** may want to edit the ${GTK_CONFIG} script: $GTK_CONFIG" ])
+ #          CFLAGS="$ac_save_CFLAGS"
+ #          LIBS="$ac_save_LIBS"
+ #       fi
+@@ -1070,7 +1070,7 @@
+ fi
+
+ echo -n "checking where to put bluefish library files... "
+-install_location=/usr/local/lib/bluefish
++install_location=/usr/X11R6/lib/bluefish
+ # Check whether --with-install-location or --without-install-location was given.
+ if test "${with_install_location+set}" = set; then
+   withval="$with_install_location"
diff --git a/www/bluefish/pkg-comment b/www/bluefish/pkg-comment
new file mode 100644
index 000000000000..a6f00e3e8ef0
--- /dev/null
+++ b/www/bluefish/pkg-comment
@@ -0,0 +1 @@
+Bluefish is an HTML editor designed for the experienced web designer
diff --git a/www/bluefish/pkg-descr b/www/bluefish/pkg-descr
new file mode 100644
index 000000000000..8e47eaa6f247
--- /dev/null
+++ b/www/bluefish/pkg-descr
@@ -0,0 +1,6 @@
+Bluefish is an advanced HTML editor that contains functionality for
+PHP, SSI, and RXML.  It is designed for the experienced web designer.
+
+WWW:   http://bluefish.linuxbox.com/
+
+- Jim <jim@blues.ghis.net>
diff --git a/www/bluefish/pkg-plist b/www/bluefish/pkg-plist
new file mode 100644
index 000000000000..e227638cf35b
--- /dev/null
+++ b/www/bluefish/pkg-plist
@@ -0,0 +1,7 @@
+bin/bluefish
+lib/bluefish/php3_functions
+lib/bluefish/ssi_functions
+lib/bluefish/rxml_functions
+share/doc/bluefish/README
+@dirrm lib/bluefish
+@dirrm share/doc/bluefish
-- 
cgit v1.2.3