From ca684388d524eda563243055272e09a88a71825c Mon Sep 17 00:00:00 2001
From: Martin Wilke <miwi@FreeBSD.org>
Date: Sat, 22 Dec 2007 00:08:36 +0000
Subject: - Fix build with gcc 4.2

PR:		118900
Submitted by:	Pietro Cerutti <gahr@gahr.ch>
---
 news/grn/Makefile                     |  8 +-------
 news/grn/files/patch-libmutt_keymap.h | 11 +++++++++++
 news/grn/files/patch-libmutt_sort.h   |  8 ++++++++
 3 files changed, 20 insertions(+), 7 deletions(-)
 create mode 100644 news/grn/files/patch-libmutt_keymap.h
 create mode 100644 news/grn/files/patch-libmutt_sort.h

(limited to 'news/grn')

diff --git a/news/grn/Makefile b/news/grn/Makefile
index 9f967fb4db26..1705637250a3 100644
--- a/news/grn/Makefile
+++ b/news/grn/Makefile
@@ -26,14 +26,8 @@ CONFIGURE_ENV=	glibpath="${GLIB_CONFIG}" \
 		CPPFLAGS="-I${LOCALBASE}/include" \
 		LDFLAGS="-L${LOCALBASE}/lib"
 
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN=		Broken with gcc 4.2
-.endif
-
 post-patch:
 	@${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
 		${WRKSRC}/configure ${WRKSRC}/libmutt/configure
 
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/news/grn/files/patch-libmutt_keymap.h b/news/grn/files/patch-libmutt_keymap.h
new file mode 100644
index 000000000000..4b8e25f45d22
--- /dev/null
+++ b/news/grn/files/patch-libmutt_keymap.h
@@ -0,0 +1,11 @@
+--- libmutt/keymap.h.orig	2007-12-20 19:31:26.000000000 +0100
++++ libmutt/keymap.h	2007-12-20 19:32:04.000000000 +0100
+@@ -77,7 +77,7 @@
+ /* dokey() records the last real key pressed  */
+ extern int LastKey;
+ 
+-extern struct mapping_t Menus[];
++extern struct mapping_t *Menus;
+ 
+ struct binding_t
+ {
diff --git a/news/grn/files/patch-libmutt_sort.h b/news/grn/files/patch-libmutt_sort.h
new file mode 100644
index 000000000000..a255b09b31ba
--- /dev/null
+++ b/news/grn/files/patch-libmutt_sort.h
@@ -0,0 +1,8 @@
+--- libmutt/sort.h.orig	2007-12-20 19:32:43.000000000 +0100
++++ libmutt/sort.h	2007-12-20 19:32:55.000000000 +0100
+@@ -45,4 +45,4 @@
+ WHERE short SortAux INITVAL (SORT_DATE); /* auxiallary sorting method */
+ WHERE short SortAlias INITVAL (SORT_ALIAS);
+ 
+-extern const struct mapping_t SortMethods[];
++extern const struct mapping_t *SortMethods;
-- 
cgit v1.2.3