From ac8911a9d4f375b412a887da6f1743aae5000856 Mon Sep 17 00:00:00 2001
From: Jean-Yves Lefort <jylefort@FreeBSD.org>
Date: Mon, 7 Nov 2005 21:33:44 +0000
Subject: Workaround bpf non-blocking brokenness (kern/84823).

Submitted by:	Rudolf Cejka <cejkar@fit.vutbr.cz>
---
 net/trafshow/Makefile               |  1 +
 net/trafshow/files/patch-trafshow.c | 11 +++++++++++
 2 files changed, 12 insertions(+)
 create mode 100644 net/trafshow/files/patch-trafshow.c

(limited to 'net/trafshow')

diff --git a/net/trafshow/Makefile b/net/trafshow/Makefile
index 81f133465795..6909bc40de59 100644
--- a/net/trafshow/Makefile
+++ b/net/trafshow/Makefile
@@ -7,6 +7,7 @@
 
 PORTNAME=	trafshow
 PORTVERSION=	5.2.1
+PORTREVISION=	1
 PORTEPOCH=	1
 CATEGORIES=	net
 MASTER_SITES=	${MASTER_SITE_NETBSD} \
diff --git a/net/trafshow/files/patch-trafshow.c b/net/trafshow/files/patch-trafshow.c
new file mode 100644
index 000000000000..e2db3953903e
--- /dev/null
+++ b/net/trafshow/files/patch-trafshow.c
@@ -0,0 +1,11 @@
+--- trafshow.c.orig	Mon Jul 12 07:20:41 2004
++++ trafshow.c	Mon Nov  7 22:25:56 2005
+@@ -305,7 +305,7 @@
+ 			fprintf(stderr, "%s: %s\n", dp->name, buf);
+ 			err++;
+ 		}
+-		if (pcap_setnonblock(pd, 1, buf) < 0) {
++		if (pcap_setnonblock(pd, 0, buf) < 0) {
+ 			fprintf(stderr, "%s: %s\n", dp->name, buf);
+ 			pcap_close(pd);
+ 			err++;
-- 
cgit v1.2.3