From 7d63224d50526ea12a9066a1c831cb9509bf5187 Mon Sep 17 00:00:00 2001
From: Maxim Sobolev <sobomax@FreeBSD.org>
Date: Mon, 19 Mar 2001 19:14:32 +0000
Subject: Use IGNORE macros to bug user that he/she has to manually download
 distfile instead of failing rule. This will prevent bento from trying to
 build the port.

Submitted by:	bento
---
 net/socks5/Makefile | 13 +++----------
 1 file changed, 3 insertions(+), 10 deletions(-)

(limited to 'net/socks5')

diff --git a/net/socks5/Makefile b/net/socks5/Makefile
index b1a2d3095ce3..a4206f69391c 100644
--- a/net/socks5/Makefile
+++ b/net/socks5/Makefile
@@ -36,15 +36,8 @@ MAN1=		runsocks.1 socks5.1 stopsocks.1 socks5_clients.1
 MAN5=		libsocks5.conf.5 socks5.conf.5
 CONFIGURE_ENV=  LIBS=-lcrypt
 
-do-fetch:
-	@if [ ! -f ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ]; then \
-	  ${ECHO} ""; \
-	  ${ECHO} "NEC requires that you grab the dist files from their"; \
-	  ${ECHO} "web site at http://www.socks.nec.com.  Please make sure"; \
-	  ${ECHO} "you have ${DISTNAME}${EXTRACT_SUFX} in ${DISTDIR}"; \
-	  ${ECHO} "and run make again."; \
-	  ${ECHO} ""; \
-	  exit 1;\
-	fi
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE="NEC requires that you grab the dist files from their web site at http://www.socks.nec.com.  Please make sure you have ${DISTNAME}${EXTRACT_SUFX} in ${DISTDIR} and run make again."
+.endif
 
 .include <bsd.port.mk>
-- 
cgit v1.2.3