From b9d86aefb0256468821c93f209d11639412bd177 Mon Sep 17 00:00:00 2001
From: "David W. Chapman Jr." <dwcjr@FreeBSD.org>
Date: Mon, 17 Jun 2002 20:57:15 +0000
Subject: Fix package building as well as vfs module installation There are
 still more files that bento will complain about, but I don't have time to fix
 that immediately

Noticed by:	Udo.Schweigert@siemens.com
---
 net/samba/Makefile  |  8 +++++---
 net/samba/pkg-plist | 13 ++++++++-----
 2 files changed, 13 insertions(+), 8 deletions(-)

(limited to 'net/samba')

diff --git a/net/samba/Makefile b/net/samba/Makefile
index f8aca187fe40..b2b7eac8044e 100644
--- a/net/samba/Makefile
+++ b/net/samba/Makefile
@@ -7,6 +7,7 @@
 
 PORTNAME=	samba
 PORTVERSION=	2.2.5.p1
+PORTREVISION=	1
 CATEGORIES=	net
 MASTER_SITES=	ftp://ftp.samba.org/pub/samba/pre/ \
 		ftp://samba.anu.edu.au/pub/samba/pre/ \
@@ -159,14 +160,15 @@ post-install:
 	${INSTALL_PROGRAM} ${WRKDIR}/${DISTNAME}/examples/VFS/audit.so ${SAMBA_VFSDIR}
 .endif
 .if defined(WITH_RECYCLE)
-	${INSTALL_PROGRAM} ${WRKDIR}/${DISTNAME}/examples/VFS/recycle.so ${SAMBA_VFSDIR}
+	${INSTALL_PROGRAM} ${WRKDIR}/${DISTNAME}/examples/VFS/recycle/recycle.so ${SAMBA_VFSDIR}
 .endif
 .endif
 	${MKDIR} ${PREFIX}/share/examples/samba
 	${CP} -rp ${WRKDIR}/${DISTNAME}/examples/* ${PREFIX}/share/examples/samba
 .if defined(WITH_AUDIT) || defined(WITH_RECYCLE)
-	@${RM} -rf ${PREFIX}/share/examples/samba/VFS/.libs
-	@for file in Makefile.orig audit.o audit.so recycle.c.orig recycle.o recycle.so skel.o skel.so ; do \
+#	@${RM} -rf ${PREFIX}/share/examples/samba/VFS/.libs
+	${FIND} ${PREFIX}/share/examples/samba/VFS -type d -name ".libs" | ${XARGS} ${RM} -r
+	@for file in audit.o audit.so recycle/recycle.o recycle/recycle.so skel.o skel.so ; do \
 		${RM} ${PREFIX}/share/examples/samba/VFS/$${file} ; \
 	done
 .endif
diff --git a/net/samba/pkg-plist b/net/samba/pkg-plist
index 6502ddcc7c85..ae7780b670ef 100644
--- a/net/samba/pkg-plist
+++ b/net/samba/pkg-plist
@@ -177,10 +177,9 @@ sbin/swat
 %%PORTDOCS%%share/doc/samba/textdocs/WinNT.txt
 %%PORTDOCS%%share/doc/samba/textdocs/cifsntdomain.txt
 %%PORTDOCS%%share/doc/samba/textdocs/security_level.txt
+share/examples/samba/LDAP/.import2_smbpasswd.pl.swp
 share/examples/samba/LDAP/README
-share/examples/samba/LDAP/export2_smbpasswd.pl
 share/examples/samba/LDAP/export_smbpasswd.pl
-share/examples/samba/LDAP/import2_smbpasswd.pl
 share/examples/samba/LDAP/import_smbpasswd.pl
 share/examples/samba/LDAP/ldapchpasswd
 share/examples/samba/LDAP/ldapsync.pl
@@ -190,14 +189,17 @@ share/examples/samba/LDAP/samba-schema-netscapeds5.x
 share/examples/samba/LDAP/samba-schema.IBMSecureWay
 share/examples/samba/README
 share/examples/samba/VFS/.cvsignore
-share/examples/samba/VFS/Makefile
 share/examples/samba/VFS/README
-share/examples/samba/VFS/block/Makefile
 share/examples/samba/VFS/block/block.c
+share/examples/samba/VFS/block/block.o
+share/examples/samba/VFS/block/block.so
 share/examples/samba/VFS/block/samba-block.conf
 share/examples/samba/VFS/block/smb.conf
+share/examples/samba/VFS/recycle/README
+share/examples/samba/VFS/recycle/cleanup_recycle.pl
+share/examples/samba/VFS/recycle/recycle.c
+share/examples/samba/VFS/recycle/recycle.conf
 share/examples/samba/VFS/audit.c
-share/examples/samba/VFS/recycle.c
 share/examples/samba/VFS/skel.c
 share/examples/samba/appliance/Makefile
 share/examples/samba/appliance/README
@@ -253,6 +255,7 @@ share/swat/help/Samba-HOWTO-Collection.html
 share/swat/help/Samba-LDAP-HOWTO.html
 share/swat/help/Samba-PDC-HOWTO.html
 share/swat/help/UNIX_INSTALL.html
+share/swat/help/cups.html
 share/swat/help/findsmb.1.html
 share/swat/help/lmhosts.5.html
 share/swat/help/make_smbcodepage.1.html
-- 
cgit v1.2.3