From 364c01ced5ca3e8e1af89d3b8a64107aaa56b5b9 Mon Sep 17 00:00:00 2001
From: Tilman Keskinoz <arved@FreeBSD.org>
Date: Sun, 23 Mar 2003 22:54:09 +0000
Subject: accounts with a . are valid strip -> ${STRIP_CMD} while i'm here

PR:i		31462
Submitted by:	pirzyk
---
 net/rdist6/Makefile            |  4 ++--
 net/rdist6/files/patch-docmd.c | 11 +++++++++++
 2 files changed, 13 insertions(+), 2 deletions(-)
 create mode 100644 net/rdist6/files/patch-docmd.c

(limited to 'net/rdist6')

diff --git a/net/rdist6/Makefile b/net/rdist6/Makefile
index b63f9f00e5fb..6897ad9496a6 100644
--- a/net/rdist6/Makefile
+++ b/net/rdist6/Makefile
@@ -30,7 +30,7 @@ MAN8=		rdistd.8
 PLIST_SUB=	RDIST_NAME=${RDIST_NAME}
 
 post-install:
-	@strip ${PREFIX}/bin/${RDIST_NAME}
-	@strip ${PREFIX}/bin/rdistd
+	@${STRIP_CMD} ${PREFIX}/bin/${RDIST_NAME}
+	@${STRIP_CMD} ${PREFIX}/bin/rdistd
 
 .include <bsd.port.post.mk>
diff --git a/net/rdist6/files/patch-docmd.c b/net/rdist6/files/patch-docmd.c
new file mode 100644
index 000000000000..6577745a992f
--- /dev/null
+++ b/net/rdist6/files/patch-docmd.c
@@ -0,0 +1,11 @@
+--- src/docmd.c.orig	Mon Nov  9 20:08:32 1998
++++ src/docmd.c	Tue Oct 23 14:32:06 2001
+@@ -611,7 +624,7 @@
+ 		c = *cp;
+ 		if (c & 0200)
+ 			isbad = TRUE;
+-		if (!isalpha(c) && !isdigit(c) && c != '_' && c != '-')
++		if (!isalpha(c) && !isdigit(c) && c != '_' && c != '-' && c != '.' )
+ 			isbad = TRUE;
+ 	}
+ 
-- 
cgit v1.2.3