From 3089e65abd11c826c05575f91dadb6d3baa4cff1 Mon Sep 17 00:00:00 2001
From: Bruce M Simpson <bms@FreeBSD.org>
Date: Fri, 14 Nov 2003 21:39:55 +0000
Subject: Use net-snmp v5 by default. Add a switch, WITH_SNMP_4, to allow 4.x
 to be used instead. Bump PORTREVISION.

---
 net/quagga/Makefile                 | 5 +++--
 net/quagga/scripts/configure.quagga | 8 ++++++--
 2 files changed, 9 insertions(+), 4 deletions(-)

(limited to 'net/quagga')

diff --git a/net/quagga/Makefile b/net/quagga/Makefile
index 3fb211ae1faf..a5298569a165 100644
--- a/net/quagga/Makefile
+++ b/net/quagga/Makefile
@@ -7,7 +7,7 @@
 
 PORTNAME=	quagga
 PORTVERSION=	0.96.4
-PORTREVISION=	2
+PORTREVISION=	3
 CATEGORIES=	net ipv6
 MASTER_SITES=	http://quagga.net/download/
 
@@ -30,7 +30,7 @@ MAN1=		vtysh.1
 MAN8=		bgpd.8 ospf6d.8 ospfd.8 ripd.8 ripngd.8 zebra.8
 
 CONFIGURE_ARGS+=--includedir=${PREFIX}/include/quagga
-SCRIPTS_ENV=	WRKDIRPREFIX=${WRKDIRPREFIX}
+SCRIPTS_ENV=	WRKDIRPREFIX=${WRKDIRPREFIX} WITH_SNMP_4=${WITH_SNMP_4}
 
 pre-fetch:
 	@${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.quagga
@@ -78,6 +78,7 @@ pre-everything::
 	@${ECHO}
 	@${ECHO} "You can build ${PORTNAME} with the following options:"
 	@${ECHO}
+	@${ECHO} "WITH_SNMP_4       Force net-snmp 4.x to be used"
 	@${ECHO} "ENABLE_USER       Specify user to run Quagga suite as"
 	@${ECHO} "ENABLE_GROUP      Specify group to run Quagga suite as"
 	@${ECHO} "ENABLE_VTY_GROUP  Specify group for vty socket ownership"
diff --git a/net/quagga/scripts/configure.quagga b/net/quagga/scripts/configure.quagga
index 3801bd9f0624..d3ca743c6d42 100644
--- a/net/quagga/scripts/configure.quagga
+++ b/net/quagga/scripts/configure.quagga
@@ -3,7 +3,7 @@
 # configure - quagga compile time option configurator
 # by Bruce M Simpson <bms@FreeBSD.org>
 #
-# $FreeBSD: /tmp/pcvs/ports/net/quagga/scripts/Attic/configure.quagga,v 1.1 2003-11-05 15:19:55 bms Exp $
+# $FreeBSD: /tmp/pcvs/ports/net/quagga/scripts/Attic/configure.quagga,v 1.2 2003-11-14 21:39:55 bms Exp $
 
 if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
 	exit
@@ -69,8 +69,12 @@ while [ "$1" ]; do
 		echo 'CONFIGURE_ARGS+=	--enable-rtadv'
 		;;
 	SNMP)
-		echo 'LIB_DEPENDS+=	snmp.4:${PORTSDIR}/net/net-snmp:install'
 		echo 'CONFIGURE_ARGS+=	--enable-snmp'
+		if [ "x${WITH_SNMP_4}" != "x" ]; then
+			echo 'LIB_DEPENDS+=snmp.4:${PORTSDIR}/net/net-snmp4:install'
+		else
+			echo 'LIB_DEPENDS+=netsnmp.5:${PORTSDIR}/net/net-snmp:install'
+		fi
 		;;
 	TCPSOCKETS)
 		echo 'CONFIGURE_ARGS+=	--enable-tcp-zebra'
-- 
cgit v1.2.3