From 1848a58f4bd270ef811eb62940d0238dd23ccfa3 Mon Sep 17 00:00:00 2001
From: Vsevolod Stakhov <vsevolod@FreeBSD.org>
Date: Mon, 25 Jul 2005 14:33:19 +0000
Subject: Add WITH_SASL option.

PR:		ports/83145
Submitted by:	Boris Samorodov <bsam@ipt.ru>
Approved by:	perky (mentor)
---
 net/py-ldap2/Makefile | 29 +++++++++++++++++++++++++----
 1 file changed, 25 insertions(+), 4 deletions(-)

(limited to 'net/py-ldap2')

diff --git a/net/py-ldap2/Makefile b/net/py-ldap2/Makefile
index 0caec0ea84d1..b2e8489afb2f 100644
--- a/net/py-ldap2/Makefile
+++ b/net/py-ldap2/Makefile
@@ -6,6 +6,7 @@
 
 PORTNAME=	ldap2
 PORTVERSION=	2.0.8
+PORTREVISION=	1
 CATEGORIES=	net
 MASTER_SITES=	${MASTER_SITE_SOURCEFORGE}
 MASTER_SITE_SUBDIR=	python-ldap
@@ -19,11 +20,31 @@ USE_PYTHON=	yes
 USE_PYDISTUTILS=	yes
 USE_OPENLDAP=	yes
 USE_REINPLACE=	yes
+WANT_OPENLDAP_VER=	22
+
+REPLACE_ARGS=	-e 's=/opt/openldap-OPENLDAP_REL_ENG_2_2/include=${LOCALBASE}/include='
+
+.if defined(WITH_SASL)
+WANT_OPENLDAP_SASL=	yes
+REPLACE_ARGS+=	-e 's=/usr/include/sasl=${LOCALBASE}/include/sasl=' \
+		-e 's=/opt/openldap-OPENLDAP_REL_ENG_2_2/lib=${LOCALBASE}/lib ${LOCALBASE}/lib/sasl2='
+CONFLICTS+=	openldap22-client-2.*
+.else
+REPLACE_ARGS+=	-e 's=ldap_r lber ssl crypto sasl2=ldap_r lber ssl crypto=' \
+		-e 's=/opt/openldap-OPENLDAP_REL_ENG_2_2/lib=${LOCALBASE}/lib='
+.endif
+
+pre-everything::
+	@${ECHO} "============================================================="
+	@${ECHO}
+	@${ECHO} "You can build ${PKGNAME} with the following options:"
+	@${ECHO}
+	@${ECHO} "WITH_SASL                with (Cyrus) SASL2 support"
+	@${ECHO}
+	@${ECHO} "============================================================="
+	@${ECHO}
 
 do-configure:
-	@${REINPLACE_CMD} -e "s=/opt/openldap-OPENLDAP_REL_ENG_2_2/lib=${LOCALBASE}/lib=" \
-		-e "s=/opt/openldap-OPENLDAP_REL_ENG_2_2/include=${LOCALBASE}/include=" \
-		-e "s=ldap_r lber ssl crypto sasl2=ldap_r lber ssl crypto=" \
-		${WRKSRC}/setup.cfg
+	@${REINPLACE_CMD} ${REPLACE_ARGS} ${WRKSRC}/setup.cfg
 
 .include <bsd.port.mk>
-- 
cgit v1.2.3