From 9e5632dd661f75b5801706e55659a4da501e49b5 Mon Sep 17 00:00:00 2001
From: Joe Marcus Clarke <marcus@FreeBSD.org>
Date: Fri, 9 Jul 2004 17:43:11 +0000
Subject: Apply a big libtool patch to allow porters to use the libtool
 installed by the libtoolX ports instead of the one included with each port. 
 Ports that set USE_LIBTOOL_VER=X will now use the ports version of libtool
 instead of the included version.  To restore previous behavior, use the new
 macro, USE_INC_LIBTOOL_VER.  Both macros accept the same argument: a libtool
 version.

For example, to use the ports version of libtool-1.5, add the following to
your Makefile:

USE_LIBTOOL_VER=        15

To use the included version of libtool with extra hacks provided by
libtool-1.5, add the following to your Makefile:

USE_INC_LIBTOOL_VER=    15

With this change, ports that had to add additional libtool hacks to prevent
.la files from being installed or to fix certain threading issues can now
delete those hacks (after appropriate testing, of course).

PR:		63944
Based on work by:eik and marcus
Approved by:	ade (autotools maintainer)
Tested by:	kris on pointyhat
Bound to be hidden problems:	You bet
---
 net/ortp/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

(limited to 'net/ortp')

diff --git a/net/ortp/Makefile b/net/ortp/Makefile
index 221bb6bd43c6..aa575c22c489 100644
--- a/net/ortp/Makefile
+++ b/net/ortp/Makefile
@@ -15,7 +15,7 @@ MAINTAINER=	sobomax@FreeBSD.org
 COMMENT=	A Real-time Transport Protocol (RTP) stack
 
 USE_GNOME=	glib20
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
 CONFIGURE_ARGS=	--with-html-dir=${PREFIX}/share/doc
 INSTALLS_SHLIB=	yes
 
-- 
cgit v1.2.3