From a33ff46559a729dda105d421c527ef916ed625bd Mon Sep 17 00:00:00 2001
From: Emanuel Haupt <ehaupt@FreeBSD.org>
Date: Tue, 25 Sep 2007 22:01:43 +0000
Subject: Fix a compilation error when CFLAGS are set in /etc/make.conf.

PR:		116631
Submitted by:	Beat Gaetzi <beat@chruetertee.ch>
---
 net/httping/Makefile             |  5 -----
 net/httping/files/patch-Makefile | 13 +++++++++++++
 2 files changed, 13 insertions(+), 5 deletions(-)
 create mode 100644 net/httping/files/patch-Makefile

(limited to 'net/httping')

diff --git a/net/httping/Makefile b/net/httping/Makefile
index e5d2d2b4d659..9b558fa8fcbf 100644
--- a/net/httping/Makefile
+++ b/net/httping/Makefile
@@ -19,11 +19,6 @@ COMMENT=	A ping-like tool for HTTP requests
 MAN1=		httping.1
 PLIST_FILES=	bin/httping
 
-CFLAGS+=	-DVERSION=\\\"${PORTVERSION}\\\"
-
-post-patch:
-	@${REINPLACE_CMD} -E '/^(DEBUG|CFLAGS)/d' ${WRKSRC}/${MAKEFILE}
-
 do-install:
 	${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
 	${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
diff --git a/net/httping/files/patch-Makefile b/net/httping/files/patch-Makefile
new file mode 100644
index 000000000000..bd6640c26e33
--- /dev/null
+++ b/net/httping/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.ori	Thu Jul 26 10:00:31 2007
++++ Makefile	Tue Sep 25 18:36:53 2007
+@@ -14,9 +14,8 @@
+ 
+ include version
+ 
+-DEBUG=-g # -D_DEBUG
+ LDFLAGS+=-lssl -lcrypto $(DEBUG)
+-CFLAGS+=-O2 -Wall -DVERSION=\"$(VERSION)\" $(DEBUG)
++CFLAGS+=-DVERSION=\"$(VERSION)\"
+ 
+ OBJS=mem.o http.o io.o str.o error.o utils.o main.o tcp.o mssl.o res.o
+ 
-- 
cgit v1.2.3