From 43133f5e9b7ee8954948d90ae61b931a9709f2d9 Mon Sep 17 00:00:00 2001
From: Steve Price <steve@FreeBSD.org>
Date: Mon, 15 Mar 1999 02:03:38 +0000
Subject: Update to version 1.4p4.

PR:		10205
Submitted by:	Michael Haro <mharo@area51.fremont.ca.us>
---
 net/cnet/Makefile       |  8 +++++---
 net/cnet/distinfo       |  2 +-
 net/cnet/files/patch-ab |  9 ---------
 net/cnet/files/patch-ad | 40 ++++++++++++++++++++++++++++++++++++++++
 4 files changed, 46 insertions(+), 13 deletions(-)
 create mode 100644 net/cnet/files/patch-ad

(limited to 'net/cnet')

diff --git a/net/cnet/Makefile b/net/cnet/Makefile
index 9d2467d11774..50d400298964 100644
--- a/net/cnet/Makefile
+++ b/net/cnet/Makefile
@@ -3,14 +3,16 @@
 # Date created:         Feb 8th, 1988
 # Whom:                 jkh
 #
-# $Id: Makefile,v 1.5 1998/09/21 22:15:56 steve Exp $
+# $Id: Makefile,v 1.6 1998/11/29 22:27:20 asami Exp $
 #
 
-DISTNAME=	cnet-1.4-3
-PKGNAME=	cnet-1.4p3
+DISTNAME=	cnet-1.4-4
+PKGNAME=	cnet-1.4p4
 CATEGORIES=	net
 MASTER_SITES=	http://www.cs.uwa.edu.au/pls/cnet/
 
+MAINTAINER=	ports@FreeBSD.org
+
 LIB_DEPENDS=	xview.3:${PORTSDIR}/x11-toolkits/xview-lib \
 		Xpm.4:${PORTSDIR}/graphics/xpm
 
diff --git a/net/cnet/distinfo b/net/cnet/distinfo
index 04724d32e0aa..af63c83c51be 100644
--- a/net/cnet/distinfo
+++ b/net/cnet/distinfo
@@ -1 +1 @@
-MD5 (cnet-1.4-3.tar.gz) = 2037adef9bbeb83b0c7f6792cdba5847
+MD5 (cnet-1.4-4.tar.gz) = 939ad439acd8db17bf056616b607c53e
diff --git a/net/cnet/files/patch-ab b/net/cnet/files/patch-ab
index 8375184d026d..405620e4094d 100644
--- a/net/cnet/files/patch-ab
+++ b/net/cnet/files/patch-ab
@@ -11,12 +11,3 @@
  #elif	defined(USE_SOLARIS2)
  #define	NDATASEGS		1
  #define	LENDATA_EVER_0		FALSE
-@@ -196,7 +200,7 @@
-     int			nlinks;
-     int			*links;
- 
--    int			errno;
-+    int			errorno;
-     CnetError		cnet_errno;
- 
-     unsigned long	length_data[NDATASEGS];
diff --git a/net/cnet/files/patch-ad b/net/cnet/files/patch-ad
new file mode 100644
index 000000000000..f8a4ed61f52d
--- /dev/null
+++ b/net/cnet/files/patch-ad
@@ -0,0 +1,40 @@
+patch-ad:
+--- src/compile.c.orig	Sun Jan 26 03:42:23 1997
++++ src/compile.c	Sat Feb 13 02:29:14 1999
+@@ -2,6 +2,7 @@
+ 
+ #include <fcntl.h>
+ #include <sys/stat.h>
++#include <dlfcn.h>
+ 
+ #if	!defined(MAXPATHLEN)
+ #define	MAXPATHLEN	1024
+@@ -25,6 +26,9 @@
+ #elif	defined(USE_IRIX5)
+ #include "irix5/compile.c"
+ 
++#elif	defined(USE_FREEBSD)
++#include "freebsd/compile.c"
++
+ #elif	defined(USE_LINUXAOUT)
+ #include "linuxaout/compile.c"
+ 
+@@ -263,7 +267,6 @@
+ 			int kflag; char **Cflags, *o_file, *c_file;
+ {
+     extern int	fork			_PARAMS((void));
+-    extern int	execvp			_PARAMS((const char *, char **));
+ 
+     struct stat	stat_c, stat_o;
+ 
+@@ -483,6 +486,10 @@
+ {
+ 
+ #define	RECIEVE		"[Rr][Ee][Cc][IiEe][Ee][Vv]"
++
++#if	defined(USE_FREEBSD)
++#include	<unistd.h>
++#endif
+ 
+ #if	defined(SVR4) || defined(__svr4__)
+ #include <regexpr.h>
-- 
cgit v1.2.3