From 5a9cc6bcfe49addc15729908305c927d329fa92b Mon Sep 17 00:00:00 2001
From: Sergey Matveychuk <sem@FreeBSD.org>
Date: Mon, 2 Aug 2004 08:33:10 +0000
Subject: NRG is a system for maintaining and visualizing network data and
 other resource utilization data.

PR:		ports/69504
Submitted by:	Michael Ranner <mranner@inode.at>
---
 net-mgmt/nrg/Makefile                           |  74 ++++++++++
 net-mgmt/nrg/distinfo                           |   2 +
 net-mgmt/nrg/files/nrg-apcupsdstat.patch        | 186 ++++++++++++++++++++++++
 net-mgmt/nrg/files/patch-examples               |  13 ++
 net-mgmt/nrg/files/patch-nrg-apachestat         |  50 +++++++
 net-mgmt/nrg/files/patch-nrg-bindstat           |  11 ++
 net-mgmt/nrg/files/patch-nrg-rrdkeeper          |  15 ++
 net-mgmt/nrg/files/patch-nrg-sendmailstat       |  11 ++
 net-mgmt/nrg/files/patch-roverpingd-Makefile.in |  13 ++
 net-mgmt/nrg/files/patch-roverpingd-receive.c   |  13 ++
 net-mgmt/nrg/files/run-nrg.sh                   |   7 +
 net-mgmt/nrg/pkg-descr                          |   9 ++
 net-mgmt/nrg/pkg-message                        |  11 ++
 net-mgmt/nrg/pkg-plist                          | 114 +++++++++++++++
 14 files changed, 529 insertions(+)
 create mode 100644 net-mgmt/nrg/Makefile
 create mode 100644 net-mgmt/nrg/distinfo
 create mode 100644 net-mgmt/nrg/files/nrg-apcupsdstat.patch
 create mode 100644 net-mgmt/nrg/files/patch-examples
 create mode 100644 net-mgmt/nrg/files/patch-nrg-apachestat
 create mode 100644 net-mgmt/nrg/files/patch-nrg-bindstat
 create mode 100644 net-mgmt/nrg/files/patch-nrg-rrdkeeper
 create mode 100644 net-mgmt/nrg/files/patch-nrg-sendmailstat
 create mode 100644 net-mgmt/nrg/files/patch-roverpingd-Makefile.in
 create mode 100644 net-mgmt/nrg/files/patch-roverpingd-receive.c
 create mode 100644 net-mgmt/nrg/files/run-nrg.sh
 create mode 100644 net-mgmt/nrg/pkg-descr
 create mode 100644 net-mgmt/nrg/pkg-message
 create mode 100644 net-mgmt/nrg/pkg-plist

(limited to 'net-mgmt/nrg')

diff --git a/net-mgmt/nrg/Makefile b/net-mgmt/nrg/Makefile
new file mode 100644
index 000000000000..1adccf05a47c
--- /dev/null
+++ b/net-mgmt/nrg/Makefile
@@ -0,0 +1,74 @@
+# New ports collection makefile for:   nrg
+# Date created:        18 January 2004
+# Whom:                Michael Ranner
+#
+# $FreeBSD$
+#
+
+PORTNAME=	nrg
+PORTVERSION=	0.99.22
+CATEGORIES=	net-mgmt sysutils
+MASTER_SITES=	ftp://nrg.hep.wisc.edu/pub/src/nrg/ \
+		http://www.ranner.jawa.at/stuff/
+
+MAINTAINER=	mranner@inode.at
+COMMENT=	Tool for visualizing network and resource utilization data
+
+BUILD_DEPENDS=	${SITE_PERL}/RRDp.pm:${PORTSDIR}/net/rrdtool \
+		${LOCALBASE}/bin/snmpget:${PORTSDIR}/net-mgmt/net-snmp4
+RUN_DEPENDS=	${BUILD_DEPENDS} \
+		${SITE_PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+
+NRG_WEB_PREFIX?=	${PREFIX}/www/data
+NRG_WEB_DIR?=		nrg
+NRG_WEB_TITLE?=		FreeBSD NRG Homepage
+
+NRG_DIR?=		nrg
+NRGDIR=			${NRG_DIR}
+DOCSDIR=		${NRGDIR}/html
+EXAMPLESDIR=	${NRGDIR}/examples
+
+SITE_PERL_ARCH=	${SITE_PERL}/${PERL_ARCH}
+
+PKGMESSAGE=		${WRKDIR}/pkg-message
+USE_PERL5=	yes
+USE_REINPLACE=	yes
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX}/${NRGDIR}
+ALL_TARGET=		pingd
+PLIST_SUB=		NRGDIR=${NRG_DIR}
+
+pre-fetch:
+	@${ECHO} ""
+	@${ECHO} "You may use the following build options:"
+	@${ECHO} ""
+	@${ECHO} "    -DWITH_APCNISCLIENT to build collector for nrg-apcupsdstat"
+	@${ECHO} ""
+
+.if defined(WITH_APCNISCLIENT)
+EXTRA_PATCHES+=	${PATCHDIR}/nrg-apcupsdstat.patch
+PLIST_FILES+=	nrg/bin/nrg-apcupsdstat
+.endif
+
+post-patch:
+	@${REINPLACE_CMD} -e "s,= @WEB_PREFIX@,= ${NRG_WEB_PREFIX},g" \
+		-e "s,= @NRG_WEB_DIR@,= ${NRG_WEB_DIR},g" \
+		-e "s,= @NRG_WEB_TITLE@,= \"${NRG_WEB_TITLE}\",g" \
+		${WRKSRC}/examples/Makefile.ops.in
+	@${REINPLACE_CMD} -e "s,<malloc.h>,<stdlib.h>,g" \
+		${WRKSRC}/roverpingd/send.c ${WRKSRC}/roverpingd/pingd.c \
+		${WRKSRC}/roverpingd/read_list.c
+	@${REINPLACE_CMD} -e "s,<values.h>,<limits.h>,g" \
+		-e "s, MAXINT, INT_MAX,g" \
+		${WRKSRC}/roverpingd/write_stats.c
+	@${REINPLACE_CMD} -e "s,-D__FreeBSD__,,g" \
+		${WRKSRC}/configure
+
+pre-install:
+	@${SED} 's|%%PREFIX%%|${PREFIX}|g' <${.CURDIR}/pkg-message >${PKGMESSAGE}
+
+post-install:
+	@${INSTALL_SCRIPT} ${FILESDIR}/run-nrg.sh ${PREFIX}/nrg/
+	@${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/nrg/distinfo b/net-mgmt/nrg/distinfo
new file mode 100644
index 000000000000..26b09797969a
--- /dev/null
+++ b/net-mgmt/nrg/distinfo
@@ -0,0 +1,2 @@
+MD5 (nrg-0.99.22.tar.gz) = 439242d8567aab1a375873128a34fc5c
+SIZE (nrg-0.99.22.tar.gz) = 2889103
diff --git a/net-mgmt/nrg/files/nrg-apcupsdstat.patch b/net-mgmt/nrg/files/nrg-apcupsdstat.patch
new file mode 100644
index 000000000000..1ec07df8aaf1
--- /dev/null
+++ b/net-mgmt/nrg/files/nrg-apcupsdstat.patch
@@ -0,0 +1,186 @@
+--- collectors/nrg-apcupsdstat.in.orig	Fri Mar  5 18:13:13 2004
++++ collectors/nrg-apcupsdstat.in	Fri Mar  5 18:13:13 2004
+@@ -0,0 +1,146 @@
++#!@PERL@
++#
++# nrg-apcupsdstat - a nrg collector for reporting apcupsd statistics
++#
++# options: temp and battery
++#
++# michael ranner <mranner@inode.at>
++#
++# $Id$
++#
++
++$mode = 'battery';
++$server = 'localhost';
++$port = '7000';
++$stamp = '0';
++$stat = '0';
++$apcnisclient = "/usr/local/bin/apcnisclient";
++
++#------------------------------------------------------------------
++# parse argv...
++
++while ( $ARGV[0] =~ /^-/ ) {
++  $arg = $ARGV[0];
++  if ( $arg =~ /^-d/ ) {
++    $debug = 1;
++    shift @ARGV;
++  } elsif ( $arg =~ /^-p/ ) {
++    $port = $ARGV[1];
++    shift @ARGV; shift @ARGV;
++  } elsif ( $arg =~ /^-m/ ) {
++    $mode = $ARGV[1];
++    shift @ARGV; shift @ARGV;
++  } else {
++    print "unknown option: \"$arg\"\n";
++    &usage;
++    exit 1;
++  }
++  $i++;
++}
++
++if ( $#ARGV != 0 ) { 
++  print "usage: nrg-apcupsdstat [args] apc_server\n";
++  exit;
++}
++$server = $ARGV[0];
++
++if ( $debug ) {
++  $date = `date`; chop $date;
++  print "nrg-apcupsdstat: started in debug mode at $date\n";
++  print "nrg-apcupsdstat: contacting $server at $port\n";
++}
++
++if ( $mode ne 'load' && $mode ne 'temp' && $mode ne 'battery'
++  && $mode ne 'inv' && $mode ne 'outv' && $mode ne 'battv' ) {
++  print "unknown mode: \"$mode\"\n";
++  &usage;
++  exit 1;
++}
++
++#------------------------------------------------------------------
++# get the stats from apc nis client...
++
++if ( $port !~ /^\d+$/ ) {
++  $port = getservbyname($port,'tcp') || &abend;
++}
++
++open(CLIENT, "$apcnisclient $server:$port status|");
++
++while(<CLIENT>) {
++  push(@details, $_);
++}
++close(CLIENT);
++
++if ( ! @details ) { &abend; }
++
++#------------------------------------------------------------------
++# parse the stats...
++
++foreach $_ (@details) {
++  ($n, $stamp) = split(": ") if /^DATE/;
++
++  if ($mode eq "battery") {
++    next if !/^BCHARGE/;
++    ($k, $n, $stat) = split;
++    last;
++  } elsif ($mode eq "battv") {
++    next if !/^BATTV/;
++    ($k, $n, $stat) = split;
++    last;
++  } elsif ($mode eq "inv") {
++    next if !/^LINEV/;
++    ($k, $n, $stat) = split;
++    last;
++  } elsif ($mode eq "load") {
++    next if !/^LOADPCT/;
++    ($k, $n, $stat) = split;
++    last;
++  } elsif ($mode eq "temp") {
++    next if !/^ITEMP/;
++    ($k, $n, $stat) = split;
++    last;
++  } elsif ($mode eq "outv") {
++    next if !/^OUTPUTV/;
++    ($k, $n, $stat) = split;
++    last;
++  }
++
++}
++
++$stamp = time;
++
++#------------------------------------------------------------------
++# print out nrg collector format output...
++
++if ( ! $stamp || ! $stat ) {
++  #print "nrg-apcupsdstat: could not get stats from $server!\n";
++  $stamp = time;
++  $details = "no stats from $server";
++} else {
++  $details = "$stat $mode GAUGE";
++}
++
++$localtime = scalar localtime($stamp);
++print "$stamp $localtime\n";
++print "INF uptime\n"; # FIXME
++print "$details\n";
++
++exit;
++
++#==================================================================
++
++sub usage {
++  print "usage: nrg-apcupsdstat [-d] [-p port] [-m mode] apc_server\n";
++}
++
++#------------------------------------------------------------------
++
++sub abend {
++  if ( $debug) {"nrg-sendmail: connection to $server:$port failed\n";}
++  $stamp = time;
++  $localtime = scalar localtime($stamp);
++  print "$stamp $localtime\n";
++  print "INF uptime\n";
++  print "connection to $server port $port failed\n";
++  exit;
++}
+--- Makefile.in.orig	Fri Jul 23 21:42:58 2004
++++ Makefile.in	Fri Jul 23 21:43:11 2004
+@@ -19,7 +19,7 @@
+ CONTRIB_DIR = ${prefix}/contrib
+ 
+ BIN_FILES = \
+-  dsreport mrtg2nrg nrg-apachestat nrg-autoconf \
++  dsreport mrtg2nrg nrg-apachestat nrg-apcupsdstat nrg-autoconf \
+   nrg-bindresponse nrg-bindstat nrg-bindstatd \
+   nrg-cgikeeper nrg-discover-apache nrg-discover-bind \
+   nrg-discover-errors nrg-discover-ifaces nrg-discover-netdev \
+--- configure.orig	Fri Jul 23 21:44:13 2004
++++ configure	Fri Jul 23 21:38:18 2004
+@@ -2019,6 +2019,7 @@
+   Makefile \
+   collectors/nrg-apmstat \
+   collectors/nrg-apachestat \
++  collectors/nrg-apcupsdstat \
+   collectors/nrg-bindresponse \
+   collectors/nrg-bindstat \
+   collectors/nrg-bindstatd \
+@@ -2189,6 +2190,7 @@
+   Makefile \
+   collectors/nrg-apmstat \
+   collectors/nrg-apachestat \
++  collectors/nrg-apcupsdstat \
+   collectors/nrg-bindresponse \
+   collectors/nrg-bindstat \
+   collectors/nrg-bindstatd \
+@@ -2312,6 +2314,7 @@
+ 
+ for f in \
+   collectors/nrg-apachestat \
++  collectors/nrg-apcupsdstat \
+   collectors/nrg-bindresponse \
+   collectors/nrg-bindstat \
+   collectors/nrg-bindstatd \
diff --git a/net-mgmt/nrg/files/patch-examples b/net-mgmt/nrg/files/patch-examples
new file mode 100644
index 000000000000..f5ddb0c11844
--- /dev/null
+++ b/net-mgmt/nrg/files/patch-examples
@@ -0,0 +1,13 @@
+--- ./examples/Makefile.ops.in.orig	Sun Jul 20 20:51:10 2003
++++ ./examples/Makefile.ops.in	Fri Mar  5 18:08:03 2004
+@@ -4,8 +4,8 @@
+ # $Id: Makefile.ops.in,v 1.41 2003/07/20 15:16:04 rader Exp $
+ #
+ 
+-WEB_PREFIX = /usr/local/web/html
+-NRG_WEB_TITLE = "Somesite's NRG Home Page"
++WEB_PREFIX = /usr/local/www/data
++NRG_WEB_TITLE = "FreeBSD NRG Homepage"
+ MCONF_FILES = NRG.mconf Site.mconf
+ NRG_WEB_DIR = nrg
+ 
diff --git a/net-mgmt/nrg/files/patch-nrg-apachestat b/net-mgmt/nrg/files/patch-nrg-apachestat
new file mode 100644
index 000000000000..e74401d8ff30
--- /dev/null
+++ b/net-mgmt/nrg/files/patch-nrg-apachestat
@@ -0,0 +1,50 @@
+--- ./collectors/nrg-apachestat.in.orig	Sun Jul 20 20:51:09 2003
++++ ./collectors/nrg-apachestat.in	Fri Mar  5 18:08:03 2004
+@@ -11,7 +11,7 @@
+ $mode = "requests";
+ $server = "localhost";
+ $port = "80";
+-$url = "server-status";
++$url = "server-status?auto";
+ $stamp = 0;
+ $stat = 0;
+ 
+@@ -88,15 +88,24 @@
+   # parse the stats...
+ 
+   while(<SOCK>) {
++  if ( $_ =~ /Uptime: (\d+)/ ) {
++	$uptime = $1;
++	last;
++  }
+   if ( $_ =~ /Server uptime:/ ) {
+     if ( $_ =~ /(\d+) hour/ ) { $uptime += $1*60*60; }
+     if ( $_ =~ /(\d+) minute/ ) { $uptime += $1*60; }
+     if ( $_ =~ /(\d+) second/ ) { $uptime += $1; }
+   }
+-  if ( $mode eq 'requests' && $_ =~ /Total accesses: (\d+)/ ) {
++  if ( $mode eq 'requests' && $_ =~ /Total accesses: (\d+)/i ) {
+     $stat = $1;
+     &debug("$stat accesses\n");
+-    last;
++	last if $url !~ /auto$/;
++  }
++  if ( $mode eq 'bytes' && $_ =~ /Total kBytes: (\d+)/ ) {
++    $stat = $1*1024;
++    &debug("$stat bytes\n");
++	last if $url !~ /auto$/;
+   }
+   if ( $mode eq 'bytes' && $_ =~ /Total Traffic: (\d+) kB/ ) {
+     $stat = $1*1024;
+@@ -105,6 +114,11 @@
+   }
+   if ( $mode eq 'bytes' && $_ =~ /Total Traffic: (\d+)\.(\d) MB/ ) {
+     $stat = ($1*1024*1024) + (($2/10)*1024*1024);
++    &debug("$stat bytes\n");
++    last;
++  }
++  if ( $mode eq 'bytes' && $_ =~ /Total Traffic: (\d+)\.(\d) GB/ ) {
++    $stat = ($1*1024*1024*1024) + (($2/10)*1024*1024*1024);
+     &debug("$stat bytes\n");
+     last;
+   }
diff --git a/net-mgmt/nrg/files/patch-nrg-bindstat b/net-mgmt/nrg/files/patch-nrg-bindstat
new file mode 100644
index 000000000000..e54f61e76292
--- /dev/null
+++ b/net-mgmt/nrg/files/patch-nrg-bindstat
@@ -0,0 +1,11 @@
+--- ./collectors/nrg-bindstat.in.orig	Sun Jul 20 20:51:09 2003
++++ ./collectors/nrg-bindstat.in	Fri Mar  5 18:08:03 2004
+@@ -24,7 +24,7 @@
+ $version = "4.9.6";
+ $mode = "queries";
+ $server = "localhost";
+-$port = "88888";
++$port = "28888";
+ $stamp = 0;
+ $stat = 0;
+ 
diff --git a/net-mgmt/nrg/files/patch-nrg-rrdkeeper b/net-mgmt/nrg/files/patch-nrg-rrdkeeper
new file mode 100644
index 000000000000..4a0cdff9dfc7
--- /dev/null
+++ b/net-mgmt/nrg/files/patch-nrg-rrdkeeper
@@ -0,0 +1,15 @@
+--- src/nrg-rrdkeeper.in.orig	Fri Mar  5 18:04:41 2004
++++ src/nrg-rrdkeeper.in	Fri Mar  5 18:05:19 2004
+@@ -631,6 +631,12 @@
+ 
+   }
+ 
++  $dir = $path;
++  $dir =~ s/[^\/]+.rrd//;
++  if (! -d $dir) {
++    system("mkdir -p $dir");
++  }
++
+   #print "RRDs::create @create_options \n";
+   RRDs::create @create_options;
+ 
diff --git a/net-mgmt/nrg/files/patch-nrg-sendmailstat b/net-mgmt/nrg/files/patch-nrg-sendmailstat
new file mode 100644
index 000000000000..a2a14d06fac2
--- /dev/null
+++ b/net-mgmt/nrg/files/patch-nrg-sendmailstat
@@ -0,0 +1,11 @@
+--- ./collectors/nrg-sendmailstat.in.orig	Sun Jul 20 20:51:09 2003
++++ ./collectors/nrg-sendmailstat.in	Fri Mar  5 18:08:03 2004
+@@ -13,7 +13,7 @@
+ 
+ $mode = 'msgs';
+ $server = 'localhost';
+-$port = '88889';
++$port = '28889';
+ $stamp = '0';
+ $stat = '0';
+ 
diff --git a/net-mgmt/nrg/files/patch-roverpingd-Makefile.in b/net-mgmt/nrg/files/patch-roverpingd-Makefile.in
new file mode 100644
index 000000000000..abacdc1eca29
--- /dev/null
+++ b/net-mgmt/nrg/files/patch-roverpingd-Makefile.in
@@ -0,0 +1,13 @@
+--- roverpingd/Makefile.in.orig	Sun Aug  1 20:51:19 2004
++++ roverpingd/Makefile.in	Sun Aug  1 20:51:29 2004
+@@ -6,8 +6,8 @@
+ SRCS = pingd.c read_list.c send.c receive.c sock.c packet.c write_stats.c
+ OBJS = pingd.o read_list.o send.o receive.o sock.o packet.o write_stats.o
+ 
+-CC = @CC@
+-CFLAGS = @CFLAGS@
++CC ?= @CC@
++CFLAGS ?= @CFLAGS@
+ LDFLAGS = @LDFLAGS@
+ #DEFINES = -D__DEBUG_DATA_POINTS__
+ DEFINES = 
diff --git a/net-mgmt/nrg/files/patch-roverpingd-receive.c b/net-mgmt/nrg/files/patch-roverpingd-receive.c
new file mode 100644
index 000000000000..d1b1df8332ba
--- /dev/null
+++ b/net-mgmt/nrg/files/patch-roverpingd-receive.c
@@ -0,0 +1,13 @@
+--- roverpingd/receive.c.orig	Sun Aug  1 15:55:04 2004
++++ roverpingd/receive.c	Sun Aug  1 15:55:43 2004
+@@ -170,9 +170,7 @@
+ #ifdef __DEBUG_DATA_POINTS__
+       /* assumes NUM_DATA_POINTS == 20... can't use loop here because */
+       /* because it will get interrupted causing disjointed output... */
+-      if ( debuggin) { fprintf(stderr,"node %d data...
+-  %d %d %d %d %d %d %d %d %d %d
+-  %d %d %d %d %d %d %d %d %d %d (next=%d)\n", 
++      if ( debuggin) { fprintf(stderr,"node %d data...\n %d %d %d %d %d %d %d %d %d %d\n %d %d %d %d %d %d %d %d %d %d (next=%d)\n", 
+         idx,
+         ping_list[idx]->n_latency_data[0], ping_list[idx]->n_latency_data[1],
+         ping_list[idx]->n_latency_data[2], ping_list[idx]->n_latency_data[3],
diff --git a/net-mgmt/nrg/files/run-nrg.sh b/net-mgmt/nrg/files/run-nrg.sh
new file mode 100644
index 000000000000..4beca07ecb25
--- /dev/null
+++ b/net-mgmt/nrg/files/run-nrg.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+LOG=/var/log/run-nrg.log
+
+#renice 5 -p $$ >/dev/null 2>&1
+/usr/local/nrg/run-nrg >$LOG
+#/usr/local/nrg/run-nrg.local >>$LOG
diff --git a/net-mgmt/nrg/pkg-descr b/net-mgmt/nrg/pkg-descr
new file mode 100644
index 000000000000..7c9bbb5bb1d4
--- /dev/null
+++ b/net-mgmt/nrg/pkg-descr
@@ -0,0 +1,9 @@
+NRG is a system for maintaining and visualizing network data and
+other resource utilization data. It automates the maintenance of
+RRDtool databases and graph web pages (that look like MRTG web
+pages.) NRG is primarily configured using very terse meta-
+configuration strings. These strings tell NRG to autodiscover
+network devices and verify that their current NRG configuration
+is correct.
+
+WWW: http://nrg.hep.wisc.edu/
diff --git a/net-mgmt/nrg/pkg-message b/net-mgmt/nrg/pkg-message
new file mode 100644
index 000000000000..7be9ccfb3646
--- /dev/null
+++ b/net-mgmt/nrg/pkg-message
@@ -0,0 +1,11 @@
+
+************************************************************
+
+For configuration and upgrade, please read file located at:
+%%PREFIX%%/nrg/html/index.html
+
+Afer configuration add the next line to crontab:
+*/5 * * * * %%PREFIX%%/nrg/run-nrg.sh
+
+************************************************************
+
diff --git a/net-mgmt/nrg/pkg-plist b/net-mgmt/nrg/pkg-plist
new file mode 100644
index 000000000000..c249ced1f369
--- /dev/null
+++ b/net-mgmt/nrg/pkg-plist
@@ -0,0 +1,114 @@
+%%NRGDIR%%/bin/dsreport
+%%NRGDIR%%/bin/mrtg2nrg
+%%NRGDIR%%/bin/nrg-apachestat
+%%NRGDIR%%/bin/nrg-autoconf
+%%NRGDIR%%/bin/nrg-bindresponse
+%%NRGDIR%%/bin/nrg-bindstat
+%%NRGDIR%%/bin/nrg-bindstatd
+%%NRGDIR%%/bin/nrg-cgikeeper
+%%NRGDIR%%/bin/nrg-discover-apache
+%%NRGDIR%%/bin/nrg-discover-bind
+%%NRGDIR%%/bin/nrg-discover-errors
+%%NRGDIR%%/bin/nrg-discover-ifaces
+%%NRGDIR%%/bin/nrg-discover-netdev
+%%NRGDIR%%/bin/nrg-discover-pingd
+%%NRGDIR%%/bin/nrg-discover-pvcs
+%%NRGDIR%%/bin/nrg-discover-sendmail
+%%NRGDIR%%/bin/nrg-discover-snmpd
+%%NRGDIR%%/bin/rrdmerge
+%%NRGDIR%%/bin/nrg-discover-tables
+%%NRGDIR%%/bin/nrg-discover-tcp
+%%NRGDIR%%/bin/nrg-find-confs
+%%NRGDIR%%/bin/nrg-indexmaker
+%%NRGDIR%%/bin/nrg-rrdkeeper
+%%NRGDIR%%/bin/nrg-pingdstat
+%%NRGDIR%%/bin/nrg-runmaker
+%%NRGDIR%%/bin/nrg-sendmailstat
+%%NRGDIR%%/bin/nrg-sendmailstatd
+%%NRGDIR%%/bin/nrg-snmpwalk
+%%NRGDIR%%/bin/nrg-spiketrimmer
+%%NRGDIR%%/bin/nrg-tablemaker
+%%NRGDIR%%/bin/nrg-tcpresponse
+%%NRGDIR%%/bin/rrdtrim
+%%NRGDIR%%/etc/nrg-oid-names
+%%NRGDIR%%/etc/run-star-head.pl
+%%NRGDIR%%/etc/run-star-tail.pl
+%%NRGDIR%%/templates/database-mrtg.rrd.tm
+%%NRGDIR%%/templates/discover-bind.tm
+%%NRGDIR%%/templates/discover-apache.tm
+%%NRGDIR%%/templates/discover-errors.tm
+%%NRGDIR%%/templates/discover-ifaces.tm
+%%NRGDIR%%/templates/discover-netdev.tm
+%%NRGDIR%%/templates/discover-pingd.tm
+%%NRGDIR%%/templates/discover-pvcs.tm
+%%NRGDIR%%/templates/discover-sendmail.tm
+%%NRGDIR%%/templates/discover-snmpd.tm
+%%NRGDIR%%/templates/discover-tables.tm
+%%NRGDIR%%/templates/discover-tcp.tm
+%%NRGDIR%%/templates/graph-current.cgi.tm
+%%NRGDIR%%/templates/graph-longterm.cgi.tm
+%%NRGDIR%%/templates/graph-mrtg.cgi.tm
+%%NRGDIR%%/templates/table-df.cgi.tm
+%%NRGDIR%%/templates/table-errors.cgi.tm
+%%NRGDIR%%/templates/table-ifaces.cgi.tm
+%%NRGDIR%%/templates/table-load.cgi.tm
+%%NRGDIR%%/templates/table-mem.cgi.tm
+%%NRGDIR%%/templates/table-ping-latency.cgi.tm
+%%NRGDIR%%/templates/table-ping-loss.cgi.tm
+%%NRGDIR%%/templates/table-swap.cgi.tm
+%%NRGDIR%%/templates/table-tcp.cgi.tm
+%%EXAMPLESDIR%%/Default.conf
+%%EXAMPLESDIR%%/NRG.mconf
+%%EXAMPLESDIR%%/Site.mconf
+%%EXAMPLESDIR%%/apache.mconf
+%%EXAMPLESDIR%%/bind.mconf
+%%EXAMPLESDIR%%/cisco.mconf
+%%EXAMPLESDIR%%/ftp.mconf
+%%EXAMPLESDIR%%/http.mconf
+%%EXAMPLESDIR%%/iface-errors.mconf
+%%EXAMPLESDIR%%/ifaces.mconf
+%%EXAMPLESDIR%%/imap.mconf
+%%EXAMPLESDIR%%/ping.mconf
+%%EXAMPLESDIR%%/pop.mconf
+%%EXAMPLESDIR%%/procurve.mconf
+%%EXAMPLESDIR%%/sendmail.mconf
+%%EXAMPLESDIR%%/smtp.mconf
+%%EXAMPLESDIR%%/ssh.mconf
+%%EXAMPLESDIR%%/trunk.mconf
+%%EXAMPLESDIR%%/unix.mconf
+%%DOCSDIR%%/apachestat.html
+%%DOCSDIR%%/bindstat.html
+%%DOCSDIR%%/changes
+%%DOCSDIR%%/collectors.html
+%%DOCSDIR%%/conf-string-list.html
+%%DOCSDIR%%/conf-strings.html
+%%DOCSDIR%%/configuration.html
+%%DOCSDIR%%/contrib.html
+%%DOCSDIR%%/index.html
+%%DOCSDIR%%/install.html
+%%DOCSDIR%%/log2rrd.html
+%%DOCSDIR%%/nrg+rrd.gif
+%%DOCSDIR%%/metaconf-strings.html
+%%DOCSDIR%%/metaconf.html
+%%DOCSDIR%%/mrtg-vs-nrg.html
+%%DOCSDIR%%/mrtg2nrg.html
+%%DOCSDIR%%/operation.html
+%%DOCSDIR%%/readme.html
+%%DOCSDIR%%/templates.html
+%%DOCSDIR%%/sample-conf.html
+%%DOCSDIR%%/sendmailstat.html
+%%DOCSDIR%%/upgrade.html
+%%DOCSDIR%%/whats-new
+%%NRGDIR%%/Makefile
+%%NRGDIR%%/Default.conf
+%%NRGDIR%%/NRG.mconf
+%%NRGDIR%%/Site.mconf
+%%NRGDIR%%/.VERSION
+%%NRGDIR%%/run-nrg.sh
+@dirrm %%NRGDIR%%/templates
+@dirrm %%NRGDIR%%/etc
+@dirrm %%NRGDIR%%/bin
+@dirrm %%NRGDIR%%/archive
+@dirrm %%EXAMPLESDIR%%
+@dirrm %%DOCSDIR%%
+@dirrm %%NRGDIR%%
-- 
cgit v1.2.3