From 1053946769cbc9f36d5baf35cc4f67a9cfd7c03a Mon Sep 17 00:00:00 2001
From: Aaron Dalton <aaron@FreeBSD.org>
Date: Wed, 26 Jul 2006 00:44:43 +0000
Subject: Adding port misc/fcalc, a calculator for photographic formulas.

PR:		ports/98837
Submitted by:	Serge Gagnon <serge.gagnon@b2b2c.ca>
---
 misc/Makefile        |  1 +
 misc/fcalc/Makefile  | 37 +++++++++++++++++++++++++++++++++++++
 misc/fcalc/distinfo  |  3 +++
 misc/fcalc/pkg-descr |  9 +++++++++
 misc/fcalc/pkg-plist | 34 ++++++++++++++++++++++++++++++++++
 5 files changed, 84 insertions(+)
 create mode 100644 misc/fcalc/Makefile
 create mode 100644 misc/fcalc/distinfo
 create mode 100644 misc/fcalc/pkg-descr
 create mode 100644 misc/fcalc/pkg-plist

(limited to 'misc')

diff --git a/misc/Makefile b/misc/Makefile
index 8dcff2e349d8..bdcdb604e762 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -80,6 +80,7 @@
     SUBDIR += ewipe
     SUBDIR += explosions
     SUBDIR += ezload
+    SUBDIR += fcalc
     SUBDIR += felis
     SUBDIR += fep
     SUBDIR += figlet
diff --git a/misc/fcalc/Makefile b/misc/fcalc/Makefile
new file mode 100644
index 000000000000..69782e84b8c2
--- /dev/null
+++ b/misc/fcalc/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for:	fcalc
+# Date Created:				11 jun 2006
+# Whom:					Serge Gagnon <serge.gagnon@b2b2c.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	fcalc
+PORTVERSION=	1
+CATEGORIES=	misc
+MASTER_SITES=	http://tangentsoft.net/fcalc/
+DISTNAME=	${PORTNAME}-tcl
+
+MAINTAINER=	serge.gagnon@b2b2c.ca
+COMMENT=	F/Calc is a calculator for photographic formulas
+
+RUN_DEPENDS=	${LOCALBASE}/lib/tix8.1/Tix.tcl:${PORTSDIR}/x11-toolkits/tix
+
+NO_BUILD=	yes
+USE_X_PREFIX=	yes
+USE_TK=	84
+
+WRKSRC=	${WRKDIR}/${PORTNAME}-1.00
+
+post-patch:
+	${REINPLACE_CMD} -e 's|BINDIR=/usr/local/bin|BINDIR=${PREFIX}/bin|' \
+		-e 's|LIBDIR=/usr/local/lib/fcalc|LIBDIR=${PREFIX}/lib/fcalc|' \
+		${WRKSRC}/INSTALL
+	${REINPLACE_CMD} -e 's|netscape|firefox|' ${WRKSRC}/Dialogs.tcl
+	${REINPLACE_CMD} -e 's|exec wish|exec wish8.4|' \
+		-e 's|^set libDir.*||' -e 's|^#set libDir|set libDir|' \
+		${WRKSRC}/fcalc
+
+do-install:
+	cd ${WRKSRC}; ./INSTALL
+
+.include <bsd.port.mk>
diff --git a/misc/fcalc/distinfo b/misc/fcalc/distinfo
new file mode 100644
index 000000000000..938c0852548d
--- /dev/null
+++ b/misc/fcalc/distinfo
@@ -0,0 +1,3 @@
+MD5 (fcalc-tcl.tar.gz) = b12b74f53f61110447ff8b90bf7eadd5
+SHA256 (fcalc-tcl.tar.gz) = db8fb22fe4082be38e5dda96c8676c5d3aa1f81ab0341260071ba15ecfd2f15d
+SIZE (fcalc-tcl.tar.gz) = 42711
diff --git a/misc/fcalc/pkg-descr b/misc/fcalc/pkg-descr
new file mode 100644
index 000000000000..32cddd431b99
--- /dev/null
+++ b/misc/fcalc/pkg-descr
@@ -0,0 +1,9 @@
+f/Calc is a calculator for photographic formulas. These formulas
+are at the heart of many interesting questions about the technical
+side of photography. You could compute these functions by hand, but
+they range from tedious to difficult, even with a good scientific
+calculator. When you let f/Calc do the hard work, you gain an
+intuitive feel for what the results mean, because you can quickly
+try new input values to see how they affect the result.
+
+WWW: http://tangentsoft.net/fcalc/
diff --git a/misc/fcalc/pkg-plist b/misc/fcalc/pkg-plist
new file mode 100644
index 000000000000..9b38394d560d
--- /dev/null
+++ b/misc/fcalc/pkg-plist
@@ -0,0 +1,34 @@
+bin/fcalc
+lib/fcalc/AoV.tcl
+lib/fcalc/Dialogs.tcl
+lib/fcalc/DoF.tcl
+lib/fcalc/FoV.tcl
+lib/fcalc/Hyperfocal.tcl
+lib/fcalc/LensMath.tcl
+lib/fcalc/Magnification.tcl
+lib/fcalc/SpotMeter.tcl
+lib/fcalc/fNumbers.tcl
+lib/fcalc/help/AoV.htm
+lib/fcalc/help/Credits.htm
+lib/fcalc/help/DoF.htm
+lib/fcalc/help/FNumber.htm
+lib/fcalc/help/FoV.htm
+lib/fcalc/help/Future.htm
+lib/fcalc/help/Hyperfocal.htm
+lib/fcalc/help/Introduction.htm
+lib/fcalc/help/License.htm
+lib/fcalc/help/Magnification.htm
+lib/fcalc/help/SpotMetering.htm
+lib/fcalc/help/angle-of-view.gif
+lib/fcalc/help/dof-far.gif
+lib/fcalc/help/dof-near.gif
+lib/fcalc/help/f-number-to-stops.gif
+lib/fcalc/help/fov-horz.gif
+lib/fcalc/help/fov-vert.gif
+lib/fcalc/help/hyperfocal.gif
+lib/fcalc/help/magnification.gif
+lib/fcalc/help/spot-metering.gif
+lib/fcalc/help/sqrt2.gif
+lib/fcalc/help/stops-to-f-number.gif
+@dirrm lib/fcalc/help
+@dirrm lib/fcalc
-- 
cgit v1.2.3