From 7883df5ea28a0934e59540ca93a33a726bb9aa07 Mon Sep 17 00:00:00 2001
From: "Jordan K. Hubbard" <jkh@FreeBSD.org>
Date: Sat, 24 Sep 1994 03:57:13 +0000
Subject: Mshell port from Jean-Marc Zucconi (jmz@thud.cdrom.com).  Jean-Marc
 is now our leading ports-supplier!  Let's all give him a big THANK YOU! :)
 Submitted by:	jmz

---
 misc/mshell/Makefile       | 18 ++++++++++++++
 misc/mshell/files/patch-aa | 62 ++++++++++++++++++++++++++++++++++++++++++++++
 misc/mshell/files/patch-ab | 46 ++++++++++++++++++++++++++++++++++
 misc/mshell/files/patch-ac | 19 ++++++++++++++
 misc/mshell/files/patch-ad | 19 ++++++++++++++
 misc/mshell/files/patch-ae | 22 ++++++++++++++++
 misc/mshell/pkg-comment    |  1 +
 misc/mshell/pkg-descr      | 10 ++++++++
 misc/mshell/pkg-plist      |  8 ++++++
 9 files changed, 205 insertions(+)
 create mode 100644 misc/mshell/Makefile
 create mode 100644 misc/mshell/files/patch-aa
 create mode 100644 misc/mshell/files/patch-ab
 create mode 100644 misc/mshell/files/patch-ac
 create mode 100644 misc/mshell/files/patch-ad
 create mode 100644 misc/mshell/files/patch-ae
 create mode 100644 misc/mshell/pkg-comment
 create mode 100644 misc/mshell/pkg-descr
 create mode 100644 misc/mshell/pkg-plist

(limited to 'misc/mshell')

diff --git a/misc/mshell/Makefile b/misc/mshell/Makefile
new file mode 100644
index 000000000000..0880f95790aa
--- /dev/null
+++ b/misc/mshell/Makefile
@@ -0,0 +1,18 @@
+DISTNAME=	mshell
+DISTFILES=	7432.Z
+MASTER_SITES=	ftp://src.doc.ic.ac.uk/usenet/alt.sources/articles/7000-7999/
+NO_WRKSUBDIR=	yes
+
+EXTRACT_COOKIE?=	${.CURDIR}/.extract_done
+
+extract: fetch pre-extract ${EXTRACT_COOKIE}
+
+${EXTRACT_COOKIE}:
+	@echo "===>  Extracting for ${DISTNAME}"
+	@rm -rf ${WRKDIR}
+	@mkdir -p ${WRKDIR}
+	zcat ${DISTDIR}/${DISTFILES} |(cd ${WRKDIR}; \
+	awk '{if (/^#!/) x++} {if(x) print $$0'}| /bin/sh)
+	@touch -f ${EXTRACT_COOKIE}
+
+.include <bsd.port.mk>
diff --git a/misc/mshell/files/patch-aa b/misc/mshell/files/patch-aa
new file mode 100644
index 000000000000..4dbbaa227a8c
--- /dev/null
+++ b/misc/mshell/files/patch-aa
@@ -0,0 +1,62 @@
+*** Makefile.orig	Sat Sep 24 02:37:56 1994
+--- Makefile	Sat Sep 24 02:39:11 1994
+***************
+*** 8,21 ****
+  #
+  # Check mshell.h for other options, e.g., max menu sizes.
+  
+! CFLAGS =  -O -DBSD -DMENUDIR='"/nyx/lib/menus"' -DLOGDIR='"/nyx/lib/logs"'
+  OBJS =	mshell.o main.o string.o functions1.o functions2.o chdir.o mail.o \
+  	settatr.o setenv.o xsystem.o dl.o macro.o
+  
+  mshell: $(OBJS)
+  	cc $(CFLAGS) $(OBJS) -lcurses -ltermcap -o mshell
+  
+  $(OBJS) : mshell.h
+  
+  clean:
+! 	rm *.o mshell
+--- 8,50 ----
+  #
+  # Check mshell.h for other options, e.g., max menu sizes.
+  
+! CFLAGS =  -O -DBSD -DMENUDIR='"/usr/local/lib/menus"' -DMAILDIR='"/var/mail/"' \
+! 	-DGLOBAL_MACRO_FILE='"/usr/local/lib/menus/macros"' \
+! 	-DCOMMAND_LIST='"/usr/local/lib/menus/commands"'
+  OBJS =	mshell.o main.o string.o functions1.o functions2.o chdir.o mail.o \
+  	settatr.o setenv.o xsystem.o dl.o macro.o
+  
++ all: mshell
++ 
+  mshell: $(OBJS)
+  	cc $(CFLAGS) $(OBJS) -lcurses -ltermcap -o mshell
+  
+  $(OBJS) : mshell.h
+  
+  clean:
+! 	rm -f *.o mshell
+! 
+! install: mshell
+! 	mkdir -p /usr/local/bin 
+! 	install -c -o bin mshell /usr/local/bin
+! 	mkdir -p /usr/local/lib/menus
+! 	sed -e s/dldir/HOME/g < sample.men > /usr/local/lib/menus/sample.men
+! 	install -c -m 644 menulogin /usr/local/lib/menus
+! 	mkdir -p /usr/local/man/man1
+! 	echo .Dd `/bin/date` > mshell.1
+! 	echo .Dt MSHELL 1 >> mshell.1
+! 	echo .Sh NAME >> mshell.1
+! 	echo .Nm mshell >> mshell.1
+! 	echo .Nd a Unix menuing shell >> mshell.1
+! 	echo .Sh SYNOPSIS >> mshell.1
+! 	echo .Nm mshell >> mshell.1
+! 	echo .Op Fl s >> mshell.1
+! 	echo .Ar menuname >> mshell.1
+! 	echo .Sh DESCRIPTION >> mshell.1
+! 	cat mshell.doc >>mshell.1
+! 	echo >>mshell.1
+! 	cat menu.doc >>mshell.1
+! 	echo >>mshell.1
+! 	echo .Sh AUTHOR >>mshell.1
+! 	echo Andrew Burt, aburt@du.edu >>mshell.1
+! 	install -m 644  mshell.1 /usr/local/man/man1
diff --git a/misc/mshell/files/patch-ab b/misc/mshell/files/patch-ab
new file mode 100644
index 000000000000..a7a739994612
--- /dev/null
+++ b/misc/mshell/files/patch-ab
@@ -0,0 +1,46 @@
+*** settatr.c.orig	Sat Sep 24 00:47:17 1994
+--- settatr.c	Sat Sep 24 00:49:46 1994
+***************
+*** 15,21 ****
+  	ioctl ( 0, TIOCGETP, &sg );
+  	if (access(".stty", 0) == -1) {	/* not already set up */
+  		sg.sg_erase = '';
+! 		sg.sg_kill  = '';
+  		sg.sg_flags |= XTABS;
+  	}
+  	sg.sg_flags |= ECHO;
+--- 15,21 ----
+  	ioctl ( 0, TIOCGETP, &sg );
+  	if (access(".stty", 0) == -1) {	/* not already set up */
+  		sg.sg_erase = '';
+! 		sg.sg_kill  = 21; /* ^U */
+  		sg.sg_flags |= XTABS;
+  	}
+  	sg.sg_flags |= ECHO;
+***************
+*** 25,36 ****
+  	ioctl ( 0, TIOCSETP, &sg );
+  
+  	ioctl ( 0, TIOCGETC, &tc );
+! 	tc.t_intrc  = '';
+  	ioctl ( 0, TIOCSETC, &tc );
+  
+  	ioctl ( 0, TIOCGLTC, &lt );
+! 	lt.t_werasc = '';
+! 	lt.t_rprntc = '';
+  	ioctl ( 0, TIOCSLTC, &lt );
+  #endif
+  #ifdef SYSV
+--- 25,36 ----
+  	ioctl ( 0, TIOCSETP, &sg );
+  
+  	ioctl ( 0, TIOCGETC, &tc );
+! 	tc.t_intrc  = 3; /* ^C */
+  	ioctl ( 0, TIOCSETC, &tc );
+  
+  	ioctl ( 0, TIOCGLTC, &lt );
+! 	lt.t_werasc = 23; /* ^W */
+! 	lt.t_rprntc = 18; /* ^R */
+  	ioctl ( 0, TIOCSLTC, &lt );
+  #endif
+  #ifdef SYSV
diff --git a/misc/mshell/files/patch-ac b/misc/mshell/files/patch-ac
new file mode 100644
index 000000000000..75efbcd0b77f
--- /dev/null
+++ b/misc/mshell/files/patch-ac
@@ -0,0 +1,19 @@
+*** functions1.c.orig	Sat Sep 24 00:51:45 1994
+--- functions1.c	Sat Sep 24 00:52:03 1994
+***************
+*** 15,21 ****
+  	FILE * fp;
+  	char record [DESCLEN];
+  	if (( fp = fopen (filename, "r")) == NULL ) {
+! 		printf ("\tNo such helpfile as %s\!\!\n", filename);
+  		return;
+  	}
+  
+--- 15,21 ----
+  	FILE * fp;
+  	char record [DESCLEN];
+  	if (( fp = fopen (filename, "r")) == NULL ) {
+! 		printf ("\tNo such helpfile as %s!!\n", filename);
+  		return;
+  	}
+  
diff --git a/misc/mshell/files/patch-ad b/misc/mshell/files/patch-ad
new file mode 100644
index 000000000000..03131f105ac0
--- /dev/null
+++ b/misc/mshell/files/patch-ad
@@ -0,0 +1,19 @@
+*** mshell.c.orig	Sat Sep 24 00:51:51 1994
+--- mshell.c	Sat Sep 24 00:52:20 1994
+***************
+*** 142,148 ****
+  
+  			if ( strcmp (action_string, NULLSTR) == 0 ) {
+  				invalid_option = TRUE;
+! 				printf ("\tNo such help option name as: %s\!\!\n", opt2);
+  			}
+  			else {
+  				tmpword[0] = EOS;
+--- 142,148 ----
+  
+  			if ( strcmp (action_string, NULLSTR) == 0 ) {
+  				invalid_option = TRUE;
+! 				printf ("\tNo such help option name as: %s!!\n", opt2);
+  			}
+  			else {
+  				tmpword[0] = EOS;
diff --git a/misc/mshell/files/patch-ae b/misc/mshell/files/patch-ae
new file mode 100644
index 000000000000..928f9c25b1d7
--- /dev/null
+++ b/misc/mshell/files/patch-ae
@@ -0,0 +1,22 @@
+*** string.c.orig	Fri Sep 23 18:34:06 1994
+--- string.c	Fri Sep 23 18:50:39 1994
+***************
+*** 4,9 ****
+--- 4,20 ----
+  #define strchr	index
+  #endif
+  
++ char *
++ gets (char *s)
++ {
++     char *x = fgets (s, WORDLEN, stdin);
++     if (x) {
++ 	char *p = strchr (x, '\n');
++ 	if (p) 
++ 	    *p = 0;
++     }
++     return x;
++ }
+  
+  /* function to find the position of sub_string in main_string 
+   * ---------------------------------------------------------- */
diff --git a/misc/mshell/pkg-comment b/misc/mshell/pkg-comment
new file mode 100644
index 000000000000..c5cbd853901f
--- /dev/null
+++ b/misc/mshell/pkg-comment
@@ -0,0 +1 @@
+Mshell: a Unix menuing shell
diff --git a/misc/mshell/pkg-descr b/misc/mshell/pkg-descr
new file mode 100644
index 000000000000..34ab28927554
--- /dev/null
+++ b/misc/mshell/pkg-descr
@@ -0,0 +1,10 @@
+Mshell was written to shield users (and other non-Unix gurus, like
+mathematicians and secretaries in the department) from "raw" Unix.  It
+is as flexible as you can get (supports full shell capabilties like
+pipes, etc. inside the menu commands) but simple to write menus for.
+It is was developped for Nyx, a free, public access Unix system. 
+Indeed, you're welcome to try Nyx -- log into Nyx as:
+
+	- telnet to nyx.cs.du.edu (130.253.192.68), user 'new'.
+	- call 303-871-3324
+
diff --git a/misc/mshell/pkg-plist b/misc/mshell/pkg-plist
new file mode 100644
index 000000000000..0a3c415a695b
--- /dev/null
+++ b/misc/mshell/pkg-plist
@@ -0,0 +1,8 @@
+@cd /usr/local
+@mode 644
+@owner bin
+lib/menus/sample.men
+lib/menus/menulogin
+man/man1/mshell.1
+@mode 755
+bin/mshell
-- 
cgit v1.2.3