From 5384f97a0555c4691c10dfad547e6fead458cd1d Mon Sep 17 00:00:00 2001
From: Max Khon <fjoe@FreeBSD.org>
Date: Tue, 6 Aug 2002 10:17:14 +0000
Subject: - build with libslang by default (and provide -DWITHOUT_SLANG knob) -
 fix LIB_DEPENDS for gettext - honor LOCALBASE for uzip - urar now works

---
 misc/mc/Makefile                     | 13 ++++++++++++-
 misc/mc/files/patch-aa               | 34 +++++++++++++++++++++++++++++-----
 misc/mc/files/patch-vfs::extfs::uzip | 10 ----------
 3 files changed, 41 insertions(+), 16 deletions(-)
 delete mode 100644 misc/mc/files/patch-vfs::extfs::uzip

(limited to 'misc/mc')

diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index cc78a4ec6cf9..8222d7e5c439 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -13,15 +13,22 @@ MASTER_SITE_SUBDIR=	stable/sources/mc
 
 MAINTAINER=	ports@FreeBSD.org
 
-LIB_DEPENDS=	intl.2:${PORTSDIR}/devel/gettext
+LIB_DEPENDS=	intl.4:${PORTSDIR}/devel/gettext
 BUILD_DEPENDS=	ispell:${PORTSDIR}/textproc/ispell
+.if !defined(WITHOUT_SLANG)
+LIB_DEPENDS=	slang.1:${PORTSDIR}/devel/libslang
+.endif
 
 USE_GMAKE=	yes
 USE_GNOMENG=	yes
 USE_GNOME=	glib12
 USE_REINPLACE=	yes
 GNU_CONFIGURE=	yes
+.if !defined(WITHOUT_SLANG)
+CONFIGURE_ARGS=	--with-slang --without-gnome
+.else
 CONFIGURE_ARGS=	--with-ncurses --without-gnome
+.endif
 CONFIGURE_ENV=	CPPFLAGS=-I${LOCALBASE}/include \
 		LDFLAGS="-L${LOCALBASE}/lib -lintl"
 CONFIGURE_TARGET=	--target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
@@ -32,6 +39,10 @@ post-patch:
 	@find ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} \
 		-e 's|\$$(libdir)/mc|\$$(datadir)/mc|g' \
 		-e 's|\$$(datadir)/locale|\$$(prefix)/share/locale|g'
+	@${REINPLACE_CMD} -e 's|DRAR=/usr/bin|DRAR=${LOCALBASE}/bin|' \
+		${WRKSRC}/vfs/extfs/urar.in
+	@${REINPLACE_CMD} -e 's|/usr/bin/\(.*\)zip|${LOCALBASE}/bin/\1zip|' \
+		${WRKSRC}/vfs/extfs/uzip 
 
 post-install:
 	@${LN} -sf mc ${PREFIX}/bin/midc
diff --git a/misc/mc/files/patch-aa b/misc/mc/files/patch-aa
index ddf766c5a2e3..ad601425d952 100644
--- a/misc/mc/files/patch-aa
+++ b/misc/mc/files/patch-aa
@@ -1,8 +1,5 @@
-
-$FreeBSD: /tmp/pcvs/ports/misc/mc/files/Attic/patch-aa,v 1.12 2002-08-05 21:26:26 fjoe Exp $
-
---- configure.orig	Fri Aug 24 11:05:06 2001
-+++ configure	Tue Sep 11 18:16:08 2001
+--- configure.orig	Fri Aug 24 15:05:06 2001
++++ configure	Tue Aug  6 16:45:45 2002
 @@ -2552,6 +2552,8 @@
    echo "$as_me:2552: result: no" >&5
  echo "${ECHO_T}no" >&6
@@ -12,3 +9,30 @@ $FreeBSD: /tmp/pcvs/ports/misc/mc/files/Attic/patch-aa,v 1.12 2002-08-05 21:26:2
  rm -f conftest*
  
  echo "$as_me:2557: checking for minix/config.h" >&5
+@@ -12971,7 +12973,7 @@
+   echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+   ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lslang  $LIBS"
++LIBS="-lslang -ltermcap $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line 12976 "configure"
+ #include "confdefs.h"
+@@ -13251,7 +13253,7 @@
+ #define HAVE_SYSTEM_SLANG 1
+ EOF
+ 
+-	    LSLANG="-lslang"
++	    LSLANG="-lslang -ltermcap"
+ 	    screen_manager="SLang (system-installed library)"
+ 	    echo "$as_me:13256: result: Using system installed SLang library" >&5
+ echo "${ECHO_T}Using system installed SLang library" >&6
+@@ -14223,7 +14225,7 @@
+ #define HAVE_SYSTEM_SLANG 1
+ EOF
+ 
+-	    LSLANG="-lslang"
++	    LSLANG="-lslang -ltermcap"
+ 	    screen_manager="SLang (system-installed library)"
+ 	    echo "$as_me:14228: result: Using system installed SLang library" >&5
+ echo "${ECHO_T}Using system installed SLang library" >&6
diff --git a/misc/mc/files/patch-vfs::extfs::uzip b/misc/mc/files/patch-vfs::extfs::uzip
deleted file mode 100644
index d18927146f8e..000000000000
--- a/misc/mc/files/patch-vfs::extfs::uzip
+++ /dev/null
@@ -1,10 +0,0 @@
---- vfs/extfs/uzip.orig	Wed Mar  7 18:34:21 2001
-+++ vfs/extfs/uzip	Fri Apr 20 12:42:02 2001
-@@ -17,5 +17,5 @@
- # Location of the zip program
--my $app_zip = '/usr/bin/zip';
-+my $app_zip = '/usr/local/bin/zip';
- # Location of the unzip program
--my $app_unzip = '/usr/bin/unzip';
-+my $app_unzip = '/usr/local/bin/unzip';
- # Set this to 1 if zipinfo (unzip -Z) is to be used (recommended), otherwise 0.
-- 
cgit v1.2.3