From c5a9970f43e813f57275b6c2ce6d3052998821c2 Mon Sep 17 00:00:00 2001
From: Maxim Sobolev <sobomax@FreeBSD.org>
Date: Thu, 14 Mar 2002 16:40:24 +0000
Subject: Manually invoke `${MAKE} patch' for Gnumeric, because puting it into
 BUILD_DEPEDS creates short circuit when make clean is invoked either for
 Gnumeric port or for Guppi port. Perhaps our bsd.port.mk should be fixed to
 avoid such problems.

Submitted by:	John Merryweather Cooper <john_m_cooper@yahoo.com>
---
 math/guppi/Makefile | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

(limited to 'math/guppi')

diff --git a/math/guppi/Makefile b/math/guppi/Makefile
index 5f77170e9c6a..fe7ed25159c2 100644
--- a/math/guppi/Makefile
+++ b/math/guppi/Makefile
@@ -15,7 +15,6 @@ DISTNAME=	Guppi-${PORTVERSION}
 
 MAINTAINER=	gnome@FreeBSD.org
 
-BUILD_DEPENDS=	/nonexistent:${PORTSDIR}/math/gnumeric:patch
 LIB_DEPENDS=	guile.9:${PORTSDIR}/lang/guile
 
 USE_X_PREFIX=	yes
@@ -31,6 +30,12 @@ CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include/libglade-1.
 CONFIGURE_TARGET=	--target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
 PLIST_SUB=	VERSION="${PORTVERSION}"
 
+# Can't use BUILD_DEPENDS, because then we have `short circuit' for
+# make clean - Gnumeric tries to clean-up Guppi, while Guppi in turn
+# tries to clean Gnumeric.
+post-extract:
+	@cd ${PORTSDIR}/math/gnumeric && ${MAKE} patch
+
 pre-patch:
 	@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
 		 s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-- 
cgit v1.2.3