From 3b84c52d0189805db778b367cae81410821c0c73 Mon Sep 17 00:00:00 2001
From: Renato Botelho <garga@FreeBSD.org>
Date: Fri, 24 Mar 2006 13:31:52 +0000
Subject: - Use PORTDOCS facility and clean a bit Makefile and pkg-plist

---
 mail/qmail/Makefile  | 33 ++++++++++------------
 mail/qmail/pkg-plist | 77 ++--------------------------------------------------
 2 files changed, 17 insertions(+), 93 deletions(-)

(limited to 'mail/qmail')

diff --git a/mail/qmail/Makefile b/mail/qmail/Makefile
index fb19718f2b93..f8294c93db72 100644
--- a/mail/qmail/Makefile
+++ b/mail/qmail/Makefile
@@ -203,12 +203,6 @@ ALL_TARGET+=	${EXTRA_MAN8}
 MAN8+=		${EXTRA_MAN8}
 .endif
 
-.if defined(SLAVE_SPAMCONTROL)
-PLIST_SUB+=	README_AUTH=""
-.else
-PLIST_SUB+=	README_AUTH="@comment "
-.endif
-
 .if defined(SLAVE_LDAP)
 PKGMESSAGE_SUFFIX=	ldap
 PLIST_SUB+=	LDAP="" NOT_LDAP="@comment "
@@ -224,9 +218,6 @@ PLIST_SUB+=	SPAMCONTROL="@comment "
 
 .if defined(SLAVE_TLS)
 PKGMESSAGE_SUFFIX=	tls
-PLIST_SUB+=	TLS=""
-.else
-PLIST_SUB+=	TLS="@comment "
 .endif
 
 .if defined(PKGMESSAGE_SUFFIX)
@@ -248,6 +239,8 @@ SUB_FILES+=	pkg-message
 
 CSH?=	/bin/csh
 
+PORTDOCS=	*
+
 DOCFILES+=	${WRKSRC}/BLURB ${WRKSRC}/BLURB2 ${WRKSRC}/BLURB3 \
 		${WRKSRC}/BLURB4 ${WRKSRC}/INTERNALS ${WRKSRC}/SECURITY \
 		${WRKSRC}/THOUGHTS ${FILESDIR}/PORT_NOTES \
@@ -612,7 +605,7 @@ do-install:
 		${SED} -f ${WRKDIR}/bootfiles.sed ${FILESDIR}/$i > ${WRKDIR}/${i} ; \
 	fi
 .endfor
-	@${MKDIR} ${DOCSDIR} ${PREFIX}/configure
+	@${MKDIR} ${PREFIX}/configure
 	@cd ${WRKSRC} ; ./install
 	${INSTALL_PROGRAM} ${CONFIGUREPROGS} ${PREFIX}/configure
 	${INSTALL_SCRIPT} ${CONFIGUREFILES} ${PREFIX}/configure
@@ -626,7 +619,18 @@ do-install:
 . endfor
 .endfor
 .if !defined(NOPORTDOCS)
-	${INSTALL_DATA} ${DOCFILES} ${DOCSDIR}
+	@${MKDIR} ${DOCSDIR}
+	@for doc in ${DOCFILES}; do \
+		${ECHO_CMD} "${INSTALL_DATA} $${doc} ${DOCSDIR}"; \
+		${INSTALL_DATA} $${doc} ${DOCSDIR}; \
+	done
+. if defined(PACKAGE_BUILDING)
+	@${ECHO_CMD} "FreeBSD Binary package qmail installation" \
+		> ${DOCSDIR}/SYSDEPS
+. else
+	@cd ${WRKSRC} && ${CAT} `${CAT} SYSDEPS` \
+		> ${DOCSDIR}/SYSDEPS
+. endif
 .endif
 	@${MKDIR} ${PREFIX}/scripts
 	${INSTALL_SCRIPT} ${FILESDIR}/mkaliasdir ${PREFIX}/scripts
@@ -634,13 +638,6 @@ do-install:
 .for script in ${SCRIPTS}
 	${INSTALL_SCRIPT} ${WRKDIR}/scripts/${script} ${PREFIX}/scripts
 .endfor
-.if defined(PACKAGE_BUILDING)
-	@${ECHO_CMD} "FreeBSD Binary package qmail installation" \
-		> ${DOCSDIR}/SYSDEPS
-.else
-	@cd ${WRKSRC} && ${CAT} `${CAT} SYSDEPS` \
-		> ${DOCSDIR}/SYSDEPS
-.endif
 	@${SETENV} PKG_PREFIX="${PREFIX}" ${CSH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
 	@${ECHO_CMD}
 	@${CAT} ${PKGMESSAGE}
diff --git a/mail/qmail/pkg-plist b/mail/qmail/pkg-plist
index eccaf32c2698..f02516d24e61 100644
--- a/mail/qmail/pkg-plist
+++ b/mail/qmail/pkg-plist
@@ -106,79 +106,6 @@ scripts/mkaliasdir
 %%SPAMCONTROL%%scripts/qmail-pwd2recipients
 %%SPAMCONTROL%%scripts/qmail-users2recipients
 %%SPAMCONTROL%%scripts/qmail-vpopmail2recipients
-%%PORTDOCS%%%%DOCSDIR%%/BLURB
-%%PORTDOCS%%%%DOCSDIR%%/BLURB2
-%%PORTDOCS%%%%DOCSDIR%%/BLURB3
-%%PORTDOCS%%%%DOCSDIR%%/BLURB4
-%%LDAP%%%%PORTDOCS%%%%DOCSDIR%%/EXTTODO
-%%PORTDOCS%%%%DOCSDIR%%/FAQ
-%%SPAMCONTROL%%%%PORTDOCS%%%%DOCSDIR%%/FILES.spamcontrol
-%%SPAMCONTROL%%%%PORTDOCS%%%%DOCSDIR%%/HISTORY.spamcontrol
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL.alias
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL.ctl
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL.ids
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL.maildir
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL.mbox
-%%SPAMCONTROL%%%%PORTDOCS%%%%DOCSDIR%%/INSTALL.spamcontrol
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL.vsm
-%%PORTDOCS%%%%DOCSDIR%%/INTERNALS
-%%SPAMCONTROL%%%%PORTDOCS%%%%DOCSDIR%%/LICENSE.spamcontrol
-%%SPAMCONTROL%%%%PORTDOCS%%%%DOCSDIR%%/LOGGING.spamcontrol
-%%SPAMCONTROL%%%%PORTDOCS%%%%DOCSDIR%%/Makefile.djbdns
-%%PORTDOCS%%%%DOCSDIR%%/PIC.local2alias
-%%PORTDOCS%%%%DOCSDIR%%/PIC.local2ext
-%%PORTDOCS%%%%DOCSDIR%%/PIC.local2local
-%%PORTDOCS%%%%DOCSDIR%%/PIC.local2rem
-%%PORTDOCS%%%%DOCSDIR%%/PIC.local2virt
-%%PORTDOCS%%%%DOCSDIR%%/PIC.nullclient
-%%PORTDOCS%%%%DOCSDIR%%/PIC.relaybad
-%%PORTDOCS%%%%DOCSDIR%%/PIC.relaygood
-%%PORTDOCS%%%%DOCSDIR%%/PIC.rem2local
-%%LDAP%%%%PORTDOCS%%%%DOCSDIR%%/POPBEFORESMTP
-%%PORTDOCS%%%%DOCSDIR%%/PORT_NOTES
-%%PORTDOCS%%%%DOCSDIR%%/PORT_NOTES_FreeBSD_40-RELEASE
-%%LDAP%%%%PORTDOCS%%%%DOCSDIR%%/QLDAPGROUP
-%%LDAP%%%%PORTDOCS%%%%DOCSDIR%%/QLDAPINSTALL
-%%LDAP%%%%PORTDOCS%%%%DOCSDIR%%/QLDAPNEWS
-%%LDAP%%%%PORTDOCS%%%%DOCSDIR%%/QLDAPPICTURE
-%%LDAP%%%%PORTDOCS%%%%DOCSDIR%%/QLDAPTODO
-%%README_AUTH%%%%PORTDOCS%%%%DOCSDIR%%/README.auth
-%%SPAMCONTROL%%%%PORTDOCS%%%%DOCSDIR%%/README.bigtodo
-%%SPAMCONTROL%%%%PORTDOCS%%%%DOCSDIR%%/README.bouncemaxbytes
-%%SPAMCONTROL%%%%PORTDOCS%%%%DOCSDIR%%/README.djbdns
-%%SPAMCONTROL%%%%PORTDOCS%%%%DOCSDIR%%/README.doublebouncetrim
-%%SPAMCONTROL%%%%PORTDOCS%%%%DOCSDIR%%/README.moreipme
-%%SPAMCONTROL%%%%PORTDOCS%%%%DOCSDIR%%/README.qmailqueue
-%%SPAMCONTROL%%%%PORTDOCS%%%%DOCSDIR%%/README.recipients
-%%SPAMCONTROL%%%%PORTDOCS%%%%DOCSDIR%%/README.spamcontrol
-%%SPAMCONTROL%%%%PORTDOCS%%%%DOCSDIR%%/README.wildmat
-%%SPAMCONTROL%%%%PORTDOCS%%%%DOCSDIR%%/README_spamcontrol.html
-%%SPAMCONTROL%%%%PORTDOCS%%%%DOCSDIR%%/RELEASE_22.spamcontrol
-%%SPAMCONTROL%%%%PORTDOCS%%%%DOCSDIR%%/RELEASE_23.spamcontrol
-%%PORTDOCS%%%%DOCSDIR%%/REMOVE.binmail
-%%PORTDOCS%%%%DOCSDIR%%/REMOVE.sendmail
-%%PORTDOCS%%%%DOCSDIR%%/SECURITY
-%%PORTDOCS%%%%DOCSDIR%%/SENDMAIL
-%%SPAMCONTROL%%%%PORTDOCS%%%%DOCSDIR%%/SMTPREPLY.spamcontrol
-%%PORTDOCS%%%%DOCSDIR%%/SYSDEPS
-%%PORTDOCS%%%%DOCSDIR%%/TEST.deliver
-%%PORTDOCS%%%%DOCSDIR%%/TEST.receive
-%%SPAMCONTROL%%%%PORTDOCS%%%%DOCSDIR%%/TESTING.spamcontrol
-%%PORTDOCS%%%%DOCSDIR%%/THOUGHTS
-%%TLS%%%%PORTDOCS%%%%DOCSDIR%%/TLS.readme
-%%SPAMCONTROL%%%%PORTDOCS%%%%DOCSDIR%%/TODO.spamcontrol
-%%PORTDOCS%%%%DOCSDIR%%/UPGRADE
-%%SPAMCONTROL%%%%PORTDOCS%%%%DOCSDIR%%/badloadertypes
-%%SPAMCONTROL%%%%PORTDOCS%%%%DOCSDIR%%/badmailfrom
-%%SPAMCONTROL%%%%PORTDOCS%%%%DOCSDIR%%/badmimetypes
-%%SPAMCONTROL%%%%PORTDOCS%%%%DOCSDIR%%/badrcptto
-%%SPAMCONTROL%%%%PORTDOCS%%%%DOCSDIR%%/conf-spamcontrol
-%%SPAMCONTROL%%%%PORTDOCS%%%%DOCSDIR%%/install_spamcontrol.sh
-%%PORTDOCS%%%%DOCSDIR%%/mailer.conf.sample
-%%LDAP%%%%PORTDOCS%%%%DOCSDIR%%/qmail.schema
-%%SPAMCONTROL%%%%PORTDOCS%%%%DOCSDIR%%/tarpitcount
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
 @dirrm bin
 %%LDAP%%@dirrm boot/qmail/env
 %%LDAP%%@dirrm boot/qmail/log
@@ -216,6 +143,6 @@ scripts/mkaliasdir
 @dirrm boot
 @dirrm configure
 @dirrm scripts
-@unexec echo "1) If you are permanently removing qmail, you should also ``rm -Rf ${PKG_PREFIX}/alias ${PKG_PREFIX}/control ${PKG_PREFIX}/queue ${PKG_PREFIX}/users'' and remove the qmail users/groups." | /usr/bin/fmt
+@unexec echo "1) If you are permanently removing qmail, you should also 'rm -rf ${PKG_PREFIX}' and remove the qmail users/groups." | /usr/bin/fmt
 @unexec echo "2) Do not forget to reconfigure your /etc/mail/mailer.conf to use your older MTA, or reconfigure your old MTA binaries if you decided to replace them." | /usr/bin/fmt
-@unexec echo "3) Do not forget to enable sendmail as your default MTA if you have to. You can do it just executing 'echo sendmail_enable=\"YES\" >> /etc/rc.conf" | /usr/bin/fmt
+@unexec echo "3) Do not forget to enable sendmail as your default MTA if you have to. You can do it just executing 'echo sendmail_enable=\"YES\"' >> /etc/rc.conf" | /usr/bin/fmt
-- 
cgit v1.2.3