From 96bc8048c3217bb231f2f30eadeb628134b557f5 Mon Sep 17 00:00:00 2001
From: Satoshi Asami <asami@FreeBSD.org>
Date: Sat, 14 Nov 1998 09:43:39 +0000
Subject: Use bsd.port.{pre,post}.mk to move PORTOBJFORMAT to front, or change
 shell loops to make loops.  Use EXTRA_PKG_FLAGS to add install scripts
 instead of adding it to PKG_FLAGS after bsd.port.mk.

---
 japanese/tcl76/Makefile | 12 +++++++-----
 1 file changed, 7 insertions(+), 5 deletions(-)

(limited to 'japanese/tcl76')

diff --git a/japanese/tcl76/Makefile b/japanese/tcl76/Makefile
index 423689c01767..39741beb46d7 100644
--- a/japanese/tcl76/Makefile
+++ b/japanese/tcl76/Makefile
@@ -3,7 +3,7 @@
 # Date created:		11 March 1997
 # Whom:			taguchi@tohoku.iij.ad.jp
 #
-# $Id: Makefile,v 1.6 1998/09/26 12:45:10 kuriyama Exp $
+# $Id: Makefile,v 1.7 1998/09/28 09:53:08 asami Exp $
 #
 
 DISTNAME=	tcl7.6p2
@@ -29,6 +29,8 @@ PATCH_DIST_ARGS=	-d ${WRKDIR}/${DISTNAME} -E ${PATCH_DIST_STRIP}
 PATCH_DIST_ARGS=	-d ${WRKDIR}/${DISTNAME} --forward --quiet -E ${PATCH_DIST_STRIP}
 .endif
 
+.include <bsd.port.pre.mk>
+
 post-extract:
 	@${MV} ${WRKDIR}/tcl7.6 ${WRKDIR}/${DISTNAME}
 
@@ -45,9 +47,9 @@ pre-install:
 
 post-install:
 	${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
-	if [ "${PORTOBJFORMAT}" = "aout" ]; then \
-		${LN} -sf libtcl76jp.so.1.0 ${PREFIX}/lib/libtcl76jp.so; \
-	fi
+.if ${PORTOBJFORMAT} == "aout" 
+	${LN} -sf libtcl76jp.so.1.0 ${PREFIX}/lib/libtcl76jp.so
+.endif
 
 test:
 	cd ${WRKSRC} && ${SETENV} PORTOBJFORMAT=${PORTOBJFORMAT} ${MAKE} test
@@ -55,4 +57,4 @@ test:
 install-man:
 	cd ${WRKSRC} && ${SETENV} PORTOBJFORMAT=${PORTOBJFORMAT} ${MAKE} install-man
 
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
-- 
cgit v1.2.3