From 6f9df5a38ec9ecc1b817733f86180ec416290b4d Mon Sep 17 00:00:00 2001
From: Michael Nottebrock <lofi@FreeBSD.org>
Date: Wed, 18 Feb 2004 12:33:12 +0000
Subject: Add dcraw, a decoder for RAW files from digital cameras.

PR: ports/62928
Submitted by:	Arjan van Leeuwen <avleeuwen@piwebs.com>
---
 graphics/dcraw/Makefile            | 23 +++++++++++++++++++++++
 graphics/dcraw/distinfo            |  2 ++
 graphics/dcraw/files/patch-dcraw.c | 10 ++++++++++
 graphics/dcraw/pkg-descr           | 11 +++++++++++
 4 files changed, 46 insertions(+)
 create mode 100644 graphics/dcraw/Makefile
 create mode 100644 graphics/dcraw/distinfo
 create mode 100644 graphics/dcraw/files/patch-dcraw.c
 create mode 100644 graphics/dcraw/pkg-descr

(limited to 'graphics/dcraw')

diff --git a/graphics/dcraw/Makefile b/graphics/dcraw/Makefile
new file mode 100644
index 000000000000..dd6b37fb8a54
--- /dev/null
+++ b/graphics/dcraw/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for:	dcraw
+# Date created: 			14 February 2004
+# Whom:					Arjan van Leeuwen <avleeuwen@piwebs.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	dcraw
+PORTVERSION=	1.166
+CATEGORIES=	graphics
+MASTER_SITES=	http://people.fruitsalad.org/avleeuwen/distfiles/${PORTNAME}/
+
+MAINTAINER=	avleeuwen@piwebs.com
+COMMENT=	Decoder for RAW files from digital cameras
+
+PLIST_FILES=	bin/dcraw
+
+.include <bsd.port.pre.mk>
+
+do-install::
+	${INSTALL_PROGRAM} ${WRKSRC}/dcraw ${PREFIX}/bin
+
+.include <bsd.port.post.mk>
diff --git a/graphics/dcraw/distinfo b/graphics/dcraw/distinfo
new file mode 100644
index 000000000000..269bafd8471b
--- /dev/null
+++ b/graphics/dcraw/distinfo
@@ -0,0 +1,2 @@
+MD5 (dcraw-1.166.tar.gz) = 370ffb53fa113410171d4f72e93a3acc
+SIZE (dcraw-1.166.tar.gz) = 40578
diff --git a/graphics/dcraw/files/patch-dcraw.c b/graphics/dcraw/files/patch-dcraw.c
new file mode 100644
index 000000000000..084224233e89
--- /dev/null
+++ b/graphics/dcraw/files/patch-dcraw.c
@@ -0,0 +1,10 @@
+--- dcraw.c.orig	Tue Feb 17 10:58:29 2004
++++ dcraw.c	Tue Feb 17 10:59:27 2004
+@@ -53,7 +53,6 @@
+ #endif
+ 
+ typedef unsigned char uchar;
+-typedef unsigned short ushort;
+ 
+ /* Global Variables */
+ 
diff --git a/graphics/dcraw/pkg-descr b/graphics/dcraw/pkg-descr
new file mode 100644
index 000000000000..215905b1673b
--- /dev/null
+++ b/graphics/dcraw/pkg-descr
@@ -0,0 +1,11 @@
+dcraw is an ANSI C program that decodes any raw image from any digital camera 
+on any computer running any operating system. It's become a standard tool 
+within and without the Open Source world. It's small (about 3000 lines), 
+portable (standard C libraries only), free (both "gratis" and "libre"), and 
+when used skillfully, produces better-quality output than the tools provided by
+the camera vendor. 
+
+WWW: http://www.cybercom.net/~dcoffin/dcraw/
+
+- Arjan
+avleeuwen@piwebs.com
-- 
cgit v1.2.3