From 7a9b9cd9b928b10528d61b82643527cedc403f34 Mon Sep 17 00:00:00 2001
From: Jean-Marc Zucconi <jmz@FreeBSD.org>
Date: Thu, 21 Dec 2000 19:00:48 +0000
Subject: Upgrade to version 2.02 and change maintainer.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

PR:		ports/23533
Submitted by:	Göran Runfeldt <goranrunfeldt@home.se>
---
 games/xevil/Makefile          | 46 +++++++++++++++++++++++++----------
 games/xevil/distinfo          |  2 +-
 games/xevil/files/patch-aa    | 56 ++++++++++++++++++++++++++++---------------
 games/xevil/files/patch-ab    | 11 +++++++++
 games/xevil/files/patch-ac    | 11 +++++++++
 games/xevil/files/patch-ad    | 14 +++++++++++
 games/xevil/pkg-comment       |  2 +-
 games/xevil/pkg-descr         | 29 ++++++++++------------
 games/xevil/pkg-plist         | 14 +++++++----
 games/xevil/scripts/configure | 18 --------------
 10 files changed, 131 insertions(+), 72 deletions(-)
 create mode 100644 games/xevil/files/patch-ab
 create mode 100644 games/xevil/files/patch-ac
 create mode 100644 games/xevil/files/patch-ad
 delete mode 100644 games/xevil/scripts/configure

(limited to 'games/xevil')

diff --git a/games/xevil/Makefile b/games/xevil/Makefile
index b801f19c1d0e..4b92791f6274 100644
--- a/games/xevil/Makefile
+++ b/games/xevil/Makefile
@@ -1,22 +1,44 @@
-# New ports collection makefile for:    xevil
-# Date created:         6 May 1995
-# Whom:                 jmz
+# New ports collection makefile for:   xevil
+# Date created:        7 November 2000
+# Whom:    G�ran Runfeldt <goranrunfeldt@home.se>
 #
 # $FreeBSD$
 #
 
 PORTNAME=	xevil
-PORTVERSION=	1.5
+PORTVERSION=	2.02
 CATEGORIES=	games
-MASTER_SITES=	${MASTER_SITE_XCONTRIB}
-MASTER_SITE_SUBDIR=	games/${PORTNAME}${PORTVERSION}
-DISTFILES=	${PORTNAME}${PORTVERSION}.tar.Z
+MASTER_SITES=	ftp://ftp.xevil.com/stable/
+DISTNAME=	xevilsrc${PORTVERSION}
 
-MAINTAINER=	jmz@FreeBSD.org
+MAINTAINER=	goranrunfeldt@home.se
 
-USE_XLIB=	yes
-MAN6=		xevil.6
-MANCOMPRESSED=	yes
-NO_WRKSUBDIR=	yes
+USE_X_PREFIX=	yes
+USE_ZIP=	yes
+USE_XPM=	yes
+ALL_TARGET=	freebsd
+
+# I'm not sure if this should be here
+.if (${MACHINE} == "alpha")
+CFLAGS+="-DXEVIL_KEYSET=UIalpha"
+.endif
+
+pre-extract:
+	@${MKDIR} ${WRKDIR}/${DISTNAME}
+
+do-extract:
+	@unzip -aqo ${DISTDIR}/${DISTFILES} -d ${WRKSRC}
+
+post-extract:
+	@${MV} -f ${WRKDIR}/${DISTNAME}/makefile ${WRKDIR}/${DISTNAME}/Makefile
+
+do-install:
+	${INSTALL_PROGRAM} ${WRKSRC}/x11/FREEBSD/xevil ${PREFIX}/bin/xevil
+.if !defined(NOPORTDOCS)
+	${MKDIR} ${PREFIX}/share/doc/xevil/instructions
+	${INSTALL_DATA} ${WRKSRC}/readme.txt ${PREFIX}/share/doc/xevil
+	${INSTALL_DATA} ${WRKSRC}/instructions/* \
+	${PREFIX}/share/doc/xevil/instructions
+.endif
 
 .include <bsd.port.mk>
diff --git a/games/xevil/distinfo b/games/xevil/distinfo
index 93fdcc61de19..987cf5b5c627 100644
--- a/games/xevil/distinfo
+++ b/games/xevil/distinfo
@@ -1 +1 @@
-MD5 (xevil1.5.tar.Z) = e8f4e5922b71e9d0efdb9a851f53d11e
+MD5 (xevilsrc2.02.zip) = e1890f77144367e2e8bbf3609458b784
diff --git a/games/xevil/files/patch-aa b/games/xevil/files/patch-aa
index eef6d10a598f..ea4cd3e46cbc 100644
--- a/games/xevil/files/patch-aa
+++ b/games/xevil/files/patch-aa
@@ -1,19 +1,37 @@
-*** utils.h~	Mon Jul 24 22:22:34 1995
---- utils.h	Thu Sep 14 04:28:35 1995
-***************
-*** 54,60 ****
-  
-  
-  // Defines
-! #define MSEC_PER_CLOCK (1.0e3 / CLOCKS_PER_SEC) 
-  
-  #ifndef max
-  #define max(a,b)               (a<b ? b : a)
---- 54,60 ----
-  
-  
-  // Defines
-! #define MSEC_PER_CLOCK 8 // (1.0e3 / CLOCKS_PER_SEC) 
-  
-  #ifndef max
-  #define max(a,b)               (a<b ? b : a)
+--- config.mk.orig	Wed Jan 19 14:19:04 2000
++++ config.mk	Thu Dec 21 19:40:33 2000
+@@ -34,12 +34,12 @@
+ # You can add -DNDEBUG to speed up a release build by removing the assert() 
+ # calls.  But, on a really obscure Linux machine, this caused Xlib to blow up 
+ # internally, so you do so at your own risk.
+-DEBUG_OPT   =   -O #-DNDEBUG
++DEBUG_OPT   =   -DNDEBUG
+ 
+ LINK_OPT    =	
+ 
+ # The string that will be used for making the packaged .tar.Z file.
+-VERSION     =   2.01
++VERSION     =   2.02
+ 
+ #SRC_DIR and WORK_DIR are only used for `make workdir`
+ SRC_DIR		= 	/mit/hardts/src/X/xevil1.4.9
+@@ -83,7 +83,9 @@
+ #### Attempt to guesss the host architecture using the HOSTYPE and hostype
+ # variables.  Then call self with the architecture name.
+ default:
+-	@if [ $${HOSTTYPE-bob} != bob ] ; then \
++	@if [ $${OPSYS-bob} != bob ]; then \
++		archit=$$OPSYS ; \
++	elif [ $${HOSTTYPE-bob} != bob ] ; then \
+ 		archit=$$HOSTTYPE ; \
+ 	elif [ $${hosttype-bob} != bob ] ; then \
+ 		archit=$$hosttype ; \
+@@ -162,7 +164,7 @@
+ # XEvil is all screwed up.
+ freebsd:
+ 	@$(MAKE) CC="c++" \
+-CFLAGS="-DUSE_RANDOM -DPROTECTED_IS_PUBLIC -DMSEC_PER_CLOCK=8 -DUNAME_USR_BIN" \
++CFLAGS="-DUSE_RANDOM -DUSE_UINT_NET_LENGTH -DUNAME_USR_BIN ${CFLAGS}" \
+ INCL_DIRS="-I/usr/X11R6/include" LIBS_DIRS="-L/usr/X11R6/lib" \
+ OBJ_DIR=$(DEPTH)/x11/FREEBSD PCKG_NAME="freebsd" \
+ LIBS="-lXpm -lX11 -lm" $(TARGETS)
diff --git a/games/xevil/files/patch-ab b/games/xevil/files/patch-ab
new file mode 100644
index 000000000000..4afdb165a17d
--- /dev/null
+++ b/games/xevil/files/patch-ab
@@ -0,0 +1,11 @@
+--- x11/ui.cpp~	Wed Jan 19 12:54:14 2000
++++ x11/ui.cpp	Thu Dec 21 19:41:38 2000
+@@ -1322,7 +1322,7 @@
+       
+       // Get font.  Use user-specified font if given.
+       // regular size font.
+-      char *theFont = fontName ? fontName : DEFAULT_FONT_NAME;
++      const char *theFont = fontName ? fontName : DEFAULT_FONT_NAME;
+       xvars.font[xvars.dpyMax] = 
+         XLoadQueryFont(xvars.dpy[xvars.dpyMax],theFont);
+       if (!xvars.font[xvars.dpyMax]) {
diff --git a/games/xevil/files/patch-ac b/games/xevil/files/patch-ac
new file mode 100644
index 000000000000..d15d837ad957
--- /dev/null
+++ b/games/xevil/files/patch-ac
@@ -0,0 +1,11 @@
+--- cmn/intel.cpp~	Wed Jan 19 12:54:34 2000
++++ cmn/intel.cpp	Thu Dec 21 19:42:34 2000
+@@ -1606,7 +1606,7 @@
+ Boolean Machine::weapon_current_is_drop_liftable(PhysicalP p) {
+   // This is a HACK, we should really make Lifter override 
+   // get_weapon_current(), etc.
+-  char *dummy;
++  const char *dummy;
+   ClassId classId = p->get_weapon_string(dummy);
+   if (classId == A_DropLiftable) {
+     return True;
diff --git a/games/xevil/files/patch-ad b/games/xevil/files/patch-ad
new file mode 100644
index 000000000000..3782a2529f40
--- /dev/null
+++ b/games/xevil/files/patch-ad
@@ -0,0 +1,14 @@
+--- Makefile~	Wed Jan 19 13:08:50 2000
++++ Makefile	Thu Dec 21 19:43:26 2000
+@@ -63,11 +63,6 @@
+ 
+ # Could also include serverping in the distribution
+ $(OBJ_DIR)/xevil$(VERSION).$(PCKG_NAME).tar.Z::
+-	cp readme.txt $(OBJ_DIR)
+-	cp gpl.txt $(OBJ_DIR)
+-	cp -r instructions $(OBJ_DIR)
+-	(cd $(OBJ_DIR); tar cf xevil$(VERSION).$(PCKG_NAME).tar xevil readme.txt gpl.txt instructions)
+-	(cd $(OBJ_DIR); compress -f xevil$(VERSION).$(PCKG_NAME).tar)
+ 
+ ## Make a distribution file.
+ dist:
diff --git a/games/xevil/pkg-comment b/games/xevil/pkg-comment
index 84c0520ef18f..9f5a1d9ceab6 100644
--- a/games/xevil/pkg-comment
+++ b/games/xevil/pkg-comment
@@ -1 +1 @@
-A side-view, fast-action, kill everything type of game
+A fast-action, networked, anti-social, kill-everything game
diff --git a/games/xevil/pkg-descr b/games/xevil/pkg-descr
index 6936ac6c31d8..53e44213136f 100644
--- a/games/xevil/pkg-descr
+++ b/games/xevil/pkg-descr
@@ -1,17 +1,14 @@
-INTRO:
-  Death, kill, maim.  XEvil is a side-view, fast-action, kill everything
-  type of game.  Play is against other human or computer players.  XEvil
-  is keyboard controlled with configurable controls.
+XEvil is a side-view, single or network-multiplayer, fast-action,
+kill-everything, game for Windows and UNIX.
 
-FEATURES:
-- Color/Black&White/Grey Scale
-- 0, 1, or 2 player.  A single player can play against machine players.
-  Multiple humans can play cooperatively against machine players or against
-  each other.  You can watch machine players kill each other.
-- Extreme violence.
-- Assortment of characters, weapons, and items.  E.g. ninja, alien, chainsaw,
-  flame-thrower, Altar-Of-Sin, and soul-swapper.
-- Keyboard controls can be configured with X resources or at runtime with the
-  graphical interface.
-- Game speed can be adjusted.
-- Different styles of game play: levels, kill-kill-kill, duel, training.
+You have sinned in life.  Now, you die and go to Hell.  XEvil is the
+contest that determines your fate in Hell for all eternity.  At the
+end of a game, you receive one of many possible rankings.  A poor
+player, for example, may spend the rest of time as "Satan's Earwax
+Remover", while a good one might achieve a prestigious title such as
+"VP of Hell Marketing" or even "Lead Software Engineer of Hell".
+
+The XEvil 2.X Instruction Manual is located in
+/usr/X11R6/share/doc/xevil/instructions
+
+WWW: http://www.xevil.com
diff --git a/games/xevil/pkg-plist b/games/xevil/pkg-plist
index 302156a4a302..37c46d82e5d4 100644
--- a/games/xevil/pkg-plist
+++ b/games/xevil/pkg-plist
@@ -1,6 +1,10 @@
 bin/xevil
-lib/app-defaults/XEvil.iris
-lib/app-defaults/XEvil.mac
-lib/app-defaults/XEvil.sun3
-lib/app-defaults/XEvil.sun4_sparc
-@unexec rmdir %D/lib/app-defaults 2>/dev/null || true
+share/doc/xevil/instructions/UNIXSetControls.gif
+share/doc/xevil/instructions/UNIXShowControls.gif
+share/doc/xevil/instructions/UNIXmenu.gif
+share/doc/xevil/instructions/instructions.html
+share/doc/xevil/instructions/keysdlg.gif
+share/doc/xevil/instructions/optionsdlg.gif
+share/doc/xevil/readme.txt
+@dirrm share/doc/xevil/instructions
+@dirrm share/doc/xevil
diff --git a/games/xevil/scripts/configure b/games/xevil/scripts/configure
deleted file mode 100644
index 93344e37cb01..000000000000
--- a/games/xevil/scripts/configure
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/bin/sh
-
-cd $WRKSRC || exit 1
-
-cat >> Makefile << END
-
-all: freebsd
-
-install:
-	cp xevil \$(PREFIX)/bin
-	mkdir -p \$(PREFIX)/lib/app-defaults
-	for f in iris mac sun3 sun4_sparc; do \
-	  cp app-defaults/XEvil.\$\$f \$(PREFIX)/lib/app-defaults/; done
-	gzip -9 <xevil.6 >\$(PREFIX)/man/man6/xevil.6.gz
-
-END
-
-exit 0
-- 
cgit v1.2.3