From e56a38c7b619477551ff845192c9fda3f3c7e08e Mon Sep 17 00:00:00 2001
From: Pav Lucistnik <pav@FreeBSD.org>
Date: Wed, 13 Jul 2005 11:46:09 +0000
Subject: Qonk is a small game I wrote to learn some SDL basics. The game is a
 small build-and-conquer strategy game with very simple rules. A complete game
 only lasts for a few minutes and can be a fun break away from work or
 whatever you're doing.

PR:		ports/83293
Submitted by:	Alejandro Pulver <alejandro@varnet.biz>
---
 games/qonk/Makefile             | 49 +++++++++++++++++++++++++++++++++++++++++
 games/qonk/distinfo             |  2 ++
 games/qonk/files/patch-main.cpp | 10 +++++++++
 games/qonk/pkg-descr            | 21 ++++++++++++++++++
 games/qonk/pkg-plist            |  3 +++
 5 files changed, 85 insertions(+)
 create mode 100644 games/qonk/Makefile
 create mode 100644 games/qonk/distinfo
 create mode 100644 games/qonk/files/patch-main.cpp
 create mode 100644 games/qonk/pkg-descr
 create mode 100644 games/qonk/pkg-plist

(limited to 'games/qonk')

diff --git a/games/qonk/Makefile b/games/qonk/Makefile
new file mode 100644
index 000000000000..f4d64589065b
--- /dev/null
+++ b/games/qonk/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for:	qonk
+# Date created:				10 Jul 2005
+# Whom:					Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	qonk
+PORTVERSION=	0.0.1
+CATEGORIES=	games
+MASTER_SITES=	http://anthony.liekens.net/pub/files/
+
+MAINTAINER=	alejandro@varnet.biz
+COMMENT=	Small build and conquer strategy game
+
+USE_GMAKE=	yes
+USE_SDL=	gfx sdl ttf
+USE_REINPLACE=	yes
+
+OPTIONS=	OPTIMIZED_CFLAGS "Enable compilation optimizations" on
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+# Fix Makefile
+	@${REINPLACE_CMD} -e 's|g++|${CXX}| ; \
+			s|sdl-config|${SDL_CONFIG}| ; \
+			s|\(-O3\)|${CFLAGS} \1|' \
+				${WRKSRC}/${MAKEFILE}
+
+# Fix paths to ${DATADIR}
+	@${REINPLACE_CMD} -e 's|\(font\.ttf\)|${DATADIR}/\1|' \
+				${WRKSRC}/main.cpp ${WRKSRC}/messages.cpp
+
+# Enable/disable compilation optimizations
+.if !defined(WITH_OPTIMIZED_CFLAGS)
+	@${REINPLACE_CMD} -e 's|-O3||' \
+				${WRKSRC}/${MAKEFILE}
+.endif
+
+do-install:
+# Program
+	${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+# Data
+	${MKDIR} ${DATADIR}
+	${INSTALL_DATA} ${WRKSRC}/font.ttf ${DATADIR}
+
+.include <bsd.port.post.mk>
diff --git a/games/qonk/distinfo b/games/qonk/distinfo
new file mode 100644
index 000000000000..10e50582031c
--- /dev/null
+++ b/games/qonk/distinfo
@@ -0,0 +1,2 @@
+MD5 (qonk-0.0.1.tar.gz) = 149759ea51a6e129682d1a4fd80148e6
+SIZE (qonk-0.0.1.tar.gz) = 53976
diff --git a/games/qonk/files/patch-main.cpp b/games/qonk/files/patch-main.cpp
new file mode 100644
index 000000000000..e17394a72ab0
--- /dev/null
+++ b/games/qonk/files/patch-main.cpp
@@ -0,0 +1,10 @@
+--- main.cpp.orig	Wed Jul 13 13:40:12 2005
++++ main.cpp	Wed Jul 13 13:41:13 2005
+@@ -1,5 +1,7 @@
+ // Copyright 2005 by Anthony Liekens anthony@liekens.net
+ 
++#include <time.h>
++
+ #include "coordinate.h"
+ #include "stars.h"
+ #include "planets.h"
diff --git a/games/qonk/pkg-descr b/games/qonk/pkg-descr
new file mode 100644
index 000000000000..3b679c480f13
--- /dev/null
+++ b/games/qonk/pkg-descr
@@ -0,0 +1,21 @@
+Qonk is a small game I wrote to learn some SDL basics. The game is a small
+build-and-conquer strategy game with very simple rules. A complete game only
+lasts for a few minutes and can be a fun break away from work or whatever
+you're doing.
+
+The setting of the game is a solar system of planets. Your goal is to conquer
+all of the planets in the game by sending ships there. Planets that are under
+your control generate new ships. Simple AI players are playing against you. As
+you gain more experience throughout the game, more AI players have to be
+kicked out of bigger solar systems.
+
+The game is currently very much in beta. I published it however in order to
+see whether it compiles on other machines, and to see what reactions people
+had on its gameplay. The game engine itself is fully functional. A lot of
+things have to be added to make this a mature game (like menus and stuff), but
+since the engine itself works, Qonk is already very playable.
+
+WWW: http://anthony.liekens.net/index.php/Computers/Qonk
+
+- Alejandro Pulver
+alejandro@varnet.biz
diff --git a/games/qonk/pkg-plist b/games/qonk/pkg-plist
new file mode 100644
index 000000000000..7a8cd501f38b
--- /dev/null
+++ b/games/qonk/pkg-plist
@@ -0,0 +1,3 @@
+bin/qonk
+%%DATADIR%%/font.ttf
+@dirrm %%DATADIR%%
-- 
cgit v1.2.3