From 7bf49c7a440ef00b430d9b20e642ab53ca29181d Mon Sep 17 00:00:00 2001
From: Alejandro Pulver <alepulver@FreeBSD.org>
Date: Wed, 30 Jan 2008 03:28:45 +0000
Subject: QMars stands for Quicker Mars. It is a completely new implementation
 of a mars simulator, which is an interpreter of the Assembler-like language
 RedCode, which is used in CoreWars. QMars is heavily optimized to be as fast
 as possible.

WWW:	http://corewar.co.uk/ankerl/qmars.htm
---
 games/qmars/Makefile  | 35 +++++++++++++++++++++++++++++++++++
 games/qmars/distinfo  |  3 +++
 games/qmars/pkg-descr |  6 ++++++
 games/qmars/pkg-plist | 13 +++++++++++++
 4 files changed, 57 insertions(+)
 create mode 100644 games/qmars/Makefile
 create mode 100644 games/qmars/distinfo
 create mode 100644 games/qmars/pkg-descr
 create mode 100644 games/qmars/pkg-plist

(limited to 'games/qmars')

diff --git a/games/qmars/Makefile b/games/qmars/Makefile
new file mode 100644
index 000000000000..0dee8a59c3e2
--- /dev/null
+++ b/games/qmars/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for:	qmars
+# Date created:				2008-01-15
+# Whom:					alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME=	qmars
+PORTVERSION=	1.1
+CATEGORIES=	games
+MASTER_SITES=	http://corewar.co.uk/ankerl/
+DISTNAME=	${PORTNAME}_${PORTVERSION}
+
+MAINTAINER=	alepulver@FreeBSD.org
+COMMENT=	Quicker Mars is heavily optimized to be as fast as possible
+
+BUILD_DEPENDS=	makedepend:${PORTSDIR}/devel/makedepend
+
+USE_BZIP2=	yes
+REINPLACE_ARGS=	-i ""
+WRKSRC=		${WRKDIR}/${PORTNAME}
+
+post-patch:
+	@${REINPLACE_CMD} -e 's|g++|${CXX}|; s|CCFLAGS =|& ${CXXFLAGS}|' \
+		${WRKSRC}/${MAKEFILE}
+	@${REINPLACE_CMD} -e 's|\./||' ${WRKSRC}/bench.*
+	@${REINPLACE_CMD} -e 's|pmars|&-server|' ${WRKSRC}/bench.pmars
+
+do-install:
+	${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+	${MKDIR} ${DATADIR}
+	${INSTALL_SCRIPT} ${WRKSRC}/bench.* ${DATADIR}
+	${CP} -r ${WRKSRC}/warriors ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/games/qmars/distinfo b/games/qmars/distinfo
new file mode 100644
index 000000000000..75aaa7d82437
--- /dev/null
+++ b/games/qmars/distinfo
@@ -0,0 +1,3 @@
+MD5 (qmars_1.1.tar.bz2) = 2b2493562af8bf98a8934d0136dd1856
+SHA256 (qmars_1.1.tar.bz2) = ee5f9535bf0dba56b069232d9052ac90b7513f68047eb9e966c6901e920dcaaf
+SIZE (qmars_1.1.tar.bz2) = 16705
diff --git a/games/qmars/pkg-descr b/games/qmars/pkg-descr
new file mode 100644
index 000000000000..9f816386f1ef
--- /dev/null
+++ b/games/qmars/pkg-descr
@@ -0,0 +1,6 @@
+QMars stands for Quicker Mars. It is a completely new implementation of a mars
+simulator, which is an interpreter of the Assembler-like language RedCode,
+which is used in CoreWars. QMars is heavily optimized to be as fast as
+possible.
+
+WWW:	http://corewar.co.uk/ankerl/qmars.htm
diff --git a/games/qmars/pkg-plist b/games/qmars/pkg-plist
new file mode 100644
index 000000000000..bd4f702dad9f
--- /dev/null
+++ b/games/qmars/pkg-plist
@@ -0,0 +1,13 @@
+bin/qmars
+%%DATADIR%%/bench.exhaust
+%%DATADIR%%/bench.exmars
+%%DATADIR%%/bench.pmars
+%%DATADIR%%/bench.qmars
+%%DATADIR%%/warriors/evolver1090.rc
+%%DATADIR%%/warriors/fixed.rc
+%%DATADIR%%/warriors/jaguar.rc
+%%DATADIR%%/warriors/npaper2.rc
+%%DATADIR%%/warriors/sonofvain.rc
+%%DATADIR%%/warriors/stalker.rc
+@dirrm %%DATADIR%%/warriors
+@dirrm %%DATADIR%%
-- 
cgit v1.2.3