From 878d849f3d4796dabc6b091fd30a6a7354968d63 Mon Sep 17 00:00:00 2001
From: Martin Wilke <miwi@FreeBSD.org>
Date: Mon, 4 Jun 2007 14:20:47 +0000
Subject: - Update to 20070525

PR:		113016
Submitted by:	Raymond Pasco<ray@cultofray.net> (maintainer)
---
 games/alephone/Makefile                            |  2 +-
 games/alephone/distinfo                            |  6 +--
 ..._Files-Network-network_microphone_sdl_dummy.cpp | 63 ++++++++++++++++++++++
 3 files changed, 67 insertions(+), 4 deletions(-)
 create mode 100644 games/alephone/files/patch-Source_Files-Network-network_microphone_sdl_dummy.cpp

(limited to 'games/alephone')

diff --git a/games/alephone/Makefile b/games/alephone/Makefile
index 7e41c45ff849..9032b6381c6c 100644
--- a/games/alephone/Makefile
+++ b/games/alephone/Makefile
@@ -6,7 +6,7 @@
 #
 
 PORTNAME=	alephone
-PORTVERSION=	20061228
+PORTVERSION=	20070525
 PORTREVISION=	1
 CATEGORIES=	games
 MASTER_SITES=	${MASTER_SITE_SOURCEFORGE}
diff --git a/games/alephone/distinfo b/games/alephone/distinfo
index 64e934784015..99c5a8c9a87e 100644
--- a/games/alephone/distinfo
+++ b/games/alephone/distinfo
@@ -1,3 +1,3 @@
-MD5 (AlephOne-20061228.tar.bz2) = ee2107386104d151ea03317376ee1b9e
-SHA256 (AlephOne-20061228.tar.bz2) = c36aaa8a7db7b5a271ddf3e8c75103b162fd28c41dbd00a288378a8c1aab89c9
-SIZE (AlephOne-20061228.tar.bz2) = 6003628
+MD5 (AlephOne-20070525.tar.bz2) = 2e37050e62418e433dfc8f66010289e3
+SHA256 (AlephOne-20070525.tar.bz2) = 98f12f5c66b68d7af87db6c7f088ff3386abb9855dc46841f20f6871e80feca3
+SIZE (AlephOne-20070525.tar.bz2) = 6657074
diff --git a/games/alephone/files/patch-Source_Files-Network-network_microphone_sdl_dummy.cpp b/games/alephone/files/patch-Source_Files-Network-network_microphone_sdl_dummy.cpp
new file mode 100644
index 000000000000..03fb1194513e
--- /dev/null
+++ b/games/alephone/files/patch-Source_Files-Network-network_microphone_sdl_dummy.cpp
@@ -0,0 +1,63 @@
+diff -ruN Source_Files.orig/Network/network_microphone_sdl_dummy.cpp Source_Files/Network/network_microphone_sdl_dummy.cpp
+--- Source_Files.orig/Network/network_microphone_sdl_dummy.cpp	Wed Dec 31 19:00:00 1969
++++ Source_Files/Network/network_microphone_sdl_dummy.cpp	Thu May 31 21:30:37 2007
+@@ -0,0 +1,59 @@
++/*
++ *  network_microphone_sdl_dummy.cpp
++ *  created for Marathon: Aleph One <http://source.bungie.org/>
++
++	Copyright (C) 2002 and beyond by Woody Zenfell, III
++	and the "Aleph One" developers.
++ 
++	This program is free software; you can redistribute it and/or modify
++	it under the terms of the GNU General Public License as published by
++	the Free Software Foundation; either version 2 of the License, or
++	(at your option) any later version.
++
++	This program is distributed in the hope that it will be useful,
++	but WITHOUT ANY WARRANTY; without even the implied warranty of
++	MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
++	GNU General Public License for more details.
++
++	This license is contained in the file "COPYING",
++	which is included with this source code; it is available online at
++	http://www.gnu.org/licenses/gpl.html
++
++ *  The code in this file is licensed to you under the GNU GPL.  As the copyright holder,
++ *  however, I reserve the right to use this code as I see fit, without being bound by the
++ *  GPL's terms.  This exemption is not intended to apply to modified versions of this file -
++ *  if I were to use a modified version, I would be a licensee of whomever modified it, and
++ *  thus must observe the GPL terms.
++ *
++ *  Dummy implementation of SDL-style network microphone.
++ *  Does nothing except satisfy the linker (and admit to anyone interested it's a poseur).
++ *
++ *  Created by woody March 9, 2002.
++ */
++
++void
++open_network_microphone() {
++    // Nothing
++}
++
++void
++close_network_microphone() {
++    // Nothing
++}
++
++void
++set_network_microphone_state(bool inActive) {
++    // Nothing
++    (void) (inActive);
++}
++
++bool
++is_network_microphone_implemented() {
++    // No!  You'll get nothing useful from us!
++    return false;
++}
++
++void
++network_microphone_idle_proc() {
++    // Nothing
++}
-- 
cgit v1.2.3