From 8a28463f99c253302bc820365a8011108898626c Mon Sep 17 00:00:00 2001
From: Oliver Eikemeier <eik@FreeBSD.org>
Date: Wed, 18 Aug 2004 22:59:35 +0000
Subject: - make gettext a build dependency - add a WITHOUT_NLS knob

Requested by:	many
---
 devel/popt/Makefile                |  36 ++++++---
 devel/popt/files/patch-Makefile.in |  37 +++++++++
 devel/popt/files/patch-test3.c     |  11 +++
 devel/popt/pkg-descr               |   4 +-
 devel/popt/pkg-plist               | 162 +++++++++++++++++--------------------
 5 files changed, 149 insertions(+), 101 deletions(-)
 create mode 100644 devel/popt/files/patch-Makefile.in
 create mode 100644 devel/popt/files/patch-test3.c

(limited to 'devel/popt')

diff --git a/devel/popt/Makefile b/devel/popt/Makefile
index 608a29fbcb88..74bc83dcd003 100644
--- a/devel/popt/Makefile
+++ b/devel/popt/Makefile
@@ -8,27 +8,39 @@
 PORTNAME=	popt
 PORTVERSION=	1.7
 CATEGORIES=	devel
-MASTER_SITES=	ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.1.x/ \
-		ftp://ftp.mirror.ac.uk/sites/ftp.rpm.org/pub/rpm/dist/rpm-4.1.x/
+MASTER_SITES=	ftp://ftp.rpm.org/pub/rpm/dist/%SUBDIR%/ \
+		http://rpmfind.net/linux/rpm.org/rpm/dist/%SUBDIR%/ \
+		ftp://ftp.mirror.ac.uk/sites/ftp.rpm.org/pub/rpm/dist/%SUBDIR%/ \
+		http://gd.tuwien.ac.at/utils/rpm.org/dist/%SUBDIR%/ \
+		ftp://sunsite.cnlab-switch.ch/mirror/rpm/dist/%SUBDIR%/ \
+		ftp://ftp.sunfreeware.com/pub/freeware/SOURCES/
+MASTER_SITE_SUBDIR=	rpm-4.1.x
 
 MAINTAINER=	eik@FreeBSD.org
 COMMENT=	A getopt(3) like library with a number of enhancements, from Redhat
 
-USE_GETTEXT=	yes
-USE_INC_LIBTOOL_VER=	13
+BUILD_DEPENDS=	xgettext:${PORTSDIR}/devel/gettext
+
+USE_LIBTOOL_VER=	15
 USE_REINPLACE=	yes
 INSTALLS_SHLIB=	yes
+
+MAN3=		popt.3
+
 CONFIGURE_ARGS=	--with-libiconv-prefix=${LOCALBASE} \
 		--program-prefix=""
-CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include" \
-		LIBS="-L${LOCALBASE}/lib"
 
-MAN3=		popt.3
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+=	NLS="@comment "
+.else
+USE_GETTEXT=	yes
+PLIST_SUB+=	NLS=""
+.endif
 
-post-patch:
-# avoid installing both charset.alias and locale.alias which conflict
-# with libiconv
-	@${REINPLACE_CMD} -E -e 's|(SUBDIRS[[:space:]]+=.*)intl|\1|' \
-		${WRKSRC}/Makefile.in
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include" \
+		LDFLAGS="-L${LOCALBASE}/lib"
 
 .include <bsd.port.mk>
diff --git a/devel/popt/files/patch-Makefile.in b/devel/popt/files/patch-Makefile.in
new file mode 100644
index 000000000000..9b7c8b3d86bd
--- /dev/null
+++ b/devel/popt/files/patch-Makefile.in
@@ -0,0 +1,37 @@
+--- Makefile.in.orig	Sat Aug 31 15:22:18 2002
++++ Makefile.in	Sat Jun 26 22:12:19 2004
+@@ -124,7 +124,7 @@
+ 	popt.ps
+ 
+ 
+-SUBDIRS = intl po
++SUBDIRS = po
+ 
+ INCLUDES = -I. -I$(top_srcdir)
+ 
+@@ -133,13 +133,13 @@
+ noinst_PROGRAMS = test1 test2 test3
+ test1_SOURCES = test1.c
+ test1_LDFLAGS = -all-static
+-test1_LDADD = $(lib_LTLIBRARIES)
++test1_LDADD = $(lib_LTLIBRARIES) $(LTLIBICONV)
+ test2_SOURCES = test2.c
+ test2_LDFLAGS = -all-static
+-test2_LDADD = $(lib_LTLIBRARIES)
++test2_LDADD = $(lib_LTLIBRARIES) $(LTLIBICONV)
+ test3_SOURCES = test3.c
+ test3_LDFLAGS = -all-static
+-test3_LDADD = $(lib_LTLIBRARIES)
++test3_LDADD = $(lib_LTLIBRARIES) # $(LTLIBICONV)
+ 
+ noinst_SCRIPTS = testit.sh
+ 
+@@ -164,7 +164,7 @@
+ LTLIBRARIES = $(lib_LTLIBRARIES)
+ 
+ libpopt_la_LDFLAGS =
+-libpopt_la_LIBADD =
++libpopt_la_LIBADD = $(LTLIBINTL)
+ am_libpopt_la_OBJECTS = popt.lo findme.lo poptparse.lo poptconfig.lo \
+ 	popthelp.lo
+ libpopt_la_OBJECTS = $(am_libpopt_la_OBJECTS)
diff --git a/devel/popt/files/patch-test3.c b/devel/popt/files/patch-test3.c
new file mode 100644
index 000000000000..112590a3226e
--- /dev/null
+++ b/devel/popt/files/patch-test3.c
@@ -0,0 +1,11 @@
+--- test3.c.orig	Wed Aug 18 23:57:09 2004
++++ test3.c	Thu Aug 19 00:01:27 2004
+@@ -9,7 +9,7 @@
+ int main (int argc, char **argv) {
+     char *out;
+     int newargc, j, f, ret;
+-    char **newargv;
++    const char **newargv;
+     FILE *fp;
+ 
+     if (argc == 1) {
diff --git a/devel/popt/pkg-descr b/devel/popt/pkg-descr
index 6571ae2d9746..afe5d91eac06 100644
--- a/devel/popt/pkg-descr
+++ b/devel/popt/pkg-descr
@@ -1,5 +1,3 @@
-Quoted from README file:
-
 This is the popt command line option parsing library. While it is similiar
 to getopt(3), it contains a number of enhancements, including:
 
@@ -9,3 +7,5 @@ to getopt(3), it contains a number of enhancements, including:
         3) popt allows users to alias command line arguments
         4) popt provides convience functions for parsing strings
            into argv[] style arrays
+
+WWW: http://freshmeat.net/projects/popt/
diff --git a/devel/popt/pkg-plist b/devel/popt/pkg-plist
index de3a4a1ee47e..25609007112d 100644
--- a/devel/popt/pkg-plist
+++ b/devel/popt/pkg-plist
@@ -2,90 +2,78 @@ include/popt.h
 lib/libpopt.a
 lib/libpopt.so
 lib/libpopt.so.0
-share/locale/cs/LC_MESSAGES/popt.mo
-share/locale/da/LC_MESSAGES/popt.mo
-share/locale/de/LC_MESSAGES/popt.mo
-share/locale/es/LC_MESSAGES/popt.mo
-share/locale/eu_ES/LC_MESSAGES/popt.mo
-share/locale/fi/LC_MESSAGES/popt.mo
-share/locale/fr/LC_MESSAGES/popt.mo
-share/locale/gl/LC_MESSAGES/popt.mo
-share/locale/hu/LC_MESSAGES/popt.mo
-share/locale/id/LC_MESSAGES/popt.mo
-share/locale/is/LC_MESSAGES/popt.mo
-share/locale/it/LC_MESSAGES/popt.mo
-share/locale/ja/LC_MESSAGES/popt.mo
-share/locale/ko/LC_MESSAGES/popt.mo
-share/locale/no/LC_MESSAGES/popt.mo
-share/locale/pl/LC_MESSAGES/popt.mo
-share/locale/pt/LC_MESSAGES/popt.mo
-share/locale/pt_BR/LC_MESSAGES/popt.mo
-share/locale/ro/LC_MESSAGES/popt.mo
-share/locale/ru/LC_MESSAGES/popt.mo
-share/locale/sk/LC_MESSAGES/popt.mo
-share/locale/sl/LC_MESSAGES/popt.mo
-share/locale/sr/LC_MESSAGES/popt.mo
-share/locale/sv/LC_MESSAGES/popt.mo
-share/locale/tr/LC_MESSAGES/popt.mo
-share/locale/uk/LC_MESSAGES/popt.mo
-share/locale/wa/LC_MESSAGES/popt.mo
-share/locale/zh/LC_MESSAGES/popt.mo
-share/locale/zh_CN.GB2312/LC_MESSAGES/popt.mo
-@unexec rmdir %D/share/locale/zh_CN.GB2312/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/zh_CN.GB2312 2>/dev/null || true
-@unexec rmdir %D/share/locale/zh/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/zh 2>/dev/null || true
-@unexec rmdir %D/share/locale/wa/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/wa 2>/dev/null || true
-@unexec rmdir %D/share/locale/uk/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/uk 2>/dev/null || true
-@unexec rmdir %D/share/locale/tr/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/tr 2>/dev/null || true
-@unexec rmdir %D/share/locale/sv/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/sv 2>/dev/null || true
-@unexec rmdir %D/share/locale/sr/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/sr 2>/dev/null || true
-@unexec rmdir %D/share/locale/sl/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/sl 2>/dev/null || true
-@unexec rmdir %D/share/locale/sk/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/sk 2>/dev/null || true
-@unexec rmdir %D/share/locale/ru/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/ru 2>/dev/null || true
-@unexec rmdir %D/share/locale/ro/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/ro 2>/dev/null || true
-@unexec rmdir %D/share/locale/pt_BR/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/pt_BR 2>/dev/null || true
-@unexec rmdir %D/share/locale/pt/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/pt 2>/dev/null || true
-@unexec rmdir %D/share/locale/pl/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/pl 2>/dev/null || true
-@unexec rmdir %D/share/locale/no/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/no 2>/dev/null || true
-@unexec rmdir %D/share/locale/ko/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/ko 2>/dev/null || true
-@unexec rmdir %D/share/locale/ja/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/ja 2>/dev/null || true
-@unexec rmdir %D/share/locale/it/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/it 2>/dev/null || true
-@unexec rmdir %D/share/locale/is/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/is 2>/dev/null || true
-@unexec rmdir %D/share/locale/id/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/id 2>/dev/null || true
-@unexec rmdir %D/share/locale/hu/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/hu 2>/dev/null || true
-@unexec rmdir %D/share/locale/gl/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/gl 2>/dev/null || true
-@unexec rmdir %D/share/locale/fr/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/fr 2>/dev/null || true
-@unexec rmdir %D/share/locale/fi/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/fi 2>/dev/null || true
-@unexec rmdir %D/share/locale/eu_ES/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/eu_ES 2>/dev/null || true
-@unexec rmdir %D/share/locale/es/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/es 2>/dev/null || true
-@unexec rmdir %D/share/locale/de/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/de 2>/dev/null || true
-@unexec rmdir %D/share/locale/da/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/da 2>/dev/null || true
-@unexec rmdir %D/share/locale/cs/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/cs 2>/dev/null || true
+%%NLS%%share/locale/cs/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/da/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/de/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/es/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/eu_ES/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/id/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/is/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/it/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/no/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/wa/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/zh/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/zh_CN.GB2312/LC_MESSAGES/popt.mo
+%%NLS%%@unexec rmdir %D/share/locale/zh_CN.GB2312/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/zh_CN.GB2312 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/zh/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/zh 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/wa/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/wa 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/uk/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/uk 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/tr/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/sv/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/sr/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/sr 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/sl/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/sl 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/sk/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/sk 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/ru/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/ro/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/ro 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/pt_BR/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/pt/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/pt 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/pl/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/pl 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/no/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/no 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/ko/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/ko 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/ja/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/it/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/is/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/is 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/id/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/hu/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/gl/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/gl 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/fr/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/fi/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/fi 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/eu_ES/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/eu_ES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/es/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/de/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/da/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/cs/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/cs 2>/dev/null || true
-- 
cgit v1.2.3