From 95f3ba274d2af49b0c7aea2ea7d8b28429c1d6c4 Mon Sep 17 00:00:00 2001
From: "Lev A. Serebryakov" <lev@FreeBSD.org>
Date: Fri, 17 Oct 2003 12:51:20 +0000
Subject:   [1] Update to new version.   [2] Really don't install non-unique
 files. MANx too.

---
 devel/msp430-gcc3/Makefile                    |  6 ++----
 devel/msp430-gcc3/distinfo                    |  2 +-
 devel/msp430-gcc3/files/patch-gcc-Makefile.in | 30 +++++++++++++++++++++++++++
 3 files changed, 33 insertions(+), 5 deletions(-)
 create mode 100644 devel/msp430-gcc3/files/patch-gcc-Makefile.in

(limited to 'devel/msp430-gcc3')

diff --git a/devel/msp430-gcc3/Makefile b/devel/msp430-gcc3/Makefile
index 8793c0b0eaee..e6c7688b3df8 100644
--- a/devel/msp430-gcc3/Makefile
+++ b/devel/msp430-gcc3/Makefile
@@ -8,7 +8,6 @@
 PORTNAME=	gcc
 PORTVERSION=	${GCCVERSION}.${PATCHVERSION}
 PORTEPOCH=	2
-PORTREVISION=	1
 CATEGORIES=	devel
 MASTER_SITES=	${MASTER_SITE_SOURCEWARE} \
 		http://lev.serebryakov.spb.ru/download/msp430/:patches
@@ -26,7 +25,7 @@ RUN_DEPENDS=	${PKGNAMEPREFIX}as:${PORTSDIR}/devel/${PKGNAMEPREFIX}binutils \
 		${PKGNAMEPREFIX}ld:${PORTSDIR}/devel/${PKGNAMEPREFIX}binutils
 
 GCCVERSION=	3.2.3
-PATCHVERSION=	20031001
+PATCHVERSION=	20031015
 
 WRKSRC=		${WRKDIR}/${PORTNAME}-${GCCVERSION}
 
@@ -38,8 +37,7 @@ CONFIGURE_ARGS=	--target=${PKGNAMEPREFIX:S/-$//} \
 		--enable-languages=c --disable-nls
 MAKE_ENV=	PATH=${PREFIX}/bin:${PATH}
 LIBTOOLFILES=	configure gcc/configure
-MAN1=		${PKGNAMEPREFIX}gcc.1 cpp.1 gcov.1
-MAN7=		fsf-funding.7 gfdl.7 gpl.7
+MAN1=		${PKGNAMEPREFIX}gcc.1 ${PKGNAMEPREFIX}cpp.1 ${PKGNAMEPREFIX}gcov.1
 
 PLIST_SUB+=	PORTVERSION=${PORTVERSION} GCC_TARG=${PKGNAMEPREFIX:S/-$//} \
 		GCC_REV=${GCCVERSION}
diff --git a/devel/msp430-gcc3/distinfo b/devel/msp430-gcc3/distinfo
index d8933bf4e7cc..2b831f1e18ef 100644
--- a/devel/msp430-gcc3/distinfo
+++ b/devel/msp430-gcc3/distinfo
@@ -1,2 +1,2 @@
 MD5 (gcc-core-3.2.3.tar.bz2) = 66664a84b383ba8d68612cd89b9478b2
-MD5 (msp430-gcc-3.2.3.20031001.tar.bz2) = fcd2fa2cb9b4e81314b232e817a63e62
+MD5 (msp430-gcc-3.2.3.20031015.tar.bz2) = 5f7ee4d06f5286653c8fe8bfa9b2a169
diff --git a/devel/msp430-gcc3/files/patch-gcc-Makefile.in b/devel/msp430-gcc3/files/patch-gcc-Makefile.in
new file mode 100644
index 000000000000..98a721e599fd
--- /dev/null
+++ b/devel/msp430-gcc3/files/patch-gcc-Makefile.in
@@ -0,0 +1,30 @@
+--- gcc/Makefile.in.orig	Fri Oct 17 16:22:44 2003
++++ gcc/Makefile.in	Fri Oct 17 16:24:38 2003
+@@ -2685,21 +2685,12 @@
+ 	  $(INSTALL_DATA) $(docdir)/gcc.1 $(DESTDIR)$(man1dir)/$(GCC_INSTALL_NAME)$(man1ext); \
+ 	  chmod a-x $(DESTDIR)$(man1dir)/$(GCC_INSTALL_NAME)$(man1ext); \
+ 	fi
+-	-rm -f $(DESTDIR)$(man1dir)/cpp$(man1ext)
+-	-$(INSTALL_DATA) $(docdir)/cpp.1 $(DESTDIR)$(man1dir)/cpp$(man1ext)
+-	-chmod a-x $(DESTDIR)$(man1dir)/cpp$(man1ext)
+-	-rm -f $(DESTDIR)$(man1dir)/gcov$(man1ext)
+-	-$(INSTALL_DATA) $(docdir)/gcov.1 $(DESTDIR)$(man1dir)/gcov$(man1ext)
+-	-chmod a-x $(DESTDIR)$(man1dir)/gcov$(man1ext)
+-	-rm -f $(DESTDIR)$(man7dir)/fsf-funding$(man7ext)
+-	-$(INSTALL_DATA) $(docdir)/fsf-funding.7 $(DESTDIR)$(man7dir)/fsf-funding$(man7ext)
+-	-chmod a-x $(DESTDIR)$(man7dir)/fsf-funding$(man7ext)
+-	-rm -f $(DESTDIR)$(man7dir)/gfdl$(man7ext)
+-	-$(INSTALL_DATA) $(docdir)/gfdl.7 $(DESTDIR)$(man7dir)/gfdl$(man7ext)
+-	-chmod a-x $(DESTDIR)$(man7dir)/gfdl$(man7ext)
+-	-rm -f $(DESTDIR)$(man7dir)/gpl$(man7ext)
+-	-$(INSTALL_DATA) $(docdir)/gpl.7 $(DESTDIR)$(man7dir)/gpl$(man7ext)
+-	-chmod a-x $(DESTDIR)$(man7dir)/gpl$(man7ext)
++	-rm -f $(DESTDIR)$(man1dir)/$(CPP_CROSS_NAME)$(man1ext)
++	-$(INSTALL_DATA) $(docdir)/cpp.1 $(DESTDIR)$(man1dir)/$(CPP_CROSS_NAME)$(man1ext)
++	-chmod a-x $(DESTDIR)$(man1dir)/$(CPP_CROSS_NAME)$(man1ext)
++	-rm -f $(DESTDIR)$(man1dir)/$(GCOV_INSTALL_NAME)$(man1ext)
++	-$(INSTALL_DATA) $(docdir)/gcov.1 $(DESTDIR)$(man1dir)/$(GCOV_INSTALL_NAME)$(man1ext)
++	-chmod a-x $(DESTDIR)$(man1dir)/$(GCOV_INSTALL_NAME)$(man1ext)
+ 
+ # Install the library.
+ install-libgcc: libgcc.mk libgcc.a installdirs
-- 
cgit v1.2.3